diff mbox series

[1/1] package/squid: fix build with host gcc 10

Message ID 20240317110444.258643-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/squid: fix build with host gcc 10 | expand

Commit Message

Fabrice Fontaine March 17, 2024, 11:04 a.m. UTC
Pass -std=c++17 to fix the following build failure with host gcc 10
raised since bump to version 6.6 in commit
c13199c9326fa2daa574f08ec8fc063a48d0eb06:

/usr/bin/g++ -O2 -I/home/buildroot/instance-0/output-1/host/include -o cf_gen ./cf_gen.cc -I. -I../include/ -I../src
./cf_gen.cc: In function 'int main(int, char**)':
./cf_gen.cc:268:63: error: forming reference to void
  268 |                     auto &newEntry = entries.emplace_back(name);
      |                                                               ^

Fixes:
 - http://autobuild.buildroot.org/results/613fee008c77f8dbbe04df9a4ce4347e43de9ef9
 - https://bugs.buildroot.org/show_bug.cgi?id=15997

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/squid/squid.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Seiderer March 17, 2024, 12:25 p.m. UTC | #1
Hello Fabrice,

On Sun, 17 Mar 2024 12:04:44 +0100, Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Pass -std=c++17 to fix the following build failure with host gcc 10
> raised since bump to version 6.6 in commit
> c13199c9326fa2daa574f08ec8fc063a48d0eb06:
>
> /usr/bin/g++ -O2 -I/home/buildroot/instance-0/output-1/host/include -o cf_gen ./cf_gen.cc -I. -I../include/ -I../src
> ./cf_gen.cc: In function 'int main(int, char**)':
> ./cf_gen.cc:268:63: error: forming reference to void
>   268 |                     auto &newEntry = entries.emplace_back(name);
>       |                                                               ^
>
> Fixes:
>  - http://autobuild.buildroot.org/results/613fee008c77f8dbbe04df9a4ce4347e43de9ef9
>  - https://bugs.buildroot.org/show_bug.cgi?id=15997
>

Thanks for taking care, maybe add 'Reported-by:' and 'Suggested-by:'?

Regards,
Peter

> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/squid/squid.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/package/squid/squid.mk b/package/squid/squid.mk
> index 3a9edac71e..6a2b522336 100644
> --- a/package/squid/squid.mk
> +++ b/package/squid/squid.mk
> @@ -21,7 +21,7 @@ SQUID_CONF_ENV = \
>  	ac_cv_func_strnstr=no \
>  	ac_cv_have_squid=yes \
>  	BUILDCXX="$(HOSTCXX)" \
> -	BUILDCXXFLAGS="$(HOST_CXXFLAGS)"
> +	BUILDCXXFLAGS="$(HOST_CXXFLAGS) -std=c++17"
>  SQUID_CONF_OPTS = \
>  	--enable-async-io=8 \
>  	--enable-linux-netfilter \
Peter Korsgaard March 22, 2024, 7:54 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Pass -std=c++17 to fix the following build failure with host gcc 10
 > raised since bump to version 6.6 in commit
 > c13199c9326fa2daa574f08ec8fc063a48d0eb06:

 > /usr/bin/g++ -O2 -I/home/buildroot/instance-0/output-1/host/include -o cf_gen ./cf_gen.cc -I. -I../include/ -I../src
 > ./cf_gen.cc: In function 'int main(int, char**)':
 > ./cf_gen.cc:268:63: error: forming reference to void
 >   268 |                     auto &newEntry = entries.emplace_back(name);
 >       |                                                               ^

 > Fixes:
 >  - http://autobuild.buildroot.org/results/613fee008c77f8dbbe04df9a4ce4347e43de9ef9
 >  - https://bugs.buildroot.org/show_bug.cgi?id=15997

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2024.02.x, 2023.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/squid/squid.mk b/package/squid/squid.mk
index 3a9edac71e..6a2b522336 100644
--- a/package/squid/squid.mk
+++ b/package/squid/squid.mk
@@ -21,7 +21,7 @@  SQUID_CONF_ENV = \
 	ac_cv_func_strnstr=no \
 	ac_cv_have_squid=yes \
 	BUILDCXX="$(HOSTCXX)" \
-	BUILDCXXFLAGS="$(HOST_CXXFLAGS)"
+	BUILDCXXFLAGS="$(HOST_CXXFLAGS) -std=c++17"
 SQUID_CONF_OPTS = \
 	--enable-async-io=8 \
 	--enable-linux-netfilter \