diff mbox series

[1/1] package/osm2pgsql: only supports 64 bits

Message ID 20240317101420.62065-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/osm2pgsql: only supports 64 bits | expand

Commit Message

Fabrice Fontaine March 17, 2024, 10:14 a.m. UTC
osm2pgsql only supports 64 bits architectures since bump to version
1.10.0 in commit e056aeeca9cf8c00c6da62c39979ce6c55c92791 and
https://github.com/osm2pgsql-dev/osm2pgsql/commit/389904269a1b1f246641d203abadfcd5cebb97cc
resulting in the following build failure with arm:

CMake Error at CMakeLists.txt:20 (message):
  osm2pgsql needs a 64 bit architecture

Fixes: e056aeeca9cf8c00c6da62c39979ce6c55c92791
 - http://autobuild.buildroot.org/results/30c2675a732fd810c68dffbb6483f9cf8e4fcbf3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/osm2pgsql/Config.in | 13 +++++++++++++
 1 file changed, 13 insertions(+)

Comments

Arnout Vandecappelle March 17, 2024, 9:44 p.m. UTC | #1
On 17/03/2024 11:14, Fabrice Fontaine wrote:
> osm2pgsql only supports 64 bits architectures since bump to version
> 1.10.0 in commit e056aeeca9cf8c00c6da62c39979ce6c55c92791 and
> https://github.com/osm2pgsql-dev/osm2pgsql/commit/389904269a1b1f246641d203abadfcd5cebb97cc

  Based on that commit, it looks like it should depend on BR2_ARCH_IS_64 instead 
of having a list of architectures? If there's any reason to have an explicit 
list, please explain in the commit message.

  For now, changes requested.

  Regards,
  Arnout

> resulting in the following build failure with arm:
> 
> CMake Error at CMakeLists.txt:20 (message):
>    osm2pgsql needs a 64 bit architecture
> 
> Fixes: e056aeeca9cf8c00c6da62c39979ce6c55c92791
>   - http://autobuild.buildroot.org/results/30c2675a732fd810c68dffbb6483f9cf8e4fcbf3
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>   package/osm2pgsql/Config.in | 13 +++++++++++++
>   1 file changed, 13 insertions(+)
> 
> diff --git a/package/osm2pgsql/Config.in b/package/osm2pgsql/Config.in
> index c6a38f3180..b97b258c59 100644
> --- a/package/osm2pgsql/Config.in
> +++ b/package/osm2pgsql/Config.in
> @@ -1,5 +1,16 @@
> +config BR2_PACKAGE_OSM2PGSQL_ARCH_SUPPORTS
> +	bool
> +	default y if BR2_aarch64 || BR2_aarch64_be
> +	default y if BR2_x86_64
> +	default y if BR2_mips64 || BR2_mips64el
> +	default y if BR2_powerpc64 || BR2_powerpc64le
> +	default y if BR2_RISCV_64
> +	default y if BR2_sparc64
> +	default y if BR2_s390x
> +
>   config BR2_PACKAGE_OSM2PGSQL
>   	bool "osm2pgsql"
> +	depends on BR2_PACKAGE_OSM2PGSQL_ARCH_SUPPORTS
>   	depends on BR2_INSTALL_LIBSTDCPP # boost, libosmium, protozero
>   	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++14
>   	depends on BR2_TOOLCHAIN_HAS_THREADS # boost, libosmium
> @@ -24,9 +35,11 @@ config BR2_PACKAGE_OSM2PGSQL
>   	  https://osm2pgsql.org
>   
>   comment "osm2pgsql needs a toolchain w/ C++, wchar, threads, gcc >= 4.9"
> +	depends on BR2_PACKAGE_OSM2PGSQL_ARCH_SUPPORTS
>   	depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS
>   	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
>   		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || !BR2_TOOLCHAIN_HAS_THREADS
>   
>   comment "osm2pgsql needs a toolchain not affected by GCC bug 64735"
> +	depends on BR2_PACKAGE_OSM2PGSQL_ARCH_SUPPORTS
>   	depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735
diff mbox series

Patch

diff --git a/package/osm2pgsql/Config.in b/package/osm2pgsql/Config.in
index c6a38f3180..b97b258c59 100644
--- a/package/osm2pgsql/Config.in
+++ b/package/osm2pgsql/Config.in
@@ -1,5 +1,16 @@ 
+config BR2_PACKAGE_OSM2PGSQL_ARCH_SUPPORTS
+	bool
+	default y if BR2_aarch64 || BR2_aarch64_be
+	default y if BR2_x86_64
+	default y if BR2_mips64 || BR2_mips64el
+	default y if BR2_powerpc64 || BR2_powerpc64le
+	default y if BR2_RISCV_64
+	default y if BR2_sparc64
+	default y if BR2_s390x
+
 config BR2_PACKAGE_OSM2PGSQL
 	bool "osm2pgsql"
+	depends on BR2_PACKAGE_OSM2PGSQL_ARCH_SUPPORTS
 	depends on BR2_INSTALL_LIBSTDCPP # boost, libosmium, protozero
 	depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # C++14
 	depends on BR2_TOOLCHAIN_HAS_THREADS # boost, libosmium
@@ -24,9 +35,11 @@  config BR2_PACKAGE_OSM2PGSQL
 	  https://osm2pgsql.org
 
 comment "osm2pgsql needs a toolchain w/ C++, wchar, threads, gcc >= 4.9"
+	depends on BR2_PACKAGE_OSM2PGSQL_ARCH_SUPPORTS
 	depends on BR2_TOOLCHAIN_SUPPORTS_ALWAYS_LOCKFREE_ATOMIC_INTS
 	depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
 		!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || !BR2_TOOLCHAIN_HAS_THREADS
 
 comment "osm2pgsql needs a toolchain not affected by GCC bug 64735"
+	depends on BR2_PACKAGE_OSM2PGSQL_ARCH_SUPPORTS
 	depends on BR2_TOOLCHAIN_HAS_GCC_BUG_64735