diff mbox series

[1/1] package/cvs: fix build without editor

Message ID 20240315221029.88170-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/cvs: fix build without editor | expand

Commit Message

Fabrice Fontaine March 15, 2024, 10:10 p.m. UTC
Set default editor to /bin/vi to fix the following build failure when no
editor is found on host:

configure:40833: checking for vim
configure:40862: result: no
configure:40833: checking for vi
configure:40862: result: no
configure:40833: checking for emacs
configure:40862: result: no
configure:40833: checking for nano
configure:40862: result: no
configure:40833: checking for pico
configure:40862: result: no
configure:40833: checking for edit
configure:40862: result: no
configure:40874: error:
    Failed to find a text file editor.  CVS cannot be compiled
    without a default log message editor.  Searched for
    `vim vi emacs nano pico edit'.  Try `configure --with-editor'.

While at it, drop CVS_CONFIGURE_ARGS variable for simplicity

Fixes:
 - http://autobuild.buildroot.org/results/5b8a747698bc2e64eb1f001e87577e86e4cb8d14

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/cvs/cvs.mk | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

Comments

Arnout Vandecappelle March 24, 2024, 3:50 p.m. UTC | #1
On 15/03/2024 23:10, Fabrice Fontaine wrote:
> Set default editor to /bin/vi to fix the following build failure when no
> editor is found on host:
> 
> configure:40833: checking for vim
> configure:40862: result: no
> configure:40833: checking for vi
> configure:40862: result: no
> configure:40833: checking for emacs
> configure:40862: result: no
> configure:40833: checking for nano
> configure:40862: result: no
> configure:40833: checking for pico
> configure:40862: result: no
> configure:40833: checking for edit
> configure:40862: result: no
> configure:40874: error:
>      Failed to find a text file editor.  CVS cannot be compiled
>      without a default log message editor.  Searched for
>      `vim vi emacs nano pico edit'.  Try `configure --with-editor'.
> 
> While at it, drop CVS_CONFIGURE_ARGS variable for simplicity

  Nice!

  Applied to master, thanks.

  Regards,
  Arnout

> 
> Fixes:
>   - http://autobuild.buildroot.org/results/5b8a747698bc2e64eb1f001e87577e86e4cb8d14
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>   package/cvs/cvs.mk | 12 ++++++------
>   1 file changed, 6 insertions(+), 6 deletions(-)
> 
> diff --git a/package/cvs/cvs.mk b/package/cvs/cvs.mk
> index bd1e04eee0..64c15f16fe 100644
> --- a/package/cvs/cvs.mk
> +++ b/package/cvs/cvs.mk
> @@ -18,18 +18,18 @@ CVS_CONF_ENV = \
>   	ac_cv_func_working_mktime=yes \
>   	cvs_cv_func_printf_ptr=yes
>   
> -CVS_CONFIGURE_ARGS = --disable-old-info-format-support
> +CVS_CONF_OPTS = \
> +	--disable-old-info-format-support \
> +	--with-editor=/bin/vi
>   ifeq ($(BR2_PACKAGE_CVS_SERVER),y)
> -CVS_CONFIGURE_ARGS += --enable-server
> +CVS_CONF_OPTS += --enable-server
>   else
> -CVS_CONFIGURE_ARGS += --disable-server
> +CVS_CONF_OPTS += --disable-server
>   endif
>   ifeq ($(BR2_PACKAGE_ZLIB),y)
> -CVS_CONFIGURE_ARGS += --with-external-zlib
> +CVS_CONF_OPTS += --with-external-zlib
>   endif
>   
> -CVS_CONF_OPTS = $(CVS_CONFIGURE_ARGS)
> -
>   define CVS_BZIP_UNPACK
>   	$(BZCAT) $(@D)/cvs-$(CVS_VERSION).tar.bz2 | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
>   	rm -f $(@D)/cvs-$(CVS_VERSION).tar.bz2
Peter Korsgaard March 25, 2024, 9:01 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Set default editor to /bin/vi to fix the following build failure when no
 > editor is found on host:

 > configure:40833: checking for vim
 > configure:40862: result: no
 > configure:40833: checking for vi
 > configure:40862: result: no
 > configure:40833: checking for emacs
 > configure:40862: result: no
 > configure:40833: checking for nano
 > configure:40862: result: no
 > configure:40833: checking for pico
 > configure:40862: result: no
 > configure:40833: checking for edit
 > configure:40862: result: no
 > configure:40874: error:
 >     Failed to find a text file editor.  CVS cannot be compiled
 >     without a default log message editor.  Searched for
 >     `vim vi emacs nano pico edit'.  Try `configure --with-editor'.

 > While at it, drop CVS_CONFIGURE_ARGS variable for simplicity

 > Fixes:
 >  - http://autobuild.buildroot.org/results/5b8a747698bc2e64eb1f001e87577e86e4cb8d14

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2024.02.x, thanks.
Peter Korsgaard March 25, 2024, 9:01 a.m. UTC | #3
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 >> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

 > Committed to 2024.02.x, thanks.

And 2023.02.x + 2023.11.x as well.
diff mbox series

Patch

diff --git a/package/cvs/cvs.mk b/package/cvs/cvs.mk
index bd1e04eee0..64c15f16fe 100644
--- a/package/cvs/cvs.mk
+++ b/package/cvs/cvs.mk
@@ -18,18 +18,18 @@  CVS_CONF_ENV = \
 	ac_cv_func_working_mktime=yes \
 	cvs_cv_func_printf_ptr=yes
 
-CVS_CONFIGURE_ARGS = --disable-old-info-format-support
+CVS_CONF_OPTS = \
+	--disable-old-info-format-support \
+	--with-editor=/bin/vi
 ifeq ($(BR2_PACKAGE_CVS_SERVER),y)
-CVS_CONFIGURE_ARGS += --enable-server
+CVS_CONF_OPTS += --enable-server
 else
-CVS_CONFIGURE_ARGS += --disable-server
+CVS_CONF_OPTS += --disable-server
 endif
 ifeq ($(BR2_PACKAGE_ZLIB),y)
-CVS_CONFIGURE_ARGS += --with-external-zlib
+CVS_CONF_OPTS += --with-external-zlib
 endif
 
-CVS_CONF_OPTS = $(CVS_CONFIGURE_ARGS)
-
 define CVS_BZIP_UNPACK
 	$(BZCAT) $(@D)/cvs-$(CVS_VERSION).tar.bz2 | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
 	rm -f $(@D)/cvs-$(CVS_VERSION).tar.bz2