diff mbox series

[1/1] package/libkrb5: force arm mode instead of Thumb mode

Message ID 20240314213252.346954-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/libkrb5: force arm mode instead of Thumb mode | expand

Commit Message

Fabrice Fontaine March 14, 2024, 9:32 p.m. UTC
Fix the following build failure in Thumb mode:

/tmp/ccdzbA2E.s:845: Error: selected processor does not support `mcr p15,0,r2,c7,c10,5' in Thumb mode

Fixes:
 - http://autobuild.buildroot.org/results/08be1fa0fee0f05818cd78d4718caa3476c570ae

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libkrb5/libkrb5.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

André Zwing March 15, 2024, 5:09 p.m. UTC | #1
Am 14.03.24 um 22:32 schrieb Fabrice Fontaine:
> Fix the following build failure in Thumb mode:
> 
> /tmp/ccdzbA2E.s:845: Error: selected processor does not support `mcr p15,0,r2,c7,c10,5' in Thumb mode
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/08be1fa0fee0f05818cd78d4718caa3476c570ae
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>   package/libkrb5/libkrb5.mk | 7 +++++++
>   1 file changed, 7 insertions(+)
> 
> diff --git a/package/libkrb5/libkrb5.mk b/package/libkrb5/libkrb5.mk
> index 62a34b2379..c58763eddd 100644
> --- a/package/libkrb5/libkrb5.mk
> +++ b/package/libkrb5/libkrb5.mk
> @@ -33,6 +33,13 @@ LIBKRB5_CONF_OPTS = \
>   	--without-tcl \
>   	--disable-rpath
>   
> +# libkrb5 has some assembly function that is not present in Thumb mode:
> +# Error: selected processor does not support `mcr p15,0,r2,c7,c10,5' in Thumb mode
> +# so, we desactivate Thumb mode
> +ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
> +LIBKRB5_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -marm"
> +endif
> +
>   # Enabling static and shared at the same time is not supported
>   ifeq ($(BR2_SHARED_STATIC_LIBS),y)
>   LIBKRB5_CONF_OPTS += --disable-static



Reviewed-by: André Zwing <nerv@dawncrow.de>
Arnout Vandecappelle March 15, 2024, 7:21 p.m. UTC | #2
On 14/03/2024 22:32, Fabrice Fontaine wrote:
> Fix the following build failure in Thumb mode:
> 
> /tmp/ccdzbA2E.s:845: Error: selected processor does not support `mcr p15,0,r2,c7,c10,5' in Thumb mode
> 
> Fixes:
>   - http://autobuild.buildroot.org/results/08be1fa0fee0f05818cd78d4718caa3476c570ae
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

  Applied to master, thanks.

  Regards,
  Arnout

> ---
>   package/libkrb5/libkrb5.mk | 7 +++++++
>   1 file changed, 7 insertions(+)
> 
> diff --git a/package/libkrb5/libkrb5.mk b/package/libkrb5/libkrb5.mk
> index 62a34b2379..c58763eddd 100644
> --- a/package/libkrb5/libkrb5.mk
> +++ b/package/libkrb5/libkrb5.mk
> @@ -33,6 +33,13 @@ LIBKRB5_CONF_OPTS = \
>   	--without-tcl \
>   	--disable-rpath
>   
> +# libkrb5 has some assembly function that is not present in Thumb mode:
> +# Error: selected processor does not support `mcr p15,0,r2,c7,c10,5' in Thumb mode
> +# so, we desactivate Thumb mode
> +ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
> +LIBKRB5_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -marm"
> +endif
> +
>   # Enabling static and shared at the same time is not supported
>   ifeq ($(BR2_SHARED_STATIC_LIBS),y)
>   LIBKRB5_CONF_OPTS += --disable-static
Peter Korsgaard March 21, 2024, 8:47 p.m. UTC | #3
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure in Thumb mode:
 > /tmp/ccdzbA2E.s:845: Error: selected processor does not support `mcr p15,0,r2,c7,c10,5' in Thumb mode

 > Fixes:
 >  - http://autobuild.buildroot.org/results/08be1fa0fee0f05818cd78d4718caa3476c570ae

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2024.02.x, thanks.
Peter Korsgaard March 21, 2024, 8:48 p.m. UTC | #4
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:
 >> Fix the following build failure in Thumb mode:
 >> /tmp/ccdzbA2E.s:845: Error: selected processor does not support `mcr p15,0,r2,c7,c10,5' in Thumb mode

 >> Fixes:
 >> - http://autobuild.buildroot.org/results/08be1fa0fee0f05818cd78d4718caa3476c570ae

 >> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

 > Committed to 2024.02.x, thanks.

Ehh, and 2023.02.x and 2023.11.x.
diff mbox series

Patch

diff --git a/package/libkrb5/libkrb5.mk b/package/libkrb5/libkrb5.mk
index 62a34b2379..c58763eddd 100644
--- a/package/libkrb5/libkrb5.mk
+++ b/package/libkrb5/libkrb5.mk
@@ -33,6 +33,13 @@  LIBKRB5_CONF_OPTS = \
 	--without-tcl \
 	--disable-rpath
 
+# libkrb5 has some assembly function that is not present in Thumb mode:
+# Error: selected processor does not support `mcr p15,0,r2,c7,c10,5' in Thumb mode
+# so, we desactivate Thumb mode
+ifeq ($(BR2_ARM_INSTRUCTIONS_THUMB),y)
+LIBKRB5_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -marm"
+endif
+
 # Enabling static and shared at the same time is not supported
 ifeq ($(BR2_SHARED_STATIC_LIBS),y)
 LIBKRB5_CONF_OPTS += --disable-static