diff mbox series

package/luarocks: bump to version 3.11.0

Message ID 20240314173130.16321-1-francois.perrad@gadz.org
State Accepted
Headers show
Series package/luarocks: bump to version 3.11.0 | expand

Commit Message

Francois Perrad March 14, 2024, 5:31 p.m. UTC
COPYING: update copyright notice
see https://github.com/luarocks/luarocks/commit/a0bc05dcc7f44b94fb4585c560928ba9be6d8bdc

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/luarocks/buildroot.lua | 3 +++
 package/luarocks/luarocks.hash | 4 ++--
 package/luarocks/luarocks.mk   | 2 +-
 3 files changed, 6 insertions(+), 3 deletions(-)

Comments

Arnout Vandecappelle March 15, 2024, 7:44 p.m. UTC | #1
On 14/03/2024 18:31, Francois Perrad wrote:
> COPYING: update copyright notice
> see https://github.com/luarocks/luarocks/commit/a0bc05dcc7f44b94fb4585c560928ba9be6d8bdc
> 
> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>   package/luarocks/buildroot.lua | 3 +++
>   package/luarocks/luarocks.hash | 4 ++--
>   package/luarocks/luarocks.mk   | 2 +-
>   3 files changed, 6 insertions(+), 3 deletions(-)
> 
> diff --git a/package/luarocks/buildroot.lua b/package/luarocks/buildroot.lua
> index 3c044d89b..2b5235866 100644
> --- a/package/luarocks/buildroot.lua
> +++ b/package/luarocks/buildroot.lua
> @@ -350,8 +350,11 @@ function buildroot.command(args)
>         return nil, "Error loading rockspec: " .. err
>      end
>      if rockspec.source.file then
> +      rockspec.source.dir = rockspec.source.dir or dir.deduce_base_dir(rockspec.source.file)
>         ok, err = fs.unpack_archive(rockspec.source.file)
>         if not ok then return nil, err end
> +   else
> +      rockspec.source.dir = rockspec.source.dir or '.'

  This change should have been explained in the commit message... Anyway, 
applied to master, thanks.

  Regards,
  Arnout

>      end
>   
>      if rockspec.source.dir ~= '.' then
> diff --git a/package/luarocks/luarocks.hash b/package/luarocks/luarocks.hash
> index 713645692..fbf527021 100644
> --- a/package/luarocks/luarocks.hash
> +++ b/package/luarocks/luarocks.hash
> @@ -1,3 +1,3 @@
>   # Locally calculated
> -sha256  ffafd83b1c42aa38042166a59ac3b618c838ce4e63f4ace9d961a5679ef58253  luarocks-3.9.1.tar.gz
> -sha256  542ad0ee9b8ba582437ca7b4d0959c9b9432f25d2067f144d017188a7a84dd2f  COPYING
> +sha256  25f56b3c7272fb35b869049371d649a1bbe668a56d24df0a66e3712e35dd44a6  luarocks-3.11.0.tar.gz
> +sha256  660773f53ed17cd0d8be7d67168c25e8cc664a506788c7b5971192bdd2994a9d  COPYING
> diff --git a/package/luarocks/luarocks.mk b/package/luarocks/luarocks.mk
> index 2bec2fca2..4c9922914 100644
> --- a/package/luarocks/luarocks.mk
> +++ b/package/luarocks/luarocks.mk
> @@ -4,7 +4,7 @@
>   #
>   ################################################################################
>   
> -LUAROCKS_VERSION = 3.9.1
> +LUAROCKS_VERSION = 3.11.0
>   LUAROCKS_SITE = https://luarocks.org/releases
>   LUAROCKS_LICENSE = MIT
>   LUAROCKS_LICENSE_FILES = COPYING
diff mbox series

Patch

diff --git a/package/luarocks/buildroot.lua b/package/luarocks/buildroot.lua
index 3c044d89b..2b5235866 100644
--- a/package/luarocks/buildroot.lua
+++ b/package/luarocks/buildroot.lua
@@ -350,8 +350,11 @@  function buildroot.command(args)
       return nil, "Error loading rockspec: " .. err
    end
    if rockspec.source.file then
+      rockspec.source.dir = rockspec.source.dir or dir.deduce_base_dir(rockspec.source.file)
       ok, err = fs.unpack_archive(rockspec.source.file)
       if not ok then return nil, err end
+   else
+      rockspec.source.dir = rockspec.source.dir or '.'
    end
 
    if rockspec.source.dir ~= '.' then
diff --git a/package/luarocks/luarocks.hash b/package/luarocks/luarocks.hash
index 713645692..fbf527021 100644
--- a/package/luarocks/luarocks.hash
+++ b/package/luarocks/luarocks.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256  ffafd83b1c42aa38042166a59ac3b618c838ce4e63f4ace9d961a5679ef58253  luarocks-3.9.1.tar.gz
-sha256  542ad0ee9b8ba582437ca7b4d0959c9b9432f25d2067f144d017188a7a84dd2f  COPYING
+sha256  25f56b3c7272fb35b869049371d649a1bbe668a56d24df0a66e3712e35dd44a6  luarocks-3.11.0.tar.gz
+sha256  660773f53ed17cd0d8be7d67168c25e8cc664a506788c7b5971192bdd2994a9d  COPYING
diff --git a/package/luarocks/luarocks.mk b/package/luarocks/luarocks.mk
index 2bec2fca2..4c9922914 100644
--- a/package/luarocks/luarocks.mk
+++ b/package/luarocks/luarocks.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-LUAROCKS_VERSION = 3.9.1
+LUAROCKS_VERSION = 3.11.0
 LUAROCKS_SITE = https://luarocks.org/releases
 LUAROCKS_LICENSE = MIT
 LUAROCKS_LICENSE_FILES = COPYING