diff mbox series

package/libmdbx: bump version to 0.12.10 "SEM"

Message ID 20240314161116.714877-1-leo@yuriev.ru
State New
Headers show
Series package/libmdbx: bump version to 0.12.10 "SEM" | expand

Commit Message

Леонид Юрьев (Leonid Yuriev) March 14, 2024, 4:11 p.m. UTC
This is bugfix release of stable libmdbx branch, in memory of the Hero
of Russia Guard Major Dmitry Semenov with the call sign "SEM".

It is reasonable to backport this patch to all applicable releases/branches of Buildroot.

The most significant fixes since v0.12.8 (previous version pinned to buildroot):

 - Fixed an major bug inherited from LMDB (Lightning Memory-Mappe Database)
   that causes database corruption during use the MDBX_DUPFIXED mode.
   In LMDB, the problem has existed for more than 10 years and is still
   present (as well as more than a dozen other bug and shortcomings
   fixed in libmdbx).

 - Fixed of a false error MDBX_CORRUPTED (-30796) in the scenario of
   working in the mode MDBX_DUPFIXED with odd length of multi-values.

 - Fixed a bug in adjusting the cursors in the case splitting a page by
   adding a new page on the left.

 - Troubleshooting an error when opening a database on a read-only file system.

 - A set of C++ API improvements:

    - added the mdbx::cursor::estimation_result type, and the behavior
      of methods cursor::estimate() is unified with cursor::move();

    - to prevent unnoticeable incorrect use of the API, for initializing
      slices returned by reference the slice::invalid() is used, instead of
      empty slices;

    - added additional C++ conversion operators to C API types;

    - types buffer::move_assign_alloc and buffer::copy_assign_alloc are public
      now for compatibility with older C++ standards and older STL versions;

    - added a new mdbx::default_buffer type;

    - added methods for slices and buffers hex_decode(), base64_decode(),
      base58_decode();

    - added type mdbx::comparator() and mdbx::default_comparator() functions;

    - added static methods buffer::hex(), buffer::base64(), buffer::base58();

    - added methods for transactions and cursors get/set_context();

    - added the cursor::clone() method;

    - implementation of base58 now is in accordance with the RFC draft.

The complete ChangeLog: https://gitflic.ru/project/erthink/libmdbx/blob?file=ChangeLog.md

Signed-off-by: Леонид Юрьев (Leonid Yuriev) <leo@yuriev.ru>
---
 package/libmdbx/libmdbx.hash | 2 +-
 package/libmdbx/libmdbx.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/libmdbx/libmdbx.hash b/package/libmdbx/libmdbx.hash
index 82cf28d6a9..1dbdef7c69 100644
--- a/package/libmdbx/libmdbx.hash
+++ b/package/libmdbx/libmdbx.hash
@@ -1,5 +1,5 @@ 
 # Hashes from: https://libmdbx.dqdkfa.ru/release/SHA256SUMS
-sha256  c78c56c53708bbfc519bf53ebf520d1f09d30ee6427a4bedf713316696e671d0  libmdbx-amalgamated-0.12.8.tar.xz
+sha256  4637e06768a9a8fc7577e6e458e045ad1f9a8baee74996a3c88bc0ad64cbcf67  libmdbx-amalgamated-0.12.10.tar.xz
 
 # Locally calculated
 sha256  310fe25c858a9515fc8c8d7d1f24a67c9496f84a91e0a0e41ea9975b1371e569  LICENSE
diff --git a/package/libmdbx/libmdbx.mk b/package/libmdbx/libmdbx.mk
index 4cc6cbd08e..6e0571ff24 100644
--- a/package/libmdbx/libmdbx.mk
+++ b/package/libmdbx/libmdbx.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-LIBMDBX_VERSION = 0.12.8
+LIBMDBX_VERSION = 0.12.10
 LIBMDBX_SOURCE = libmdbx-amalgamated-$(LIBMDBX_VERSION).tar.xz
 LIBMDBX_SITE = https://libmdbx.dqdkfa.ru/release
 LIBMDBX_SUPPORTS_IN_SOURCE_BUILD = NO