diff mbox series

[v2,1/3] package/targetcli-fb: bump version to 2.1.58

Message ID 20240312193528.664465-1-jeremy@jeremypeper.com
State Accepted
Headers show
Series [v2,1/3] package/targetcli-fb: bump version to 2.1.58 | expand

Commit Message

Jeremy J. Peper March 12, 2024, 7:35 p.m. UTC
bump to latest version because previous version did not work with python 3.11
corrected version mismatch with my first submission

Signed-off-by: Jeremy J. Peper <jeremy@jeremypeper.com>
---
 package/targetcli-fb/targetcli-fb.hash | 2 +-
 package/targetcli-fb/targetcli-fb.mk   | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Arnout Vandecappelle March 15, 2024, 8:31 p.m. UTC | #1
Hi Jeremy,

On 12/03/2024 20:35, Jeremy J. Peper wrote:
> bump to latest version because previous version did not work with python 3.11
> corrected version mismatch with my first submission

  I unfortunately already pushed before I noticed: you shouldn't include 
"personal comments" or references to the patch history in the commit message 
itself - that belongs under the --- line. So it should have been:

package/targetcli-fb: bump version to 2.1.58

Bump to latest version because previous version did not work with python 3.11

Signed-off-by: ...
---
v2: correct version mismatch




  And another thing: we've had Python 3.11 for more than a year, so this has 
been broken for quite some time. To make sure we notice in the future, it would 
be good to have a runtime test that detects the situation.

  Regards,
  Arnout

> 
> Signed-off-by: Jeremy J. Peper <jeremy@jeremypeper.com>
> ---
>   package/targetcli-fb/targetcli-fb.hash | 2 +-
>   package/targetcli-fb/targetcli-fb.mk   | 2 +-
>   2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/package/targetcli-fb/targetcli-fb.hash b/package/targetcli-fb/targetcli-fb.hash
> index 64f68a66..1732fa99 100644
> --- a/package/targetcli-fb/targetcli-fb.hash
> +++ b/package/targetcli-fb/targetcli-fb.hash
> @@ -1,3 +1,3 @@
>   # locally computed
> -sha256  7ae4120a54f24b13263b4b85c43952a03546f8b9fc9bd15fe87678f68245a33f  targetcli-fb-2.1.54.tar.gz
> +sha256  605f4e4e4e7189d6a03f11a4f55e7ddb4671002d542c2f684f87dd68391dcdc2  targetcli-fb-2.1.58.tar.gz
>   sha256  5df2a0d87d6c562f0ea11c688ac52532aa28d744cabc7994ff0537f64b3b3320  COPYING
> diff --git a/package/targetcli-fb/targetcli-fb.mk b/package/targetcli-fb/targetcli-fb.mk
> index 2d375417..8cdcc6f6 100644
> --- a/package/targetcli-fb/targetcli-fb.mk
> +++ b/package/targetcli-fb/targetcli-fb.mk
> @@ -6,7 +6,7 @@
>   
>   # When upgrading the version, be sure to also upgrade python-rtslib-fb
>   # and python-configshell-fb at the same time.
> -TARGETCLI_FB_VERSION = 2.1.54
> +TARGETCLI_FB_VERSION = 2.1.58
>   TARGETCLI_FB_SITE = $(call github,open-iscsi,targetcli-fb,v$(TARGETCLI_FB_VERSION))
>   TARGETCLI_FB_LICENSE = Apache-2.0
>   TARGETCLI_FB_LICENSE_FILES = COPYING
Jeremy J. Peper March 15, 2024, 10:21 p.m. UTC | #2
On Friday, March 15, 2024 3:31:09 PM CDT Arnout Vandecappelle wrote:
>   Hi Jeremy,
> 
> On 12/03/2024 20:35, Jeremy J. Peper wrote:
> > bump to latest version because previous version did not work with python
> > 3.11 corrected version mismatch with my first submission
> 
>   I unfortunately already pushed before I noticed: you shouldn't include
> "personal comments" or references to the patch history in the commit message
> itself - that belongs under the --- line. So it should have been:
> 
> package/targetcli-fb: bump version to 2.1.58
> 
> Bump to latest version because previous version did not work with python
> 3.11
> 
> Signed-off-by: ...
> ---
> v2: correct version mismatch

Sorry about that, I will endeavour to do that properly in the future. 

> 
>   And another thing: we've had Python 3.11 for more than a year, so this has
> been broken for quite some time. To make sure we notice in the future, it
> would be good to have a runtime test that detects the situation.
> 
>   Regards,
>   Arnout

I believe you are correct, it appears to have been broken for at least the 
past few stable releases. 

Adding the test sounds like a good idea and I'd be interested in setting that 
up at some point but I'm not sure when I'll get a chance to work through that 
learning curve. 

> > Signed-off-by: Jeremy J. Peper <jeremy@jeremypeper.com>
> > ---
> > 
> >   package/targetcli-fb/targetcli-fb.hash | 2 +-
> >   package/targetcli-fb/targetcli-fb.mk   | 2 +-
> >   2 files changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/package/targetcli-fb/targetcli-fb.hash
> > b/package/targetcli-fb/targetcli-fb.hash index 64f68a66..1732fa99 100644
> > --- a/package/targetcli-fb/targetcli-fb.hash
> > +++ b/package/targetcli-fb/targetcli-fb.hash
> > @@ -1,3 +1,3 @@
> > 
> >   # locally computed
> > 
> > -sha256  7ae4120a54f24b13263b4b85c43952a03546f8b9fc9bd15fe87678f68245a33f 
> > targetcli-fb-2.1.54.tar.gz +sha256 
> > 605f4e4e4e7189d6a03f11a4f55e7ddb4671002d542c2f684f87dd68391dcdc2 
> > targetcli-fb-2.1.58.tar.gz> 
> >   sha256  5df2a0d87d6c562f0ea11c688ac52532aa28d744cabc7994ff0537f64b3b3320
> >    COPYING> 
> > diff --git a/package/targetcli-fb/targetcli-fb.mk
> > b/package/targetcli-fb/targetcli-fb.mk index 2d375417..8cdcc6f6 100644
> > --- a/package/targetcli-fb/targetcli-fb.mk
> > +++ b/package/targetcli-fb/targetcli-fb.mk
> > @@ -6,7 +6,7 @@
> > 
> >   # When upgrading the version, be sure to also upgrade python-rtslib-fb
> >   # and python-configshell-fb at the same time.
> > 
> > -TARGETCLI_FB_VERSION = 2.1.54
> > +TARGETCLI_FB_VERSION = 2.1.58
> > 
> >   TARGETCLI_FB_SITE = $(call
> >   github,open-iscsi,targetcli-fb,v$(TARGETCLI_FB_VERSION))
> >   TARGETCLI_FB_LICENSE = Apache-2.0
> >   TARGETCLI_FB_LICENSE_FILES = COPYING

Are there any other changes that I need to make before this is suitable to be 
committed? 

Thanks again for all your feedback and guidance.
-Jeremy
Arnout Vandecappelle March 16, 2024, 7:21 p.m. UTC | #3
On 15/03/2024 23:21, Jeremy J. Peper wrote:
> On Friday, March 15, 2024 3:31:09 PM CDT Arnout Vandecappelle wrote:
>>    Hi Jeremy,
>>
>> On 12/03/2024 20:35, Jeremy J. Peper wrote:
>>> bump to latest version because previous version did not work with python
>>> 3.11 corrected version mismatch with my first submission
>>
>>    I unfortunately already pushed before I noticed: you shouldn't include
>> "personal comments" or references to the patch history in the commit message
>> itself - that belongs under the --- line. So it should have been:
>>
>> package/targetcli-fb: bump version to 2.1.58
>>
>> Bump to latest version because previous version did not work with python
>> 3.11
>>
>> Signed-off-by: ...
>> ---
>> v2: correct version mismatch
> 
> Sorry about that, I will endeavour to do that properly in the future.

  No worries. I made this comment so you could learn.


>>    And another thing: we've had Python 3.11 for more than a year, so this has
>> been broken for quite some time. To make sure we notice in the future, it
>> would be good to have a runtime test that detects the situation.
>>
>>    Regards,
>>    Arnout
> 
> I believe you are correct, it appears to have been broken for at least the
> past few stable releases.
> 
> Adding the test sounds like a good idea and I'd be interested in setting that
> up at some point but I'm not sure when I'll get a chance to work through that
> learning curve.

  For a Python package, the test is usually quite simple: just import it, and if 
there's a C library linked with it, make sure you make a call into the C 
library. See e.g. support/testing/tests/package/test_python_click.py

  A slightly more complicated test can import a Python script to do the actual 
test. See e.g. support/testing/tests/package/test_python_gnupg.py which runs 
support/testing/tests/package/sample_python_gnupg.py

[snip]
> Are there any other changes that I need to make before this is suitable to be
> committed?

  I apparently didn't make my self clear enough: it is already committed (that's 
why I said "I already pushed"). In fact, the entire series is committed.


  Regards,
  Arnout

> 
> Thanks again for all your feedback and guidance.
> -Jeremy
> 
> 
> 
>
Jeremy J. Peper March 18, 2024, 3:45 p.m. UTC | #4
On Saturday, March 16, 2024 2:21:35 PM CDT Arnout Vandecappelle wrote:
> On 15/03/2024 23:21, Jeremy J. Peper wrote:
> > On Friday, March 15, 2024 3:31:09 PM CDT Arnout Vandecappelle wrote:
> >>    Hi Jeremy,
> >> 
> >> On 12/03/2024 20:35, Jeremy J. Peper wrote:
> >>> bump to latest version because previous version did not work with python
> >>> 3.11 corrected version mismatch with my first submission
> >>> 
> >>    I unfortunately already pushed before I noticed: you shouldn't include
> >> 
> >> "personal comments" or references to the patch history in the commit
> >> message itself - that belongs under the --- line. So it should have
> >> been:
> >> 
> >> package/targetcli-fb: bump version to 2.1.58
> >> 
> >> Bump to latest version because previous version did not work with python
> >> 3.11
> >> 
> >> Signed-off-by: ...
> >> ---
> >> v2: correct version mismatch
> > 
> > Sorry about that, I will endeavour to do that properly in the future.
> 
>   No worries. I made this comment so you could learn.
> 
> >>    And another thing: we've had Python 3.11 for more than a year, so this
> >>    has
> >> 
> >> been broken for quite some time. To make sure we notice in the future, it
> >> would be good to have a runtime test that detects the situation.
> >> 
> >>    Regards,
> >>    Arnout
> > 
> > I believe you are correct, it appears to have been broken for at least the
> > past few stable releases.
> > 
> > Adding the test sounds like a good idea and I'd be interested in setting
> > that up at some point but I'm not sure when I'll get a chance to work
> > through that learning curve.
> 
>   For a Python package, the test is usually quite simple: just import it,
> and if there's a C library linked with it, make sure you make a call into
> the C library. See e.g. support/testing/tests/package/test_python_click.py
> 
>   A slightly more complicated test can import a Python script to do the
> actual test. See e.g. support/testing/tests/package/test_python_gnupg.py
> which runs support/testing/tests/package/sample_python_gnupg.py
> 
> [snip]
> 
> > Are there any other changes that I need to make before this is suitable to
> > be committed?
> 
>   I apparently didn't make my self clear enough: it is already committed
> (that's why I said "I already pushed"). In fact, the entire series is
> committed.
> 
> 
>   Regards,
>   Arnout
> 
> > Thanks again for all your feedback and guidance.
> > -Jeremy

Excellent, is it possible to get this fix added to the next release of 
2024.02.x ?
Peter Korsgaard March 21, 2024, 8:59 p.m. UTC | #5
>>>>> "Jeremy" == Jeremy J Peper <jeremy@jeremypeper.com> writes:

 >> > Thanks again for all your feedback and guidance.
 >> > -Jeremy

 > Excellent, is it possible to get this fix added to the next release of 
 > 2024.02.x ?

Yes, committed to 2024.02.x, 2023.02.x and 2023.11.x, thanks - It will
be part of the upcoming 2024.02.1 release.
diff mbox series

Patch

diff --git a/package/targetcli-fb/targetcli-fb.hash b/package/targetcli-fb/targetcli-fb.hash
index 64f68a66..1732fa99 100644
--- a/package/targetcli-fb/targetcli-fb.hash
+++ b/package/targetcli-fb/targetcli-fb.hash
@@ -1,3 +1,3 @@ 
 # locally computed
-sha256  7ae4120a54f24b13263b4b85c43952a03546f8b9fc9bd15fe87678f68245a33f  targetcli-fb-2.1.54.tar.gz
+sha256  605f4e4e4e7189d6a03f11a4f55e7ddb4671002d542c2f684f87dd68391dcdc2  targetcli-fb-2.1.58.tar.gz
 sha256  5df2a0d87d6c562f0ea11c688ac52532aa28d744cabc7994ff0537f64b3b3320  COPYING
diff --git a/package/targetcli-fb/targetcli-fb.mk b/package/targetcli-fb/targetcli-fb.mk
index 2d375417..8cdcc6f6 100644
--- a/package/targetcli-fb/targetcli-fb.mk
+++ b/package/targetcli-fb/targetcli-fb.mk
@@ -6,7 +6,7 @@ 
 
 # When upgrading the version, be sure to also upgrade python-rtslib-fb
 # and python-configshell-fb at the same time.
-TARGETCLI_FB_VERSION = 2.1.54
+TARGETCLI_FB_VERSION = 2.1.58
 TARGETCLI_FB_SITE = $(call github,open-iscsi,targetcli-fb,v$(TARGETCLI_FB_VERSION))
 TARGETCLI_FB_LICENSE = Apache-2.0
 TARGETCLI_FB_LICENSE_FILES = COPYING