diff mbox series

[v2,1/3] package/targetcli-fb: needs python-gobject

Message ID 20240312193140.663261-1-jeremy@jeremypeper.com
State Superseded
Headers show
Series [v2,1/3] package/targetcli-fb: needs python-gobject | expand

Commit Message

Jeremy J. Peper March 12, 2024, 7:31 p.m. UTC
add python-gobject to resolve "ModuleNotFoundError: No module named 'gi'" error encountered if built without it.
add python-gobject's dependencies as well

Signed-off-by: Jeremy J. Peper <jeremy@jeremypeper.com>
---
 package/targetcli-fb/Config.in       | 1 +
 package/targetcli-fb/targetcli-fb.mk | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Adam Duskett March 12, 2024, 7:41 p.m. UTC | #1
Hello;



On Tue, Mar 12, 2024 at 12:32 PM Jeremy J. Peper <jeremy@jeremypeper.com> wrote:
>
> add python-gobject to resolve "ModuleNotFoundError: No module named 'gi'" error encountered if built without it.
> add python-gobject's dependencies as well
>
> Signed-off-by: Jeremy J. Peper <jeremy@jeremypeper.com>
> ---
>  package/targetcli-fb/Config.in       | 1 +
>  package/targetcli-fb/targetcli-fb.mk | 2 +-
>  2 files changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/package/targetcli-fb/Config.in b/package/targetcli-fb/Config.in
> index 04c6a1ac..722b9400 100644
> --- a/package/targetcli-fb/Config.in
> +++ b/package/targetcli-fb/Config.in
> @@ -7,6 +7,7 @@ config BR2_PACKAGE_TARGETCLI_FB
You need to add the PYTHON_GOBJECT_DEPENDENCIES here.
IE:

depends on BR2_USE_MMU # python-gobject
depends on BR2_PACKAGE_GOBJECT_INTROSPECTION_ARCH_SUPPORTS # python-gobject
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 # python-gobject
depends on BR2_HOST_GCC_AT_LEAST_8 # python-gobject
depends on BR2_TOOLCHAIN_USES_GLIBC # python-gobject

>         select BR2_PACKAGE_PYTHON_CONFIGSHELL_FB
>         select BR2_PACKAGE_PYTHON_RTSLIB_FB
>         select BR2_PACKAGE_PYTHON_SIX
> +       select BR2_PACKAGE_PYTHON_GOBJECT
>         help
>           targetcli-fb is a command-line interface for configuring the
>           LIO generic SCSI target, present in 3.x Linux kernel
Then, add a message below this. Since there isn't an existing message,
you can copy and
paste and modify from the python-gobject package. IE:

comment "targetcli-fb needs a glibc toolchain, gcc >= 4.9, host gcc >= 8"
       depends on BR2_USE_MMU
       depends on BR2_PACKAGE_GOBJECT_INTROSPECTION_ARCH_SUPPORTS
       depends on !BR2_TOOLCHAIN_USES_GLIBC || \
               !BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || \
               !BR2_HOST_GCC_AT_LEAST_8


> diff --git a/package/targetcli-fb/targetcli-fb.mk b/package/targetcli-fb/targetcli-fb.mk
> index d2cbf79e..2d375417 100644
> --- a/package/targetcli-fb/targetcli-fb.mk
> +++ b/package/targetcli-fb/targetcli-fb.mk
> @@ -12,7 +12,7 @@ TARGETCLI_FB_LICENSE = Apache-2.0
>  TARGETCLI_FB_LICENSE_FILES = COPYING
>  TARGETCLI_FB_CPE_ID_VALID = YES
>  TARGETCLI_FB_SETUP_TYPE = setuptools
> -TARGETCLI_FB_DEPENDENCIES = python-configshell-fb python-rtslib-fb python-six
> +TARGETCLI_FB_DEPENDENCIES = python-configshell-fb python-rtslib-fb python-six python-gobject $(PYTHON_GOBJECT_DEPENDENCIES)
This was actually correct before! You only need to add python-gobject, not
$(PYTHON_GOBJECT_DEPENDENCIES).


Thanks again!
Adam
>
>  define TARGETCLI_FB_INSTALL_INIT_SYSV
>         $(INSTALL) -m 0755 -D package/targetcli-fb/S50target \
> --
> 2.39.2
>
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/targetcli-fb/Config.in b/package/targetcli-fb/Config.in
index 04c6a1ac..722b9400 100644
--- a/package/targetcli-fb/Config.in
+++ b/package/targetcli-fb/Config.in
@@ -7,6 +7,7 @@  config BR2_PACKAGE_TARGETCLI_FB
 	select BR2_PACKAGE_PYTHON_CONFIGSHELL_FB
 	select BR2_PACKAGE_PYTHON_RTSLIB_FB
 	select BR2_PACKAGE_PYTHON_SIX
+	select BR2_PACKAGE_PYTHON_GOBJECT
 	help
 	  targetcli-fb is a command-line interface for configuring the
 	  LIO generic SCSI target, present in 3.x Linux kernel
diff --git a/package/targetcli-fb/targetcli-fb.mk b/package/targetcli-fb/targetcli-fb.mk
index d2cbf79e..2d375417 100644
--- a/package/targetcli-fb/targetcli-fb.mk
+++ b/package/targetcli-fb/targetcli-fb.mk
@@ -12,7 +12,7 @@  TARGETCLI_FB_LICENSE = Apache-2.0
 TARGETCLI_FB_LICENSE_FILES = COPYING
 TARGETCLI_FB_CPE_ID_VALID = YES
 TARGETCLI_FB_SETUP_TYPE = setuptools
-TARGETCLI_FB_DEPENDENCIES = python-configshell-fb python-rtslib-fb python-six
+TARGETCLI_FB_DEPENDENCIES = python-configshell-fb python-rtslib-fb python-six python-gobject $(PYTHON_GOBJECT_DEPENDENCIES)
 
 define TARGETCLI_FB_INSTALL_INIT_SYSV
 	$(INSTALL) -m 0755 -D package/targetcli-fb/S50target \