diff mbox series

[v2,1/1] linux: disable -Werror

Message ID 20240306192604.381763-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v2,1/1] linux: disable -Werror | expand

Commit Message

Fabrice Fontaine March 6, 2024, 7:26 p.m. UTC
Disable -Werror to fix the following build failure with esp-hosted
raised at least since commit a382a7d55432918d2a1e47ae4cbe7ed50fa17a08:

In function ‘destroy_cmd_wq’,
    inlined from ‘esp_commands_teardown’ at /home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:1467:2:
./include/linux/workqueue.h:639:9: error: call to ‘__warn_flushing_systemwide_wq’ declared with attribute warning: Please avoid flushing system-wide workqueues. [-Werror=attribute-warning]
  639 |         __warn_flushing_systemwide_wq();                                \
      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:408:17: note: in expansion of macro ‘flush_scheduled_work’
  408 |                 flush_scheduled_work();
      |                 ^~~~~~~~~~~~~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/6ac7a4601938d3296ed1657c06f8cdf433757d73
 - http://autobuild.buildroot.org/results/7997cc8a67645a6e1cf4e24d172c6feae459dcfb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Peter Korsgaard):
 - Move disabling of -Werror from esp-hosted to linux.mk

 linux/linux.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Peter Korsgaard March 7, 2024, 1:05 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Disable -Werror to fix the following build failure with esp-hosted
 > raised at least since commit a382a7d55432918d2a1e47ae4cbe7ed50fa17a08:

 > In function ‘destroy_cmd_wq’,
 >     inlined from ‘esp_commands_teardown’ at /home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:1467:2:
 > ./include/linux/workqueue.h:639:9: error: call to ‘__warn_flushing_systemwide_wq’ declared with attribute warning: Please avoid flushing system-wide workqueues. [-Werror=attribute-warning]
 >   639 |         __warn_flushing_systemwide_wq();                                \
 >       |         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 > /home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:408:17:
 > note: in expansion of macro ‘flush_scheduled_work’
 >   408 |                 flush_scheduled_work();
 >       |                 ^~~~~~~~~~~~~~~~~~~~

 > Fixes:
 >  - http://autobuild.buildroot.org/results/6ac7a4601938d3296ed1657c06f8cdf433757d73
 >  - http://autobuild.buildroot.org/results/7997cc8a67645a6e1cf4e24d172c6feae459dcfb

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 > ---
 > Changes v1 -> v2 (after review of Peter Korsgaard):
 >  - Move disabling of -Werror from esp-hosted to linux.mk

Committed, thanks.
Peter Korsgaard March 21, 2024, 8:12 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Disable -Werror to fix the following build failure with esp-hosted
 > raised at least since commit a382a7d55432918d2a1e47ae4cbe7ed50fa17a08:

 > In function ‘destroy_cmd_wq’,
 >     inlined from ‘esp_commands_teardown’ at /home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:1467:2:
 > ./include/linux/workqueue.h:639:9: error: call to ‘__warn_flushing_systemwide_wq’ declared with attribute warning: Please avoid flushing system-wide workqueues. [-Werror=attribute-warning]
 >   639 |         __warn_flushing_systemwide_wq();                                \
 >       |         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 > /home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:408:17:
 > note: in expansion of macro ‘flush_scheduled_work’
 >   408 |                 flush_scheduled_work();
 >       |                 ^~~~~~~~~~~~~~~~~~~~

 > Fixes:
 >  - http://autobuild.buildroot.org/results/6ac7a4601938d3296ed1657c06f8cdf433757d73
 >  - http://autobuild.buildroot.org/results/7997cc8a67645a6e1cf4e24d172c6feae459dcfb

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 > ---
 > Changes v1 -> v2 (after review of Peter Korsgaard):
 >  - Move disabling of -Werror from esp-hosted to linux.mk

Committed to 2024.02.x, thanks.
diff mbox series

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index 53e2ad6d48..4e12b36c1f 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -436,6 +436,7 @@  define LINUX_KCONFIG_FIXUP_CMDS
 		$(call KCONFIG_ENABLE_OPT,CONFIG_LOGO)
 		$(call KCONFIG_ENABLE_OPT,CONFIG_LOGO_LINUX_CLUT224))
 	$(call KCONFIG_DISABLE_OPT,CONFIG_GCC_PLUGINS)
+	$(call KCONFIG_DISABLE_OPT,CONFIG_WERROR)
 	$(PACKAGES_LINUX_CONFIG_FIXUPS)
 endef