diff mbox series

[1/1] package/esp-hosted: disable -Werror

Message ID 20240305171938.2252446-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/esp-hosted: disable -Werror | expand

Commit Message

Fabrice Fontaine March 5, 2024, 5:19 p.m. UTC
Disable -Werror to fix the following build failure raised at least since
commit a382a7d55432918d2a1e47ae4cbe7ed50fa17a08:

In function ‘destroy_cmd_wq’,
    inlined from ‘esp_commands_teardown’ at /home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:1467:2:
./include/linux/workqueue.h:639:9: error: call to ‘__warn_flushing_systemwide_wq’ declared with attribute warning: Please avoid flushing system-wide workqueues. [-Werror=attribute-warning]
  639 |         __warn_flushing_systemwide_wq();                                \
      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
/home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:408:17: note: in expansion of macro ‘flush_scheduled_work’
  408 |                 flush_scheduled_work();
      |                 ^~~~~~~~~~~~~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/6ac7a4601938d3296ed1657c06f8cdf433757d73
 - http://autobuild.buildroot.org/results/7997cc8a67645a6e1cf4e24d172c6feae459dcfb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/esp-hosted/esp-hosted.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Giulio Benetti March 5, 2024, 5:24 p.m. UTC | #1
Hello Fabrice,

> Il giorno 5 mar 2024, alle ore 18:19, Fabrice Fontaine <fontaine.fabrice@gmail.com> ha scritto:
> 
> Disable -Werror to fix the following build failure raised at least since
> commit a382a7d55432918d2a1e47ae4cbe7ed50fa17a08:
> 
> In function ‘destroy_cmd_wq’,
>    inlined from ‘esp_commands_teardown’ at /home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:1467:2:
> ./include/linux/workqueue.h:639:9: error: call to ‘__warn_flushing_systemwide_wq’ declared with attribute warning: Please avoid flushing system-wide workqueues. [-Werror=attribute-warning]
>  639 |         __warn_flushing_systemwide_wq();                                \
>      |         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> /home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:408:17: note: in expansion of macro ‘flush_scheduled_work’
>  408 |                 flush_scheduled_work();
>      |                 ^~~~~~~~~~~~~~~~~~~~
> 
> Fixes:
> - http://autobuild.buildroot.org/results/6ac7a4601938d3296ed1657c06f8cdf433757d73
> - http://autobuild.buildroot.org/results/7997cc8a67645a6e1cf4e24d172c6feae459dcfb
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Thank you for the patch.
Reviewed-by: Giulio Benetti <giulio.benetti@benettiengineering.com>

Best regards
Giulio

> ---
> package/esp-hosted/esp-hosted.mk | 1 +
> 1 file changed, 1 insertion(+)
> 
> diff --git a/package/esp-hosted/esp-hosted.mk b/package/esp-hosted/esp-hosted.mk
> index cc61e39b36..02de3dbc52 100644
> --- a/package/esp-hosted/esp-hosted.mk
> +++ b/package/esp-hosted/esp-hosted.mk
> @@ -12,6 +12,7 @@ ESP_HOSTED_LICENSE_FILE = LICENSE
> ESP_HOSTED_MODULE_SUBDIRS = esp_hosted_ng/host
> 
> define ESP_HOSTED_LINUX_CONFIG_FIXUPS
> +    $(call KCONFIG_DISABLE_OPT,CONFIG_WERROR)
>    $(call KCONFIG_ENABLE_OPT,CONFIG_NET)
>    $(call KCONFIG_ENABLE_OPT,CONFIG_WIRELESS)
>    $(call KCONFIG_ENABLE_OPT,CONFIG_CFG80211)
> --
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard March 6, 2024, 3:52 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Disable -Werror to fix the following build failure raised at least since
 > commit a382a7d55432918d2a1e47ae4cbe7ed50fa17a08:

 > In function ‘destroy_cmd_wq’,
 >     inlined from ‘esp_commands_teardown’ at /home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:1467:2:
 > ./include/linux/workqueue.h:639:9: error: call to ‘__warn_flushing_systemwide_wq’ declared with attribute warning: Please avoid flushing system-wide workqueues. [-Werror=attribute-warning]
 >   639 |         __warn_flushing_systemwide_wq();                                \
 >       |         ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 > /home/autobuild/autobuild/instance-4/output-1/build/esp-hosted-ce3c50a33fa4bc562a1b6cbcee292c1ae0b0a404/esp_hosted_ng/host/esp_cmd.c:408:17:
 > note: in expansion of macro ‘flush_scheduled_work’
 >   408 |                 flush_scheduled_work();
 >       |                 ^~~~~~~~~~~~~~~~~~~~

 > Fixes:
 >  - http://autobuild.buildroot.org/results/6ac7a4601938d3296ed1657c06f8cdf433757d73
 >  - http://autobuild.buildroot.org/results/7997cc8a67645a6e1cf4e24d172c6feae459dcfb

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 > ---
 >  package/esp-hosted/esp-hosted.mk | 1 +
 >  1 file changed, 1 insertion(+)

 > diff --git a/package/esp-hosted/esp-hosted.mk b/package/esp-hosted/esp-hosted.mk
 > index cc61e39b36..02de3dbc52 100644
 > --- a/package/esp-hosted/esp-hosted.mk
 > +++ b/package/esp-hosted/esp-hosted.mk
 > @@ -12,6 +12,7 @@ ESP_HOSTED_LICENSE_FILE = LICENSE
 >  ESP_HOSTED_MODULE_SUBDIRS = esp_hosted_ng/host
 
 >  define ESP_HOSTED_LINUX_CONFIG_FIXUPS
 > +	$(call KCONFIG_DISABLE_OPT,CONFIG_WERROR)

I wonder if we shouldn't unconditionally disable CONFIG_WERROR in
linux.mk, similar to how we do for a number of other packages - The
Linux build could fail with warnings if a too old/new toolchain is used.

I doubt a lot of real defconfigs want to use CONFIG_WERROR, the problem
is most likely only for the arch defconfigs:

git grep CONFIG_WERROR=y
arch/x86/configs/i386_defconfig:CONFIG_WERROR=y
arch/x86/configs/x86_64_defconfig:CONFIG_WERROR=y
diff mbox series

Patch

diff --git a/package/esp-hosted/esp-hosted.mk b/package/esp-hosted/esp-hosted.mk
index cc61e39b36..02de3dbc52 100644
--- a/package/esp-hosted/esp-hosted.mk
+++ b/package/esp-hosted/esp-hosted.mk
@@ -12,6 +12,7 @@  ESP_HOSTED_LICENSE_FILE = LICENSE
 ESP_HOSTED_MODULE_SUBDIRS = esp_hosted_ng/host
 
 define ESP_HOSTED_LINUX_CONFIG_FIXUPS
+	$(call KCONFIG_DISABLE_OPT,CONFIG_WERROR)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_NET)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_WIRELESS)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_CFG80211)