diff mbox series

[1/1] package/php: add libucontext optional dependency

Message ID 20240305154003.1756299-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/php: add libucontext optional dependency | expand

Commit Message

Fabrice Fontaine March 5, 2024, 3:40 p.m. UTC
Select libucontext if the toolchain doesn't support ucontext to allow
building php on musl

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/php/Config.in | 3 +++
 package/php/php.mk    | 5 +++++
 2 files changed, 8 insertions(+)

Comments

Peter Korsgaard March 6, 2024, 2:18 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Select libucontext if the toolchain doesn't support ucontext to allow
 > building php on musl

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard March 21, 2024, 8:09 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Select libucontext if the toolchain doesn't support ucontext to allow
 > building php on musl

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2024.02.x and 2023.11.x, thanks.

We don't have libucontext on 2023.02.x.
diff mbox series

Patch

diff --git a/package/php/Config.in b/package/php/Config.in
index 69b4268c1d..af8574ac75 100644
--- a/package/php/Config.in
+++ b/package/php/Config.in
@@ -9,6 +9,7 @@  config BR2_PACKAGE_PHP_ARCH_SUPPORTS
 	default y if BR2_RISCV_64
 	default y if BR2_s390x
 	default y if BR2_TOOLCHAIN_HAS_UCONTEXT
+	default y if BR2_PACKAGE_LIBUCONTEXT_ARCH_SUPPORTS
 
 config BR2_PACKAGE_PHP
 	bool "php"
@@ -25,6 +26,8 @@  config BR2_PACKAGE_PHP
 	       BR2_USE_MMU
 	select BR2_PACKAGE_PHP_SAPI_CLI if !BR2_USE_MMU
 	select BR2_PACKAGE_PCRE2
+	select BR2_PACKAGE_LIBUCONTEXT if \
+		BR2_PACKAGE_LIBUCONTEXT_ARCH_SUPPORTS
 	help
 	  PHP  is a widely-used general-purpose scripting
 	  language that is especially suited for Web development
diff --git a/package/php/php.mk b/package/php/php.mk
index 4daf7f633d..28893be4c6 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -40,6 +40,11 @@  ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 PHP_EXTRA_LIBS += -latomic
 endif
 
+ifeq ($(BR2_PACKAGE_LIBUCONTEXT),y)
+PHP_DEPENDENCIES += libucontext
+PHP_EXTRA_LIBS += -lucontext
+endif
+
 ifeq ($(call qstrip,$(BR2_TARGET_LOCALTIME)),)
 PHP_LOCALTIME = UTC
 else