diff mbox series

package: linux-firmware: update linux fw bluetooth package for rtl88xx

Message ID 20240305070452.183573-1-karthikeyan@linumiz.com
State Accepted
Headers show
Series package: linux-firmware: update linux fw bluetooth package for rtl88xx | expand

Commit Message

karthikeyan March 5, 2024, 7:04 a.m. UTC
add realtek 8821cs bluetooth firmware in linux firmware package,
BR2_PACKAGE_LINUX_FIRMWARE_RTL_88XX_BT config for realtek 88xx family,
not device specific config to enable, add fw's in realtek 88xx family
in build instead of adding them separately.

Signed-off-by: Karthikeyan Krishnasamy <karthikeyan@linumiz.com>
---
 package/linux-firmware/linux-firmware.mk | 11 +----------
 1 file changed, 1 insertion(+), 10 deletions(-)

Comments

Arnout Vandecappelle April 7, 2024, 3:50 p.m. UTC | #1
On 05/03/2024 08:04, Karthikeyan Krishnasamy wrote:
> add realtek 8821cs bluetooth firmware in linux firmware package,
> BR2_PACKAGE_LINUX_FIRMWARE_RTL_88XX_BT config for realtek 88xx family,
> not device specific config to enable, add fw's in realtek 88xx family
> in build instead of adding them separately.

  I reworded this as follows.

     package/linux-firmware: RTL_88XX_BT: install all firmware

     Instead of enumerating each binary, which is cumbersome and may miss
     some of them, simply install all binaries starting with rtl88.


  Applied to master, thanks.

  Regards,
  Arnout

> 
> Signed-off-by: Karthikeyan Krishnasamy <karthikeyan@linumiz.com>
> ---
>   package/linux-firmware/linux-firmware.mk | 11 +----------
>   1 file changed, 1 insertion(+), 10 deletions(-)
> 
> diff --git a/package/linux-firmware/linux-firmware.mk b/package/linux-firmware/linux-firmware.mk
> index 60e8861abe..7e1e5cf6f2 100644
> --- a/package/linux-firmware/linux-firmware.mk
> +++ b/package/linux-firmware/linux-firmware.mk
> @@ -90,16 +90,7 @@ endif
>   # Realtek 88xx Bluetooth
>   ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_RTL_88XX_BT),y)
>   LINUX_FIRMWARE_FILES += \
> -	rtl_bt/rtl8812ae_fw.bin rtl_bt/rtl8821a_fw.bin \
> -	rtl_bt/rtl8821c_config.bin rtl_bt/rtl8821c_fw.bin \
> -	rtl_bt/rtl8822b_config.bin rtl_bt/rtl8822b_fw.bin \
> -	rtl_bt/rtl8822cs_config.bin rtl_bt/rtl8822cs_fw.bin \
> -	rtl_bt/rtl8822cu_config.bin rtl_bt/rtl8822cu_fw.bin \
> -	rtl_bt/rtl8851bu_fw.bin rtl_bt/rtl8851bu_config.bin \
> -	rtl_bt/rtl8852au_fw.bin rtl_bt/rtl8852au_config.bin \
> -	rtl_bt/rtl8852bu_fw.bin rtl_bt/rtl8852bu_config.bin \
> -	rtl_bt/rtl8852cu_fw.bin rtl_bt/rtl8852cu_config.bin \
> -	rtl_bt/rtl8852cu_fw_v2.bin
> +	rtl_bt/rtl88*_fw.bin rtl_bt/rtl88*_config.bin
>   LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.rtlwifi_firmware.txt
>   endif
>
Gero Schwäricke April 7, 2024, 8:38 p.m. UTC | #2
On Sun, Apr 07, 2024 at 05:50:50PM +0200, Arnout Vandecappelle via buildroot wrote:
> 
> 
> On 05/03/2024 08:04, Karthikeyan Krishnasamy wrote:
> > add realtek 8821cs bluetooth firmware in linux firmware package,
> > BR2_PACKAGE_LINUX_FIRMWARE_RTL_88XX_BT config for realtek 88xx family,
> > not device specific config to enable, add fw's in realtek 88xx family
> > in build instead of adding them separately.
> 
>  I reworded this as follows.
> 
>     package/linux-firmware: RTL_88XX_BT: install all firmware
> 
>     Instead of enumerating each binary, which is cumbersome and may miss
>     some of them, simply install all binaries starting with rtl88.
> 
> 
>  Applied to master, thanks.
> 
>  Regards,
>  Arnout

Hi,

just saw this commit. In effect it added new firmware blobs for
rtl8821cs and rtl8852btu, but also removed one for rtl8852cu, was this
intentional?

  $ diff old new
  4a5,6
  > rtl8821cs_config.bin
  > rtl8821cs_fw.bin
  14a17,18
  > rtl8852btu_config.bin
  > rtl8852btu_fw.bin
  18d21
  < rtl8852cu_fw_v2.bin

Best,
Gero

> 
> > 
> > Signed-off-by: Karthikeyan Krishnasamy <karthikeyan@linumiz.com>
> > ---
> >   package/linux-firmware/linux-firmware.mk | 11 +----------
> >   1 file changed, 1 insertion(+), 10 deletions(-)
> > 
> > diff --git a/package/linux-firmware/linux-firmware.mk b/package/linux-firmware/linux-firmware.mk
> > index 60e8861abe..7e1e5cf6f2 100644
> > --- a/package/linux-firmware/linux-firmware.mk
> > +++ b/package/linux-firmware/linux-firmware.mk
> > @@ -90,16 +90,7 @@ endif
> >   # Realtek 88xx Bluetooth
> >   ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_RTL_88XX_BT),y)
> >   LINUX_FIRMWARE_FILES += \
> > -	rtl_bt/rtl8812ae_fw.bin rtl_bt/rtl8821a_fw.bin \
> > -	rtl_bt/rtl8821c_config.bin rtl_bt/rtl8821c_fw.bin \
> > -	rtl_bt/rtl8822b_config.bin rtl_bt/rtl8822b_fw.bin \
> > -	rtl_bt/rtl8822cs_config.bin rtl_bt/rtl8822cs_fw.bin \
> > -	rtl_bt/rtl8822cu_config.bin rtl_bt/rtl8822cu_fw.bin \
> > -	rtl_bt/rtl8851bu_fw.bin rtl_bt/rtl8851bu_config.bin \
> > -	rtl_bt/rtl8852au_fw.bin rtl_bt/rtl8852au_config.bin \
> > -	rtl_bt/rtl8852bu_fw.bin rtl_bt/rtl8852bu_config.bin \
> > -	rtl_bt/rtl8852cu_fw.bin rtl_bt/rtl8852cu_config.bin \
> > -	rtl_bt/rtl8852cu_fw_v2.bin
> > +	rtl_bt/rtl88*_fw.bin rtl_bt/rtl88*_config.bin
> >   LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.rtlwifi_firmware.txt
> >   endif
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Arnout Vandecappelle April 10, 2024, 8:06 a.m. UTC | #3
On 07/04/2024 22:38, Gero Schwäricke wrote:
> On Sun, Apr 07, 2024 at 05:50:50PM +0200, Arnout Vandecappelle via buildroot wrote:
>>
>>
>> On 05/03/2024 08:04, Karthikeyan Krishnasamy wrote:
>>> add realtek 8821cs bluetooth firmware in linux firmware package,
>>> BR2_PACKAGE_LINUX_FIRMWARE_RTL_88XX_BT config for realtek 88xx family,
>>> not device specific config to enable, add fw's in realtek 88xx family
>>> in build instead of adding them separately.
>>
>>   I reworded this as follows.
>>
>>      package/linux-firmware: RTL_88XX_BT: install all firmware
>>
>>      Instead of enumerating each binary, which is cumbersome and may miss
>>      some of them, simply install all binaries starting with rtl88.
>>
>>
>>   Applied to master, thanks.
>>
>>   Regards,
>>   Arnout
> 
> Hi,
> 
> just saw this commit. In effect it added new firmware blobs for
> rtl8821cs and rtl8852btu, but also removed one for rtl8852cu, was this
> intentional?
> 
>    $ diff old new
>    4a5,6
>    > rtl8821cs_config.bin
>    > rtl8821cs_fw.bin
>    14a17,18
>    > rtl8852btu_config.bin
>    > rtl8852btu_fw.bin

  This is the purpose of the patch.

>    18d21
>    < rtl8852cu_fw_v2.bin

  This is definitely not intentional. I clearly didn't test the patch enough 
before applying :-(

  Care to send a fix?  I think the easiest is to change the pattern to 
rtl88*.bin, but it needs to be verified.

  Regards,
  Arnout

> 
> Best,
> Gero
> 
>>
>>>
>>> Signed-off-by: Karthikeyan Krishnasamy <karthikeyan@linumiz.com>
>>> ---
>>>    package/linux-firmware/linux-firmware.mk | 11 +----------
>>>    1 file changed, 1 insertion(+), 10 deletions(-)
>>>
>>> diff --git a/package/linux-firmware/linux-firmware.mk b/package/linux-firmware/linux-firmware.mk
>>> index 60e8861abe..7e1e5cf6f2 100644
>>> --- a/package/linux-firmware/linux-firmware.mk
>>> +++ b/package/linux-firmware/linux-firmware.mk
>>> @@ -90,16 +90,7 @@ endif
>>>    # Realtek 88xx Bluetooth
>>>    ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_RTL_88XX_BT),y)
>>>    LINUX_FIRMWARE_FILES += \
>>> -	rtl_bt/rtl8812ae_fw.bin rtl_bt/rtl8821a_fw.bin \
>>> -	rtl_bt/rtl8821c_config.bin rtl_bt/rtl8821c_fw.bin \
>>> -	rtl_bt/rtl8822b_config.bin rtl_bt/rtl8822b_fw.bin \
>>> -	rtl_bt/rtl8822cs_config.bin rtl_bt/rtl8822cs_fw.bin \
>>> -	rtl_bt/rtl8822cu_config.bin rtl_bt/rtl8822cu_fw.bin \
>>> -	rtl_bt/rtl8851bu_fw.bin rtl_bt/rtl8851bu_config.bin \
>>> -	rtl_bt/rtl8852au_fw.bin rtl_bt/rtl8852au_config.bin \
>>> -	rtl_bt/rtl8852bu_fw.bin rtl_bt/rtl8852bu_config.bin \
>>> -	rtl_bt/rtl8852cu_fw.bin rtl_bt/rtl8852cu_config.bin \
>>> -	rtl_bt/rtl8852cu_fw_v2.bin
>>> +	rtl_bt/rtl88*_fw.bin rtl_bt/rtl88*_config.bin
>>>    LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.rtlwifi_firmware.txt
>>>    endif
>> _______________________________________________
>> buildroot mailing list
>> buildroot@buildroot.org
>> https://lists.buildroot.org/mailman/listinfo/buildroot
Gero Schwäricke April 17, 2024, 9:10 p.m. UTC | #4
Hi Arnout,

On Wed, Apr 10, 2024 at 10:06:08AM +0200, Arnout Vandecappelle via buildroot wrote:
> 
> On 07/04/2024 22:38, Gero Schwäricke wrote:
[snip]
> > 
> > just saw this commit. In effect it added new firmware blobs for
> > rtl8821cs and rtl8852btu, but also removed one for rtl8852cu, was this
> > intentional?
> > 
> >    $ diff old new
> >    4a5,6
> >    > rtl8821cs_config.bin
> >    > rtl8821cs_fw.bin
> >    14a17,18
> >    > rtl8852btu_config.bin
> >    > rtl8852btu_fw.bin
> 
>  This is the purpose of the patch.
> 
> >    18d21
> >    < rtl8852cu_fw_v2.bin
> 
>  This is definitely not intentional. I clearly didn't test the patch enough
> before applying :-(
> 
>  Care to send a fix?  I think the easiest is to change the pattern to
> rtl88*.bin, but it needs to be verified.

I just send the patch. For testing I recorded the firmware package with

  tar --list --file output/build/linux-firmware-20240115/br-firmware.tar | sort > /tmp/.old  # and /tmp/.new

The diff is then

  $ diff /tmp/.old /tmp/.new 
  22a23
  > rtl_bt/rtl8852cu_fw_v2.bin

Seems to work as intended.

I noticed though that due to the new globbing approach the kconfig help
string is outdated. I'll send that as a separate patch.

Best,
Gero

> 
>  Regards,
>  Arnout
> 
> > 
> > Best,
> > Gero
[snip]
diff mbox series

Patch

diff --git a/package/linux-firmware/linux-firmware.mk b/package/linux-firmware/linux-firmware.mk
index 60e8861abe..7e1e5cf6f2 100644
--- a/package/linux-firmware/linux-firmware.mk
+++ b/package/linux-firmware/linux-firmware.mk
@@ -90,16 +90,7 @@  endif
 # Realtek 88xx Bluetooth
 ifeq ($(BR2_PACKAGE_LINUX_FIRMWARE_RTL_88XX_BT),y)
 LINUX_FIRMWARE_FILES += \
-	rtl_bt/rtl8812ae_fw.bin rtl_bt/rtl8821a_fw.bin \
-	rtl_bt/rtl8821c_config.bin rtl_bt/rtl8821c_fw.bin \
-	rtl_bt/rtl8822b_config.bin rtl_bt/rtl8822b_fw.bin \
-	rtl_bt/rtl8822cs_config.bin rtl_bt/rtl8822cs_fw.bin \
-	rtl_bt/rtl8822cu_config.bin rtl_bt/rtl8822cu_fw.bin \
-	rtl_bt/rtl8851bu_fw.bin rtl_bt/rtl8851bu_config.bin \
-	rtl_bt/rtl8852au_fw.bin rtl_bt/rtl8852au_config.bin \
-	rtl_bt/rtl8852bu_fw.bin rtl_bt/rtl8852bu_config.bin \
-	rtl_bt/rtl8852cu_fw.bin rtl_bt/rtl8852cu_config.bin \
-	rtl_bt/rtl8852cu_fw_v2.bin
+	rtl_bt/rtl88*_fw.bin rtl_bt/rtl88*_config.bin
 LINUX_FIRMWARE_ALL_LICENSE_FILES += LICENCE.rtlwifi_firmware.txt
 endif