diff mbox series

[1/1] package/poco: fix BR2_SHARED_STATIC_LIBS build

Message ID 20240304170723.3908730-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/poco: fix BR2_SHARED_STATIC_LIBS build | expand

Commit Message

Fabrice Fontaine March 4, 2024, 5:07 p.m. UTC
poco can't be built statically since commit
073a89196a22f995c142cd11640d3cfb7cef691d. However, commit
add7c433d250e153d9e58fe7da3bd52171ba2652 enabled static (and shared)
build with BR2_SHARED_STATIC_LIBS resulting in the following build
failure since at least version 1.11.1:

/home/buildroot/autobuild/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips-buildroot-linux-gnu/11.2.0/../../../../mips-buildroot-linux-gnu/bin/ld: /home/buildroot/autobuild/instance-1/output-1/build/poco-1.11.1/lib/Linux/mips/libPocoXML.a(ParserEngine.o): in function `Poco::XML::ParserEngine::handleStartElement(void*, char const*, char const**)':
ParserEngine.cpp:(.text+0x2f8): undefined reference to `XML_GetSpecifiedAttributeCount'

Fixes: add7c433d250e153d9e58fe7da3bd52171ba2652
 - http://autobuild.buildroot.org/results/afc434a13d5e7a8affa4abb4058d7bebc81aca29
 - http://autobuild.buildroot.org/results/860b70a8c9c4a6a53247ac4bdb4fd0851b28c61a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/poco/poco.mk | 6 ------
 1 file changed, 6 deletions(-)

Comments

Peter Korsgaard March 4, 2024, 9:51 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > poco can't be built statically since commit
 > 073a89196a22f995c142cd11640d3cfb7cef691d. However, commit
 > add7c433d250e153d9e58fe7da3bd52171ba2652 enabled static (and shared)
 > build with BR2_SHARED_STATIC_LIBS resulting in the following build
 > failure since at least version 1.11.1:

 > /home/buildroot/autobuild/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips-buildroot-linux-gnu/11.2.0/../../../../mips-buildroot-linux-gnu/bin/ld:
 > /home/buildroot/autobuild/instance-1/output-1/build/poco-1.11.1/lib/Linux/mips/libPocoXML.a(ParserEngine.o):
 > in function `Poco::XML::ParserEngine::handleStartElement(void*, char
 > const*, char const**)':
 > ParserEngine.cpp:(.text+0x2f8): undefined reference to `XML_GetSpecifiedAttributeCount'

 > Fixes: add7c433d250e153d9e58fe7da3bd52171ba2652
 >  - http://autobuild.buildroot.org/results/afc434a13d5e7a8affa4abb4058d7bebc81aca29
 >  - http://autobuild.buildroot.org/results/860b70a8c9c4a6a53247ac4bdb4fd0851b28c61a

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard March 19, 2024, 4:35 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > poco can't be built statically since commit
 > 073a89196a22f995c142cd11640d3cfb7cef691d. However, commit
 > add7c433d250e153d9e58fe7da3bd52171ba2652 enabled static (and shared)
 > build with BR2_SHARED_STATIC_LIBS resulting in the following build
 > failure since at least version 1.11.1:

 > /home/buildroot/autobuild/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mips-buildroot-linux-gnu/11.2.0/../../../../mips-buildroot-linux-gnu/bin/ld:
 > /home/buildroot/autobuild/instance-1/output-1/build/poco-1.11.1/lib/Linux/mips/libPocoXML.a(ParserEngine.o):
 > in function `Poco::XML::ParserEngine::handleStartElement(void*, char
 > const*, char const**)':
 > ParserEngine.cpp:(.text+0x2f8): undefined reference to `XML_GetSpecifiedAttributeCount'

 > Fixes: add7c433d250e153d9e58fe7da3bd52171ba2652
 >  - http://autobuild.buildroot.org/results/afc434a13d5e7a8affa4abb4058d7bebc81aca29
 >  - http://autobuild.buildroot.org/results/860b70a8c9c4a6a53247ac4bdb4fd0851b28c61a

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2023.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/poco/poco.mk b/package/poco/poco.mk
index f8c2a658de..96ab28fb01 100644
--- a/package/poco/poco.mk
+++ b/package/poco/poco.mk
@@ -57,13 +57,7 @@  ifeq ($(BR2_SOFT_FLOAT),y)
 POCO_CONF_OPTS += --no-fpenvironment
 endif
 
-ifeq ($(BR2_STATIC_LIBS),y)
-POCO_MAKE_TARGET = static_release
-else ifeq ($(BR2_SHARED_LIBS),y)
 POCO_MAKE_TARGET = shared_release
-else ifeq ($(BR2_SHARED_STATIC_LIBS),y)
-POCO_MAKE_TARGET = all_release
-endif
 
 POCO_LDFLAGS=$(TARGET_LDFLAGS)
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)