diff mbox series

[1/1] package/tllist: fix build with gcc 4.8

Message ID 20240304155426.3510178-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/tllist: fix build with gcc 4.8 | expand

Commit Message

Fabrice Fontaine March 4, 2024, 3:54 p.m. UTC
Fix the following build failure with gcc 4.8 raised since the addition
of the package in commit 996b786cfc03c3cf2ac631045650545c901e3075:

In file included from ../test.c:7:0:
../test.c: In function 'main':
../tllist.h:213:17: error: 'for' loop initial declarations are only allowed in C99 mode
                 for (int _i = 0; _i < __insize; _i++) {                 \
                 ^

Fixes: 996b786cfc03c3cf2ac631045650545c901e3075
 - http://autobuild.buildroot.org/results/e82fdf4f9ef199e1baa169d38a75872bddd4e6dd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/tllist/tllist.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Peter Korsgaard March 4, 2024, 9:48 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure with gcc 4.8 raised since the addition
 > of the package in commit 996b786cfc03c3cf2ac631045650545c901e3075:

 > In file included from ../test.c:7:0:
 > ../test.c: In function 'main':
 > ../tllist.h:213:17: error: 'for' loop initial declarations are only allowed in C99 mode
 >                  for (int _i = 0; _i < __insize; _i++) {                 \
 >                  ^

 > Fixes: 996b786cfc03c3cf2ac631045650545c901e3075
 >  - http://autobuild.buildroot.org/results/e82fdf4f9ef199e1baa169d38a75872bddd4e6dd

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/tllist/tllist.mk b/package/tllist/tllist.mk
index 88a28d2427..69a34a65ab 100644
--- a/package/tllist/tllist.mk
+++ b/package/tllist/tllist.mk
@@ -12,5 +12,6 @@  TLLIST_LICENSE_FILES = LICENSE
 # header only
 TLLIST_INSTALL_TARGET = NO
 TLLIST_INSTALL_STAGING = YES
+TLLIST_CFLAGS = $(TARGET_CFLAGS) -std=c99
 
 $(eval $(meson-package))