diff mbox series

[v9,11/22] boot/ti-k3-r5-loader: set binman environment

Message ID 20240304153253.732708-12-dario.binacchi@amarulasolutions.com
State Changes Requested
Headers show
Series Add support for AM62x-SK HS-FS devices | expand

Commit Message

Dario Binacchi March 4, 2024, 3:32 p.m. UTC
Recent version of U-Boot use binman to provide a mechanism for building
images, from simple SPL + U-Boot combinations, to more complex
arrangements with many parts.

The patch set the BINMAN_INDIRS environment variable to provide the
directory to search for binary blobs and select the packages required by
binman.

The dependency of binman is not really easy to follow. First we have the
packages list from binman.rst [1] then we have to install additional python
modules [2]. Maybe in the future it will be necessary to add host-lzma and
host-lz4 in the dependencies list.

[1] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/binman/binman.rst?plain=1#L377
[2] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/buildman/requirements.txt
Co-developed-by: Michael Trimarchi <michael@amarulasolutions.com>
Signed-off-by: Michael Trimarchi <michael@amarulasolutions.com>
Co-developed-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>

---

Changes in v6:
- Update the commit message adding the links of requirements.

Changes in v5:
- Add dependecy on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS
- Drop runtime dependecies
- Add host-python-pylibfdt dependency without requiring
  BR2_TARGET_UBOOT_NEEDS_PYLIBFDT configuration
- Add host-python3 and host-python-setuptools dependencies
- Add SOB and COB tags of Romain Naour

Changes in v4:
- Drop the BR2_TARGET_TI_K3_R5_LOADER_USE_BINMAN option

Changes in v2:
- Change commit message
- Add BR2_TARGET_TI_K3_R5_LOADER_USE_BINMAN option
- Select packages required by binman if
  BR2_TARGET_TI_K3_R5_LOADER_USE_BINMAN is enabled

 boot/ti-k3-r5-loader/Config.in          | 1 +
 boot/ti-k3-r5-loader/ti-k3-r5-loader.mk | 8 +++++++-
 2 files changed, 8 insertions(+), 1 deletion(-)

Comments

Bryan Brattlof March 19, 2024, 3:16 p.m. UTC | #1
Hi Dario,

On March  4, 2024 thus sayeth Dario Binacchi:
> Recent version of U-Boot use binman to provide a mechanism for building
> images, from simple SPL + U-Boot combinations, to more complex
> arrangements with many parts.
> 
> The patch set the BINMAN_INDIRS environment variable to provide the
> directory to search for binary blobs and select the packages required by
> binman.
> 
> The dependency of binman is not really easy to follow. First we have the
> packages list from binman.rst [1] then we have to install additional python
> modules [2]. Maybe in the future it will be necessary to add host-lzma and
> host-lz4 in the dependencies list.
> 
> [1] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/binman/binman.rst?plain=1#L377
> [2] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/buildman/requirements.txt
> Co-developed-by: Michael Trimarchi <michael@amarulasolutions.com>
> Signed-off-by: Michael Trimarchi <michael@amarulasolutions.com>
> Co-developed-by: Romain Naour <romain.naour@smile.fr>
> Signed-off-by: Romain Naour <romain.naour@smile.fr>
> Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
> 
> ---
> 

...

> diff --git a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk 
> b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> index 0ffcb8235f2e..fdb058f3b72a 100644
> --- a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> +++ b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> @@ -39,7 +39,12 @@ TI_K3_R5_LOADER_DEPENDENCIES = \
>  	host-pkgconf \
>  	$(BR2_MAKE_HOST_DEPENDENCY) \
>  	host-arm-gnu-toolchain \
> -	host-openssl
> +	host-openssl \
> +	host-python-jsonschema \
> +	host-python-pyyaml \
> +	host-python3 \
> +	host-python-setuptools \
> +	host-python-pylibfdt

Just a question on how boot dependencies are resolved. Do we need to add 
ti-k3-boot-firmware to this list? How does ti-k3-r5-loader know to 
'build' the firmware before we build tiboot3.bin?

~Bryan
Romain Naour April 3, 2024, 8:28 a.m. UTC | #2
Hello Bryan, All,

Le 19/03/2024 à 16:16, Bryan Brattlof a écrit :
> Hi Dario,
> 
> On March  4, 2024 thus sayeth Dario Binacchi:
>> Recent version of U-Boot use binman to provide a mechanism for building
>> images, from simple SPL + U-Boot combinations, to more complex
>> arrangements with many parts.
>>
>> The patch set the BINMAN_INDIRS environment variable to provide the
>> directory to search for binary blobs and select the packages required by
>> binman.
>>
>> The dependency of binman is not really easy to follow. First we have the
>> packages list from binman.rst [1] then we have to install additional python
>> modules [2]. Maybe in the future it will be necessary to add host-lzma and
>> host-lz4 in the dependencies list.
>>
>> [1] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/binman/binman.rst?plain=1#L377
>> [2] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/buildman/requirements.txt
>> Co-developed-by: Michael Trimarchi <michael@amarulasolutions.com>
>> Signed-off-by: Michael Trimarchi <michael@amarulasolutions.com>
>> Co-developed-by: Romain Naour <romain.naour@smile.fr>
>> Signed-off-by: Romain Naour <romain.naour@smile.fr>
>> Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
>>
>> ---
>>
> 
> ...
> 
>> diff --git a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk 
>> b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
>> index 0ffcb8235f2e..fdb058f3b72a 100644
>> --- a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
>> +++ b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
>> @@ -39,7 +39,12 @@ TI_K3_R5_LOADER_DEPENDENCIES = \
>>  	host-pkgconf \
>>  	$(BR2_MAKE_HOST_DEPENDENCY) \
>>  	host-arm-gnu-toolchain \
>> -	host-openssl
>> +	host-openssl \
>> +	host-python-jsonschema \
>> +	host-python-pyyaml \
>> +	host-python3 \
>> +	host-python-setuptools \
>> +	host-python-pylibfdt
> 
> Just a question on how boot dependencies are resolved. Do we need to add 
> ti-k3-boot-firmware to this list? How does ti-k3-r5-loader know to 
> 'build' the firmware before we build tiboot3.bin?

Indeed, without ti-k3-boot-firmware package installed, binman warn about
"Missing blob"

make ti_am62x_sk_defconfig
make ti-k3-r5-loader

  BINMAN  .binman_stamp
Image 'tiboot3-am62x-hs-evm.bin' is missing optional external blobs but is still
functional: ti-fs-enc.bin sysfw-inner-cert

/binman/tiboot3-am62x-hs-evm.bin/ti-fs-enc.bin
(ti-sysfw/ti-fs-firmware-am62x-hs-enc.bin):
   Missing blob

/binman/tiboot3-am62x-hs-evm.bin/sysfw-inner-cert
(ti-sysfw/ti-fs-firmware-am62x-hs-cert.bin):
   Missing blob

Image 'tiboot3-am62x-hs-fs-evm.bin' is missing optional external blobs but is
still functional: ti-fs-enc.bin sysfw-inner-cert

/binman/tiboot3-am62x-hs-fs-evm.bin/ti-fs-enc.bin
(ti-sysfw/ti-fs-firmware-am62x-hs-fs-enc.bin):
   Missing blob

/binman/tiboot3-am62x-hs-fs-evm.bin/sysfw-inner-cert
(ti-sysfw/ti-fs-firmware-am62x-hs-fs-cert.bin):
   Missing blob

Image 'tiboot3-am62x-gp-evm.bin' is missing optional external blobs but is still
functional: ti-fs-gp.bin

/binman/tiboot3-am62x-gp-evm.bin/ti-fs-gp.bin
(ti-sysfw/ti-fs-firmware-am62x-gp.bin):
   Missing blob

  OFCHK   .config

So, we should add ti-k3-boot-firmware in dependencies to avoid building
ti-k3-r5-loader before ti-k3-boot-firmware.

When building the AM6 defconfig, the build order is ordered alphabetically by
default and ti-k3-boot-firmware is installed before ti-k3-r5-loader.

Best regards,
Romain


> 
> ~Bryan
Michael Nazzareno Trimarchi April 3, 2024, 8:34 a.m. UTC | #3
Hi Romain

On Wed, Apr 3, 2024 at 10:28 AM Romain Naour <romain.naour@smile.fr> wrote:
>
> Hello Bryan, All,
>
> Le 19/03/2024 à 16:16, Bryan Brattlof a écrit :
> > Hi Dario,
> >
> > On March  4, 2024 thus sayeth Dario Binacchi:
> >> Recent version of U-Boot use binman to provide a mechanism for building
> >> images, from simple SPL + U-Boot combinations, to more complex
> >> arrangements with many parts.
> >>
> >> The patch set the BINMAN_INDIRS environment variable to provide the
> >> directory to search for binary blobs and select the packages required by
> >> binman.
> >>
> >> The dependency of binman is not really easy to follow. First we have the
> >> packages list from binman.rst [1] then we have to install additional python
> >> modules [2]. Maybe in the future it will be necessary to add host-lzma and
> >> host-lz4 in the dependencies list.
> >>
> >> [1] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/binman/binman.rst?plain=1#L377
> >> [2] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/buildman/requirements.txt
> >> Co-developed-by: Michael Trimarchi <michael@amarulasolutions.com>
> >> Signed-off-by: Michael Trimarchi <michael@amarulasolutions.com>
> >> Co-developed-by: Romain Naour <romain.naour@smile.fr>
> >> Signed-off-by: Romain Naour <romain.naour@smile.fr>
> >> Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
> >>
> >> ---
> >>
> >
> > ...
> >
> >> diff --git a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> >> b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> >> index 0ffcb8235f2e..fdb058f3b72a 100644
> >> --- a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> >> +++ b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> >> @@ -39,7 +39,12 @@ TI_K3_R5_LOADER_DEPENDENCIES = \
> >>      host-pkgconf \
> >>      $(BR2_MAKE_HOST_DEPENDENCY) \
> >>      host-arm-gnu-toolchain \
> >> -    host-openssl
> >> +    host-openssl \
> >> +    host-python-jsonschema \
> >> +    host-python-pyyaml \
> >> +    host-python3 \
> >> +    host-python-setuptools \
> >> +    host-python-pylibfdt
> >
> > Just a question on how boot dependencies are resolved. Do we need to add
> > ti-k3-boot-firmware to this list? How does ti-k3-r5-loader know to
> > 'build' the firmware before we build tiboot3.bin?
>
> Indeed, without ti-k3-boot-firmware package installed, binman warn about
> "Missing blob"
>
> make ti_am62x_sk_defconfig
> make ti-k3-r5-loader
>
>   BINMAN  .binman_stamp
> Image 'tiboot3-am62x-hs-evm.bin' is missing optional external blobs but is still
> functional: ti-fs-enc.bin sysfw-inner-cert
>
> /binman/tiboot3-am62x-hs-evm.bin/ti-fs-enc.bin
> (ti-sysfw/ti-fs-firmware-am62x-hs-enc.bin):
>    Missing blob
>
> /binman/tiboot3-am62x-hs-evm.bin/sysfw-inner-cert
> (ti-sysfw/ti-fs-firmware-am62x-hs-cert.bin):
>    Missing blob
>
> Image 'tiboot3-am62x-hs-fs-evm.bin' is missing optional external blobs but is
> still functional: ti-fs-enc.bin sysfw-inner-cert
>
> /binman/tiboot3-am62x-hs-fs-evm.bin/ti-fs-enc.bin
> (ti-sysfw/ti-fs-firmware-am62x-hs-fs-enc.bin):
>    Missing blob
>
> /binman/tiboot3-am62x-hs-fs-evm.bin/sysfw-inner-cert
> (ti-sysfw/ti-fs-firmware-am62x-hs-fs-cert.bin):
>    Missing blob
>
> Image 'tiboot3-am62x-gp-evm.bin' is missing optional external blobs but is still
> functional: ti-fs-gp.bin
>
> /binman/tiboot3-am62x-gp-evm.bin/ti-fs-gp.bin
> (ti-sysfw/ti-fs-firmware-am62x-gp.bin):
>    Missing blob
>
>   OFCHK   .config
>
> So, we should add ti-k3-boot-firmware in dependencies to avoid building
> ti-k3-r5-loader before ti-k3-boot-firmware.
>
> When building the AM6 defconfig, the build order is ordered alphabetically by
> default and ti-k3-boot-firmware is installed before ti-k3-r5-loader.
>

OK, this is a valid point. Anyway what you suggest force select or a
depend. If you have more points, is better to write down all of
them in one review, and not split as now every new patcheset. What do you think?

Michael

> Best regards,
> Romain
>
>
> >
> > ~Bryan
>
Romain Naour April 3, 2024, 9:37 a.m. UTC | #4
Hi Michael,

Le 03/04/2024 à 10:34, Michael Nazzareno Trimarchi a écrit :
> Hi Romain
> 
> On Wed, Apr 3, 2024 at 10:28 AM Romain Naour <romain.naour@smile.fr> wrote:
>>
>> Hello Bryan, All,
>>
>> Le 19/03/2024 à 16:16, Bryan Brattlof a écrit :
>>> Hi Dario,
>>>
>>> On March  4, 2024 thus sayeth Dario Binacchi:
>>>> Recent version of U-Boot use binman to provide a mechanism for building
>>>> images, from simple SPL + U-Boot combinations, to more complex
>>>> arrangements with many parts.
>>>>
>>>> The patch set the BINMAN_INDIRS environment variable to provide the
>>>> directory to search for binary blobs and select the packages required by
>>>> binman.
>>>>
>>>> The dependency of binman is not really easy to follow. First we have the
>>>> packages list from binman.rst [1] then we have to install additional python
>>>> modules [2]. Maybe in the future it will be necessary to add host-lzma and
>>>> host-lz4 in the dependencies list.
>>>>
>>>> [1] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/binman/binman.rst?plain=1#L377
>>>> [2] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/buildman/requirements.txt
>>>> Co-developed-by: Michael Trimarchi <michael@amarulasolutions.com>
>>>> Signed-off-by: Michael Trimarchi <michael@amarulasolutions.com>
>>>> Co-developed-by: Romain Naour <romain.naour@smile.fr>
>>>> Signed-off-by: Romain Naour <romain.naour@smile.fr>
>>>> Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
>>>>
>>>> ---
>>>>
>>>
>>> ...
>>>
>>>> diff --git a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
>>>> b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
>>>> index 0ffcb8235f2e..fdb058f3b72a 100644
>>>> --- a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
>>>> +++ b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
>>>> @@ -39,7 +39,12 @@ TI_K3_R5_LOADER_DEPENDENCIES = \
>>>>      host-pkgconf \
>>>>      $(BR2_MAKE_HOST_DEPENDENCY) \
>>>>      host-arm-gnu-toolchain \
>>>> -    host-openssl
>>>> +    host-openssl \
>>>> +    host-python-jsonschema \
>>>> +    host-python-pyyaml \
>>>> +    host-python3 \
>>>> +    host-python-setuptools \
>>>> +    host-python-pylibfdt
>>>
>>> Just a question on how boot dependencies are resolved. Do we need to add
>>> ti-k3-boot-firmware to this list? How does ti-k3-r5-loader know to
>>> 'build' the firmware before we build tiboot3.bin?
>>
>> Indeed, without ti-k3-boot-firmware package installed, binman warn about
>> "Missing blob"
>>
>> make ti_am62x_sk_defconfig
>> make ti-k3-r5-loader
>>
>>   BINMAN  .binman_stamp
>> Image 'tiboot3-am62x-hs-evm.bin' is missing optional external blobs but is still
>> functional: ti-fs-enc.bin sysfw-inner-cert
>>
>> /binman/tiboot3-am62x-hs-evm.bin/ti-fs-enc.bin
>> (ti-sysfw/ti-fs-firmware-am62x-hs-enc.bin):
>>    Missing blob
>>
>> /binman/tiboot3-am62x-hs-evm.bin/sysfw-inner-cert
>> (ti-sysfw/ti-fs-firmware-am62x-hs-cert.bin):
>>    Missing blob
>>
>> Image 'tiboot3-am62x-hs-fs-evm.bin' is missing optional external blobs but is
>> still functional: ti-fs-enc.bin sysfw-inner-cert
>>
>> /binman/tiboot3-am62x-hs-fs-evm.bin/ti-fs-enc.bin
>> (ti-sysfw/ti-fs-firmware-am62x-hs-fs-enc.bin):
>>    Missing blob
>>
>> /binman/tiboot3-am62x-hs-fs-evm.bin/sysfw-inner-cert
>> (ti-sysfw/ti-fs-firmware-am62x-hs-fs-cert.bin):
>>    Missing blob
>>
>> Image 'tiboot3-am62x-gp-evm.bin' is missing optional external blobs but is still
>> functional: ti-fs-gp.bin
>>
>> /binman/tiboot3-am62x-gp-evm.bin/ti-fs-gp.bin
>> (ti-sysfw/ti-fs-firmware-am62x-gp.bin):
>>    Missing blob
>>
>>   OFCHK   .config
>>
>> So, we should add ti-k3-boot-firmware in dependencies to avoid building
>> ti-k3-r5-loader before ti-k3-boot-firmware.
>>
>> When building the AM6 defconfig, the build order is ordered alphabetically by
>> default and ti-k3-boot-firmware is installed before ti-k3-r5-loader.
>>
> 
> OK, this is a valid point. Anyway what you suggest force select or a
> depend. If you have more points, is better to write down all of
> them in one review, and not split as now every new patcheset. What do you think?
> 

I reviewed the series already and make some suggestions that were not included.
Same about the review from Bryan (this one) and Andreas (make HS-FS the default
for AM62 and AM64).

I'm working on a V11 including some Buildroot rework, the BSP itself is ok.

Best regards,
Romain


> Michael
> 
>> Best regards,
>> Romain
>>
>>
>>>
>>> ~Bryan
>>
> 
>
Michael Nazzareno Trimarchi April 3, 2024, 9:46 a.m. UTC | #5
Hi Romain

On Wed, Apr 3, 2024 at 11:38 AM Romain Naour <romain.naour@smile.fr> wrote:
>
> Hi Michael,
>
> Le 03/04/2024 à 10:34, Michael Nazzareno Trimarchi a écrit :
> > Hi Romain
> >
> > On Wed, Apr 3, 2024 at 10:28 AM Romain Naour <romain.naour@smile.fr> wrote:
> >>
> >> Hello Bryan, All,
> >>
> >> Le 19/03/2024 à 16:16, Bryan Brattlof a écrit :
> >>> Hi Dario,
> >>>
> >>> On March  4, 2024 thus sayeth Dario Binacchi:
> >>>> Recent version of U-Boot use binman to provide a mechanism for building
> >>>> images, from simple SPL + U-Boot combinations, to more complex
> >>>> arrangements with many parts.
> >>>>
> >>>> The patch set the BINMAN_INDIRS environment variable to provide the
> >>>> directory to search for binary blobs and select the packages required by
> >>>> binman.
> >>>>
> >>>> The dependency of binman is not really easy to follow. First we have the
> >>>> packages list from binman.rst [1] then we have to install additional python
> >>>> modules [2]. Maybe in the future it will be necessary to add host-lzma and
> >>>> host-lz4 in the dependencies list.
> >>>>
> >>>> [1] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/binman/binman.rst?plain=1#L377
> >>>> [2] https://source.denx.de/u-boot/u-boot/-/blob/v2024.01/tools/buildman/requirements.txt
> >>>> Co-developed-by: Michael Trimarchi <michael@amarulasolutions.com>
> >>>> Signed-off-by: Michael Trimarchi <michael@amarulasolutions.com>
> >>>> Co-developed-by: Romain Naour <romain.naour@smile.fr>
> >>>> Signed-off-by: Romain Naour <romain.naour@smile.fr>
> >>>> Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
> >>>>
> >>>> ---
> >>>>
> >>>
> >>> ...
> >>>
> >>>> diff --git a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> >>>> b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> >>>> index 0ffcb8235f2e..fdb058f3b72a 100644
> >>>> --- a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> >>>> +++ b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
> >>>> @@ -39,7 +39,12 @@ TI_K3_R5_LOADER_DEPENDENCIES = \
> >>>>      host-pkgconf \
> >>>>      $(BR2_MAKE_HOST_DEPENDENCY) \
> >>>>      host-arm-gnu-toolchain \
> >>>> -    host-openssl
> >>>> +    host-openssl \
> >>>> +    host-python-jsonschema \
> >>>> +    host-python-pyyaml \
> >>>> +    host-python3 \
> >>>> +    host-python-setuptools \
> >>>> +    host-python-pylibfdt
> >>>
> >>> Just a question on how boot dependencies are resolved. Do we need to add
> >>> ti-k3-boot-firmware to this list? How does ti-k3-r5-loader know to
> >>> 'build' the firmware before we build tiboot3.bin?
> >>
> >> Indeed, without ti-k3-boot-firmware package installed, binman warn about
> >> "Missing blob"
> >>
> >> make ti_am62x_sk_defconfig
> >> make ti-k3-r5-loader
> >>
> >>   BINMAN  .binman_stamp
> >> Image 'tiboot3-am62x-hs-evm.bin' is missing optional external blobs but is still
> >> functional: ti-fs-enc.bin sysfw-inner-cert
> >>
> >> /binman/tiboot3-am62x-hs-evm.bin/ti-fs-enc.bin
> >> (ti-sysfw/ti-fs-firmware-am62x-hs-enc.bin):
> >>    Missing blob
> >>
> >> /binman/tiboot3-am62x-hs-evm.bin/sysfw-inner-cert
> >> (ti-sysfw/ti-fs-firmware-am62x-hs-cert.bin):
> >>    Missing blob
> >>
> >> Image 'tiboot3-am62x-hs-fs-evm.bin' is missing optional external blobs but is
> >> still functional: ti-fs-enc.bin sysfw-inner-cert
> >>
> >> /binman/tiboot3-am62x-hs-fs-evm.bin/ti-fs-enc.bin
> >> (ti-sysfw/ti-fs-firmware-am62x-hs-fs-enc.bin):
> >>    Missing blob
> >>
> >> /binman/tiboot3-am62x-hs-fs-evm.bin/sysfw-inner-cert
> >> (ti-sysfw/ti-fs-firmware-am62x-hs-fs-cert.bin):
> >>    Missing blob
> >>
> >> Image 'tiboot3-am62x-gp-evm.bin' is missing optional external blobs but is still
> >> functional: ti-fs-gp.bin
> >>
> >> /binman/tiboot3-am62x-gp-evm.bin/ti-fs-gp.bin
> >> (ti-sysfw/ti-fs-firmware-am62x-gp.bin):
> >>    Missing blob
> >>
> >>   OFCHK   .config
> >>
> >> So, we should add ti-k3-boot-firmware in dependencies to avoid building
> >> ti-k3-r5-loader before ti-k3-boot-firmware.
> >>
> >> When building the AM6 defconfig, the build order is ordered alphabetically by
> >> default and ti-k3-boot-firmware is installed before ti-k3-r5-loader.
> >>
> >
> > OK, this is a valid point. Anyway what you suggest force select or a
> > depend. If you have more points, is better to write down all of
> > them in one review, and not split as now every new patcheset. What do you think?
> >
>
> I reviewed the series already and make some suggestions that were not included.
> Same about the review from Bryan (this one) and Andreas (make HS-FS the default
> for AM62 and AM64).
>
> I'm working on a V11 including some Buildroot rework, the BSP itself is ok.
>

Ok, this way you make again all the people testing, when your patches
can be on top of this series that already
was proven that it was working. It's even important that you consider
the effort of the people on testing series and
patches that are on going on the TI side to include gpu. Hope that
your V11 will come soon and not include too many changes.
All your suggestions come from SoC or boards that are not even
included in buildroot and on platforms where they are not yet
supported.
People are contributing on what they can test and include and patches
that are not part of a series that state to support some architecture
should not be forced in the same series. Sometimes we can even accept
that a series is supposed to do what is in the series description.

Michael



> Best regards,
> Romain
>
>
> > Michael
> >
> >> Best regards,
> >> Romain
> >>
> >>
> >>>
> >>> ~Bryan
> >>
> >
> >
>
diff mbox series

Patch

diff --git a/boot/ti-k3-r5-loader/Config.in b/boot/ti-k3-r5-loader/Config.in
index 5f86c045c99f..fc71337e80cc 100644
--- a/boot/ti-k3-r5-loader/Config.in
+++ b/boot/ti-k3-r5-loader/Config.in
@@ -1,6 +1,7 @@ 
 config BR2_TARGET_TI_K3_R5_LOADER
 	bool "ti-k3-r5-loader"
 	depends on BR2_aarch64
+	depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS # python-rpds-py -> python-jsonschema
 	help
 	  Separate U-Boot SPL build for R5 core on TI's K3 processors.
 	  Usually used to build tiboot3.bin with k3-image-gen.
diff --git a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
index 0ffcb8235f2e..fdb058f3b72a 100644
--- a/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
+++ b/boot/ti-k3-r5-loader/ti-k3-r5-loader.mk
@@ -39,7 +39,12 @@  TI_K3_R5_LOADER_DEPENDENCIES = \
 	host-pkgconf \
 	$(BR2_MAKE_HOST_DEPENDENCY) \
 	host-arm-gnu-toolchain \
-	host-openssl
+	host-openssl \
+	host-python-jsonschema \
+	host-python-pyyaml \
+	host-python3 \
+	host-python-setuptools \
+	host-python-pylibfdt
 
 TI_K3_R5_LOADER_MAKE = $(BR2_MAKE)
 TI_K3_R5_LOADER_MAKE_ENV = $(TARGET_MAKE_ENV)
@@ -58,6 +63,7 @@  TI_K3_R5_LOADER_MAKE_OPTS = \
 	CROSS_COMPILE=$(HOST_DIR)/bin/arm-none-eabi- \
 	ARCH=arm \
 	HOSTCC="$(HOSTCC) $(subst -I/,-isystem /,$(subst -I /,-isystem /,$(HOST_CFLAGS)))" \
+	BINMAN_INDIRS=$(BINARIES_DIR) \
 	HOSTLDFLAGS="$(HOST_LDFLAGS)"
 
 define TI_K3_R5_LOADER_BUILD_CMDS