diff mbox series

[1/1] package/strongswan: drop BR2_PACKAGE_STRONGSWAN_SCEP

Message ID 20240303172622.629998-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/strongswan: drop BR2_PACKAGE_STRONGSWAN_SCEP | expand

Commit Message

Fabrice Fontaine March 3, 2024, 5:26 p.m. UTC
scepclient is unrecognized since bump to version 5.9.8 in commit
b79d735139282ecf052dc89d4c221bbd16447112 and
https://github.com/strongswan/strongswan/commit/8716f7c03c6193b1cb53837243177f36280ff4f7:

configure: WARNING: unrecognized options: --disable-gtk-doc, --disable-gtk-doc-html, --disable-doc, --disable-docs, --disable-documentation, --with-xmlto, --with-fop, --enable-ipv6, --disable-nls, --enable-scepclient

Fixes: b79d735139282ecf052dc89d4c221bbd16447112

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 Config.in.legacy                 | 10 ++++++++++
 package/strongswan/Config.in     |  3 ---
 package/strongswan/strongswan.mk |  1 -
 3 files changed, 10 insertions(+), 4 deletions(-)

Comments

Peter Korsgaard March 3, 2024, 6:07 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > scepclient is unrecognized since bump to version 5.9.8 in commit
 > b79d735139282ecf052dc89d4c221bbd16447112 and
 > https://github.com/strongswan/strongswan/commit/8716f7c03c6193b1cb53837243177f36280ff4f7:

 > configure: WARNING: unrecognized options: --disable-gtk-doc,
 > --disable-gtk-doc-html, --disable-doc, --disable-docs,
 > --disable-documentation, --with-xmlto, --with-fop, --enable-ipv6,
 > --disable-nls, --enable-scepclient

 > Fixes: b79d735139282ecf052dc89d4c221bbd16447112

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard March 19, 2024, 12:21 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > scepclient is unrecognized since bump to version 5.9.8 in commit
 > b79d735139282ecf052dc89d4c221bbd16447112 and
 > https://github.com/strongswan/strongswan/commit/8716f7c03c6193b1cb53837243177f36280ff4f7:

 > configure: WARNING: unrecognized options: --disable-gtk-doc,
 > --disable-gtk-doc-html, --disable-doc, --disable-docs,
 > --disable-documentation, --with-xmlto, --with-fop, --enable-ipv6,
 > --disable-nls, --enable-scepclient

 > Fixes: b79d735139282ecf052dc89d4c221bbd16447112

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2023.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/Config.in.legacy b/Config.in.legacy
index 576148c4af..5956ffcca5 100644
--- a/Config.in.legacy
+++ b/Config.in.legacy
@@ -146,6 +146,16 @@  endif
 
 comment "Legacy options removed in 2024.02"
 
+config BR2_PACKAGE_STRONGSWAN_SCEP
+	bool "strongswan SCEP client tool removed"
+	select BR2_LEGACY
+	help
+	  "ipsec scepclient" tool has been removed and replaced by the
+	  pki subcommands "pki --scep" and "pki --scepca" which
+	  implement the new SCEP RFC 8894 standard that was released in
+	  September 2020 and which supports trusted "certificate
+	  renewal" based on the existing client certificate.
+
 config BR2_PACKAGE_SHADOW_UTMPX
 	bool "shadow utmpx removed"
 	select BR2_LEGACY
diff --git a/package/strongswan/Config.in b/package/strongswan/Config.in
index f2e597e016..5231e69ca8 100644
--- a/package/strongswan/Config.in
+++ b/package/strongswan/Config.in
@@ -204,9 +204,6 @@  config BR2_PACKAGE_STRONGSWAN_PKI
 	bool "Enable pki certificate utility"
 	default y
 
-config BR2_PACKAGE_STRONGSWAN_SCEP
-	bool "Enable SCEP client tool"
-
 config BR2_PACKAGE_STRONGSWAN_SCRIPTS
 	bool "Enable additional utilities (found in scripts directory)"
 	default y
diff --git a/package/strongswan/strongswan.mk b/package/strongswan/strongswan.mk
index 36cb72f6be..5521fb7dd4 100644
--- a/package/strongswan/strongswan.mk
+++ b/package/strongswan/strongswan.mk
@@ -33,7 +33,6 @@  STRONGSWAN_CONF_OPTS += \
 	--enable-stroke=$(if $(BR2_PACKAGE_STRONGSWAN_STROKE),yes,no) \
 	--enable-sql=$(if $(BR2_PACKAGE_STRONGSWAN_SQL),yes,no) \
 	--enable-pki=$(if $(BR2_PACKAGE_STRONGSWAN_PKI),yes,no) \
-	--enable-scepclient=$(if $(BR2_PACKAGE_STRONGSWAN_SCEP),yes,no) \
 	--enable-scripts=$(if $(BR2_PACKAGE_STRONGSWAN_SCRIPTS),yes,no) \
 	--enable-vici=$(if $(BR2_PACKAGE_STRONGSWAN_VICI),yes,no) \
 	--enable-swanctl=$(if $(BR2_PACKAGE_STRONGSWAN_VICI),yes,no) \