diff mbox series

[1/1] package/luvi: fix build with aarch64_be

Message ID 20240303103000.454697-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/luvi: fix build with aarch64_be | expand

Commit Message

Fabrice Fontaine March 3, 2024, 10:30 a.m. UTC
Fix the following build failure with aarch64_be raised since the
addition of aarch64_be support to luajit in commit
28e5c2f2bdd147dbb9aefbc040fc618f46ee0663:

luajit: unknown architecture

Fixes: 28e5c2f2bdd147dbb9aefbc040fc618f46ee0663
 - http://autobuild.buildroot.org/results/9b89eff7d90173b8c74b8f676650709cc4418e65

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/luvi/luvi.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Peter Korsgaard March 4, 2024, 11:49 a.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure with aarch64_be raised since the
 > addition of aarch64_be support to luajit in commit
 > 28e5c2f2bdd147dbb9aefbc040fc618f46ee0663:

 > luajit: unknown architecture

 > Fixes: 28e5c2f2bdd147dbb9aefbc040fc618f46ee0663
 >  - http://autobuild.buildroot.org/results/9b89eff7d90173b8c74b8f676650709cc4418e65

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard March 19, 2024, 3:37 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure with aarch64_be raised since the
 > addition of aarch64_be support to luajit in commit
 > 28e5c2f2bdd147dbb9aefbc040fc618f46ee0663:

 > luajit: unknown architecture

 > Fixes: 28e5c2f2bdd147dbb9aefbc040fc618f46ee0663
 >  - http://autobuild.buildroot.org/results/9b89eff7d90173b8c74b8f676650709cc4418e65

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2023.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/luvi/luvi.mk b/package/luvi/luvi.mk
index a8e645fab3..ebd1066c5c 100644
--- a/package/luvi/luvi.mk
+++ b/package/luvi/luvi.mk
@@ -22,6 +22,8 @@  else ifeq ($(BR2_arm)$(BR2_armeb),y)
 LUVI_TARGET_ARCH = arm
 else ifeq ($(BR2_aarch64),y)
 LUVI_TARGET_ARCH = arm64
+else ifeq ($(BR2_aarch64_be),y)
+LUVI_TARGET_ARCH = arm64be
 else ifeq ($(BR2_mips),y)
 LUVI_TARGET_ARCH = mips
 else ifeq ($(BR2_mipsel),y)