diff mbox series

[v2,1/1] package/powertop: fix gettext build

Message ID 20240302212852.197223-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v2,1/1] package/powertop: fix gettext build | expand

Commit Message

Fabrice Fontaine March 2, 2024, 9:28 p.m. UTC
Fix gettext build raised since bump to version 2.15 in commit
d65b960859046be486ced6c490d3671bd1392661:

*** error: gettext infrastructure mismatch: using a Makefile.in.in from gettext version 0.18 but the autoconf macros are from gettext version 0.20

Fixes: d65b960859046be486ced6c490d3671bd1392661
 - http://autobuild.buildroot.org/results/bb80a7842d18651e5069f3a91f06a9c23218d260

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Yann E. Morin):
 - Set POWERTOP_AUTOPOINT=YES instead of patching

 package/powertop/powertop.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Yann E. MORIN March 2, 2024, 10:24 p.m. UTC | #1
FAbrice, All,

On 2024-03-02 22:28 +0100, Fabrice Fontaine spake thusly:
> Fix gettext build raised since bump to version 2.15 in commit
> d65b960859046be486ced6c490d3671bd1392661:
> 
> *** error: gettext infrastructure mismatch: using a Makefile.in.in from gettext version 0.18 but the autoconf macros are from gettext version 0.20
> 
> Fixes: d65b960859046be486ced6c490d3671bd1392661
>  - http://autobuild.buildroot.org/results/bb80a7842d18651e5069f3a91f06a9c23218d260
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

See below...

> ---
> Changes v1 -> v2 (after review of Yann E. Morin):
>  - Set POWERTOP_AUTOPOINT=YES instead of patching
> 
>  package/powertop/powertop.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/powertop/powertop.mk b/package/powertop/powertop.mk
> index 0481caee07..a7a57939e0 100644
> --- a/package/powertop/powertop.mk
> +++ b/package/powertop/powertop.mk
> @@ -20,6 +20,7 @@ POWERTOP_DEPENDENCIES = \
>  POWERTOP_CONF_ENV = LIBS=$(TARGET_NLS_LIBS)
>  # 0001-add-disable-stack-protector-option.patch
>  POWERTOP_AUTORECONF = YES
> +POWERTOP_AUTOPOINT = YES
>  POWERTOP_AUTORECONF_OPTS = --include=$(HOST_DIR)/share/autoconf-archive

I did like it much that autopoint was added in-between the two autoconf
variables, so I moved it above but "forgot" to amend before pushing, as
there was still some discrepancies in how the _CONF_{ENV,OPTS} variables
were spread far and wide from each other.

So I pushed a followup commit that reoraganised the varialbes in a more
logical manner...

Thanks!

Regards,
Yann E. MORIN.

>  POWERTOP_CONF_OPTS = --disable-stack-protector
>  
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard March 19, 2024, 11:21 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix gettext build raised since bump to version 2.15 in commit
 > d65b960859046be486ced6c490d3671bd1392661:

 > *** error: gettext infrastructure mismatch: using a Makefile.in.in
 > from gettext version 0.18 but the autoconf macros are from gettext
 > version 0.20

 > Fixes: d65b960859046be486ced6c490d3671bd1392661
 >  - http://autobuild.buildroot.org/results/bb80a7842d18651e5069f3a91f06a9c23218d260

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
 > ---
 > Changes v1 -> v2 (after review of Yann E. Morin):
 >  - Set POWERTOP_AUTOPOINT=YES instead of patching

Committed to 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/powertop/powertop.mk b/package/powertop/powertop.mk
index 0481caee07..a7a57939e0 100644
--- a/package/powertop/powertop.mk
+++ b/package/powertop/powertop.mk
@@ -20,6 +20,7 @@  POWERTOP_DEPENDENCIES = \
 POWERTOP_CONF_ENV = LIBS=$(TARGET_NLS_LIBS)
 # 0001-add-disable-stack-protector-option.patch
 POWERTOP_AUTORECONF = YES
+POWERTOP_AUTOPOINT = YES
 POWERTOP_AUTORECONF_OPTS = --include=$(HOST_DIR)/share/autoconf-archive
 POWERTOP_CONF_OPTS = --disable-stack-protector