diff mbox series

[1/1] package/redis: disable -Werror

Message ID 20240301183349.808102-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/redis: disable -Werror | expand

Commit Message

Fabrice Fontaine March 1, 2024, 6:33 p.m. UTC
Disable -Werror to avoid the following build failure raised since bump
to version 7.2.1 in commit d49f53f8aaf0bff9c8d04c16485c844fef2832d0 and
https://github.com/redis/redis/commit/8e138ba44fc3eb676c0f31faac19d1acc6a4c7ed:

In function 'hi_sdsll2str',
    inlined from 'hi_sdsfromlonglong' at sds.c:500:15:
sds.c:457:12: error: writing 1 byte into a region of size 0 [-Werror=stringop-overflow=]
  457 |         *s = *p;
      |         ~~~^~~~

Fixes: d49f53f8aaf0bff9c8d04c16485c844fef2832d0
 - http://autobuild.buildroot.org/results/fdc9f940b348430cb4da8efecc5cc047b21df281
 - http://autobuild.buildroot.org/results/e5747674d52b065203a0442f7cab13e8be5f426b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/redis/redis.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard March 1, 2024, 6:54 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Disable -Werror to avoid the following build failure raised since bump
 > to version 7.2.1 in commit d49f53f8aaf0bff9c8d04c16485c844fef2832d0 and
 > https://github.com/redis/redis/commit/8e138ba44fc3eb676c0f31faac19d1acc6a4c7ed:

 > In function 'hi_sdsll2str',
 >     inlined from 'hi_sdsfromlonglong' at sds.c:500:15:
 > sds.c:457:12: error: writing 1 byte into a region of size 0 [-Werror=stringop-overflow=]
 >   457 |         *s = *p;
 >       |         ~~~^~~~

 > Fixes: d49f53f8aaf0bff9c8d04c16485c844fef2832d0
 >  - http://autobuild.buildroot.org/results/fdc9f940b348430cb4da8efecc5cc047b21df281
 >  - http://autobuild.buildroot.org/results/e5747674d52b065203a0442f7cab13e8be5f426b

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard March 18, 2024, 1:31 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Disable -Werror to avoid the following build failure raised since bump
 > to version 7.2.1 in commit d49f53f8aaf0bff9c8d04c16485c844fef2832d0 and
 > https://github.com/redis/redis/commit/8e138ba44fc3eb676c0f31faac19d1acc6a4c7ed:

 > In function 'hi_sdsll2str',
 >     inlined from 'hi_sdsfromlonglong' at sds.c:500:15:
 > sds.c:457:12: error: writing 1 byte into a region of size 0 [-Werror=stringop-overflow=]
 >   457 |         *s = *p;
 >       |         ~~~^~~~

 > Fixes: d49f53f8aaf0bff9c8d04c16485c844fef2832d0
 >  - http://autobuild.buildroot.org/results/fdc9f940b348430cb4da8efecc5cc047b21df281
 >  - http://autobuild.buildroot.org/results/e5747674d52b065203a0442f7cab13e8be5f426b

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2023.11.x, thanks.

> ---
 >  package/redis/redis.mk | 2 +-
 >  1 file changed, 1 insertion(+), 1 deletion(-)

 > diff --git a/package/redis/redis.mk b/package/redis/redis.mk
 > index 09a3b9448b..2680b11b74 100644
 > --- a/package/redis/redis.mk
 > +++ b/package/redis/redis.mk
 > @@ -30,7 +30,7 @@ endif
 >  # https://github.com/antirez/redis/pull/609).  We set PREFIX
 >  # instead.
 >  REDIS_BUILDOPTS = $(TARGET_CONFIGURE_OPTS) \
 > -	PREFIX=$(TARGET_DIR)/usr MALLOC=libc
 > +	PREFIX=$(TARGET_DIR)/usr MALLOC=libc WARNINGS=
 
 >  ifeq ($(BR2_PACKAGE_SYSTEMD),y)
 >  REDIS_DEPENDENCIES += systemd
 > -- 

 > 2.43.0

 > _______________________________________________
 > buildroot mailing list
 > buildroot@buildroot.org
 > https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/redis/redis.mk b/package/redis/redis.mk
index 09a3b9448b..2680b11b74 100644
--- a/package/redis/redis.mk
+++ b/package/redis/redis.mk
@@ -30,7 +30,7 @@  endif
 # https://github.com/antirez/redis/pull/609).  We set PREFIX
 # instead.
 REDIS_BUILDOPTS = $(TARGET_CONFIGURE_OPTS) \
-	PREFIX=$(TARGET_DIR)/usr MALLOC=libc
+	PREFIX=$(TARGET_DIR)/usr MALLOC=libc WARNINGS=
 
 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
 REDIS_DEPENDENCIES += systemd