diff mbox series

[v2,1/3] package/rust/rust.mk: add missing host-zlib dependency

Message ID 20240229224122.1085300-1-romain.naour@smile.fr
State Accepted
Headers show
Series [v2,1/3] package/rust/rust.mk: add missing host-zlib dependency | expand

Commit Message

Romain Naour Feb. 29, 2024, 10:41 p.m. UTC
Several rust tool are linking against zlib, so add
the depedency explicitely in HOST_RUST_DEPENDENCIES.

For now, host-rust build system is not able to find
provided by Buildroot in HOST_DIR due to at least two
issues that will be fixed in followup commits.

Signed-off-by: Romain Naour <romain.naour@smile.fr>
---
v2: new commit
---
 package/rust/rust.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Yann E. MORIN March 2, 2024, 10:07 p.m. UTC | #1
Romain, All,

On 2024-02-29 23:41 +0100, Romain Naour spake thusly:
> Several rust tool are linking against zlib, so add
> the depedency explicitely in HOST_RUST_DEPENDENCIES.
> 
> For now, host-rust build system is not able to find
> provided by Buildroot in HOST_DIR due to at least two
> issues that will be fixed in followup commits.

I've slightly reflowed the commit log, and added a note about the
transitive depndency.

> Signed-off-by: Romain Naour <romain.naour@smile.fr>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
> v2: new commit
> ---
>  package/rust/rust.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/rust/rust.mk b/package/rust/rust.mk
> index f7a5c0fcd5..16a397407f 100644
> --- a/package/rust/rust.mk
> +++ b/package/rust/rust.mk
> @@ -20,6 +20,7 @@ HOST_RUST_DEPENDENCIES = \
>  	host-python3 \
>  	host-rust-bin \
>  	host-openssl \
> +	host-zlib \
>  	$(BR2_CMAKE_HOST_DEPENDENCY)
>  
>  HOST_RUST_VERBOSITY = $(if $(VERBOSE),2,0)
> -- 
> 2.43.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/rust/rust.mk b/package/rust/rust.mk
index f7a5c0fcd5..16a397407f 100644
--- a/package/rust/rust.mk
+++ b/package/rust/rust.mk
@@ -20,6 +20,7 @@  HOST_RUST_DEPENDENCIES = \
 	host-python3 \
 	host-rust-bin \
 	host-openssl \
+	host-zlib \
 	$(BR2_CMAKE_HOST_DEPENDENCY)
 
 HOST_RUST_VERBOSITY = $(if $(VERBOSE),2,0)