diff mbox series

[1/2] package/pico-sdk: new package

Message ID 20240228195333.712751-1-buildroot@bubu1.eu
State Superseded
Headers show
Series [1/2] package/pico-sdk: new package | expand

Commit Message

Marcus Hoffmann Feb. 28, 2024, 7:53 p.m. UTC
Add the pi-pico sdk as a dependency for picotool. This is a bit of a
weird package, because you normally clone the git repository and point
the picotool (or rp2040 firmware project) build to it.

For picotool specifically, only headers are used from the sdk, for
building a firmware project, it is included as source files via cmake,
so this pretty much has the same semantics for that as well.

Signed-off-by: Marcus Hoffmann <buildroot@bubu1.eu>
---
 package/Config.in              |  1 +
 package/pico-sdk/Config.in     |  9 +++++++++
 package/pico-sdk/pico-sdk.hash |  3 +++
 package/pico-sdk/pico-sdk.mk   | 20 ++++++++++++++++++++
 4 files changed, 33 insertions(+)
 create mode 100644 package/pico-sdk/Config.in
 create mode 100644 package/pico-sdk/pico-sdk.hash
 create mode 100644 package/pico-sdk/pico-sdk.mk
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index bf0fe078b9..b01024ae04 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1785,6 +1785,7 @@  menu "Hardware handling"
 	source "package/opensc/Config.in"
 	source "package/owfs/Config.in"
 	source "package/pcsc-lite/Config.in"
+	source "package/pico-sdk/Config.in"
 	source "package/rpi-rgb-led-matrix/Config.in"
 	source "package/tslib/Config.in"
 	source "package/uhd/Config.in"
diff --git a/package/pico-sdk/Config.in b/package/pico-sdk/Config.in
new file mode 100644
index 0000000000..962139925c
--- /dev/null
+++ b/package/pico-sdk/Config.in
@@ -0,0 +1,9 @@ 
+config BR2_PACKAGE_PICO_SDK
+	bool "pico-sdk"
+	help
+	  Raspberry Pi Pico SDK. Provides the headers, libraries
+	  and build system necessary to write programs for the
+	  RP2040-based devices such as the Raspberry Pi Pico in
+	  C, C++ or assembly language.
+
+	  https://github.com/raspberrypi/pico-sdk
diff --git a/package/pico-sdk/pico-sdk.hash b/package/pico-sdk/pico-sdk.hash
new file mode 100644
index 0000000000..5db7e8bdb4
--- /dev/null
+++ b/package/pico-sdk/pico-sdk.hash
@@ -0,0 +1,3 @@ 
+# Locally calculated
+sha256  95f5e522be3919e36a47975ffd3b208c38880c14468bd489ac672cfe3cec803c  pico-sdk-1.5.1.tar.gz
+sha256  483f865953435b66c443dee7558debe3cc3cf8fcbb6a112fd9fc6a795d53f1f6  LICENSE.TXT
diff --git a/package/pico-sdk/pico-sdk.mk b/package/pico-sdk/pico-sdk.mk
new file mode 100644
index 0000000000..0c475d8aa1
--- /dev/null
+++ b/package/pico-sdk/pico-sdk.mk
@@ -0,0 +1,20 @@ 
+################################################################################
+#
+# pico-sdk
+#
+################################################################################
+
+PICO_SDK_VERSION = 1.5.1
+PICO_SDK_SITE = $(call github,raspberrypi,pico-sdk,$(PICO_SDK_VERSION))
+PICO_SDK_LICENSE = BSD-3-Clause
+PICO_SDK_LICENSE_FILES = LICENSE.TXT
+PICO_SDK_INSTALL_STAGING = YES
+# Header-only lib, as far as buildroot is concerned
+PICO_SDK_INSTALL_TARGET = NO
+
+define PICO_SDK_INSTALL_STAGING_CMDS
+	mkdir -p $(STAGING_DIR)/usr/include/pico-sdk
+	cp -r $(@D)/* $(STAGING_DIR)/usr/include/pico-sdk
+endef
+
+$(eval $(generic-package))