diff mbox series

[1/1] package/erlang: fix build with autoconf 2.72

Message ID 20240226173644.1077579-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/erlang: fix build with autoconf 2.72 | expand

Commit Message

Fabrice Fontaine Feb. 26, 2024, 5:36 p.m. UTC
Use ERLANG_FIX_AUTOCONF_VERSION to fix the following build failure
raised since bump of autoconf to version 2.72 in commit
524f3536029dace3ce9aa154d3ca4685582e1955:

ERROR: autoconf of version 2.72 found in path! You need to have autoconf of version 2.71 in path.

Fixes: 524f3536029dace3ce9aa154d3ca4685582e1955
 - http://autobuild.buildroot.org/results/c9e8df3427fca9e8e75488e32bca18e81009238c

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/erlang/erlang.mk | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)

Comments

Peter Korsgaard Feb. 27, 2024, 10:24 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Use ERLANG_FIX_AUTOCONF_VERSION to fix the following build failure
 > raised since bump of autoconf to version 2.72 in commit
 > 524f3536029dace3ce9aa154d3ca4685582e1955:

 > ERROR: autoconf of version 2.72 found in path! You need to have autoconf of version 2.71 in path.

 > Fixes: 524f3536029dace3ce9aa154d3ca4685582e1955
 >  - http://autobuild.buildroot.org/results/c9e8df3427fca9e8e75488e32bca18e81009238c

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/erlang/erlang.mk b/package/erlang/erlang.mk
index 1600b59381..84d2f4e898 100644
--- a/package/erlang/erlang.mk
+++ b/package/erlang/erlang.mk
@@ -17,14 +17,22 @@  ERLANG_CPE_ID_VENDOR = erlang
 ERLANG_CPE_ID_PRODUCT = erlang\/otp
 ERLANG_INSTALL_STAGING = YES
 
+define ERLANG_FIX_AUTOCONF_VERSION
+	$(SED) "s/USE_AUTOCONF_VERSION=.*/USE_AUTOCONF_VERSION=$(AUTOCONF_VERSION)/" $(@D)/otp_build
+endef
+
 # Patched erts/aclocal.m4
 define ERLANG_RUN_AUTOCONF
 	cd $(@D) && PATH=$(BR_PATH) ./otp_build update_configure --no-commit
 endef
 ERLANG_DEPENDENCIES += host-autoconf
-ERLANG_PRE_CONFIGURE_HOOKS += ERLANG_RUN_AUTOCONF
+ERLANG_PRE_CONFIGURE_HOOKS += \
+	ERLANG_FIX_AUTOCONF_VERSION \
+	ERLANG_RUN_AUTOCONF
 HOST_ERLANG_DEPENDENCIES += host-autoconf
-HOST_ERLANG_PRE_CONFIGURE_HOOKS += ERLANG_RUN_AUTOCONF
+HOST_ERLANG_PRE_CONFIGURE_HOOKS += \
+	ERLANG_FIX_AUTOCONF_VERSION \
+	ERLANG_RUN_AUTOCONF
 
 # Return the EIV (Erlang Interface Version, EI_VSN)
 # $(1): base directory, i.e. either $(HOST_DIR) or $(STAGING_DIR)/usr