diff mbox series

[v3,2/2] package/python-betterproto: new package

Message ID 20240223180533.3011424-2-james.hilliard1@gmail.com
State Superseded, archived
Headers show
Series [v3,1/2] package/python-grpclib: new package | expand

Commit Message

James Hilliard Feb. 23, 2024, 6:05 p.m. UTC
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
Changes v2 -> v3:
 - add missing python-datetime runtime dependency
---
 package/Config.in                                  |  1 +
 package/python-betterproto/Config.in               |  8 ++++++++
 package/python-betterproto/python-betterproto.hash |  5 +++++
 package/python-betterproto/python-betterproto.mk   | 14 ++++++++++++++
 4 files changed, 28 insertions(+)
 create mode 100644 package/python-betterproto/Config.in
 create mode 100644 package/python-betterproto/python-betterproto.hash
 create mode 100644 package/python-betterproto/python-betterproto.mk
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index 2ddaadae69..f49c3543b2 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1006,6 +1006,7 @@  menu "External python modules"
 	source "package/python-backcall/Config.in"
 	source "package/python-bcrypt/Config.in"
 	source "package/python-beautifulsoup4/Config.in"
+	source "package/python-betterproto/Config.in"
 	source "package/python-bidict/Config.in"
 	source "package/python-bitarray/Config.in"
 	source "package/python-bitstring/Config.in"
diff --git a/package/python-betterproto/Config.in b/package/python-betterproto/Config.in
new file mode 100644
index 0000000000..8548fd43ba
--- /dev/null
+++ b/package/python-betterproto/Config.in
@@ -0,0 +1,8 @@ 
+config BR2_PACKAGE_PYTHON_BETTERPROTO
+	bool "python-betterproto"
+	select BR2_PACKAGE_PYTHON_DATEUTIL # runtime
+	select BR2_PACKAGE_PYTHON_GRPCLIB # runtime
+	help
+	  A better Protobuf / gRPC generator & library.
+
+	  http://github.com/danielgtaylor/python-betterproto
diff --git a/package/python-betterproto/python-betterproto.hash b/package/python-betterproto/python-betterproto.hash
new file mode 100644
index 0000000000..8d23d2ae56
--- /dev/null
+++ b/package/python-betterproto/python-betterproto.hash
@@ -0,0 +1,5 @@ 
+# md5, sha256 from https://pypi.org/pypi/betterproto/json
+md5  bd4192c2997959100097479c34ff87e6  betterproto-2.0.0b6.tar.gz
+sha256  720ae92697000f6fcf049c69267d957f0871654c8b0d7458906607685daee784  betterproto-2.0.0b6.tar.gz
+# Locally computed sha256 checksums
+sha256  a5b8df75467e4b57a308a94cce5fdae84808a83ee6cd5af7e175c6b9784a753f  LICENSE.md
diff --git a/package/python-betterproto/python-betterproto.mk b/package/python-betterproto/python-betterproto.mk
new file mode 100644
index 0000000000..95caf0945a
--- /dev/null
+++ b/package/python-betterproto/python-betterproto.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+#
+# python-betterproto
+#
+################################################################################
+
+PYTHON_BETTERPROTO_VERSION = 2.0.0b6
+PYTHON_BETTERPROTO_SOURCE = betterproto-$(PYTHON_BETTERPROTO_VERSION).tar.gz
+PYTHON_BETTERPROTO_SITE = https://files.pythonhosted.org/packages/45/43/4c44efd75f2ef48a16b458c2fe2cff7aa74bab8fcadf2653bb5110a87f97
+PYTHON_BETTERPROTO_SETUP_TYPE = setuptools
+PYTHON_BETTERPROTO_LICENSE = MIT
+PYTHON_BETTERPROTO_LICENSE_FILES = LICENSE.md
+
+$(eval $(python-package))