diff mbox series

[v5,12/16] boot/uboot: set BINMAN_INDIRS for TI K3 DM

Message ID 20240222101617.18422-13-dario.binacchi@amarulasolutions.com
State Changes Requested, archived
Headers show
Series Add support for AM62x-SK HS-FS devices | expand

Commit Message

Dario Binacchi Feb. 22, 2024, 10:16 a.m. UTC
As explained in [1], adding support for AM62x LP SK in U-Boot, requires
binman for building bootloader images. The BINMAN_INDIRS environment
variable is used to provide a space-separated list of directories to
search for binary blobs.

In this way, the previous setting becomes unnecessary, so let's remove
it.

[1] https://patchwork.ozlabs.org/project/uboot/patch/20231030110138.1347603-3-n-yadav@ti.com/
Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>

---

Changes in v5:
- Drop "DM=$(BINARIES_DIR)/ti-dm/$(UBOOT_TI_K3_DM_SOCNAME)/ipc_echo_testb_mcu1_0_release_strip.xer5f"
  from UBOOT_MAKE_OPTS.

no changes since v1:

 boot/uboot/uboot.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Romain Naour Feb. 22, 2024, 10:09 p.m. UTC | #1
Hello Dario,

Le 22/02/2024 à 11:16, Dario Binacchi a écrit :
> As explained in [1], adding support for AM62x LP SK in U-Boot, requires
> binman for building bootloader images. The BINMAN_INDIRS environment
> variable is used to provide a space-separated list of directories to
> search for binary blobs.
> 
> In this way, the previous setting becomes unnecessary, so let's remove
> it.
> 
> [1] https://patchwork.ozlabs.org/project/uboot/patch/20231030110138.1347603-3-n-yadav@ti.com/
> Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
> 
> ---
> 
> Changes in v5:
> - Drop "DM=$(BINARIES_DIR)/ti-dm/$(UBOOT_TI_K3_DM_SOCNAME)/ipc_echo_testb_mcu1_0_release_strip.xer5f"
>   from UBOOT_MAKE_OPTS.
> 
> no changes since v1:
> 
>  boot/uboot/uboot.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
> index dda606a88059..70982a87719f 100644
> --- a/boot/uboot/uboot.mk
> +++ b/boot/uboot/uboot.mk
> @@ -189,7 +189,7 @@ endif
>  ifeq ($(BR2_TARGET_UBOOT_NEEDS_TI_K3_DM),y)
>  UBOOT_TI_K3_DM_SOCNAME = $(call qstrip,$(BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME))
>  UBOOT_DEPENDENCIES += ti-k3-boot-firmware
> -UBOOT_MAKE_OPTS += DM=$(BINARIES_DIR)/ti-dm/$(UBOOT_TI_K3_DM_SOCNAME)/ipc_echo_testb_mcu1_0_release_strip.xer5f
> +UBOOT_MAKE_OPTS += BINMAN_INDIRS=$(BINARIES_DIR)

Binman tool is not specific to TI K3 platform, see my previous comment [1]

[1] http://lists.busybox.net/pipermail/buildroot/2024-February/685949.html

Best regards,
Romain


>  endif
>  
>  ifeq ($(BR2_TARGET_UBOOT_NEEDS_OPENSBI),y)
Romain Naour Feb. 22, 2024, 10:35 p.m. UTC | #2
Le 22/02/2024 à 23:09, Romain Naour a écrit :
> Hello Dario,
> 
> Le 22/02/2024 à 11:16, Dario Binacchi a écrit :
>> As explained in [1], adding support for AM62x LP SK in U-Boot, requires
>> binman for building bootloader images. The BINMAN_INDIRS environment
>> variable is used to provide a space-separated list of directories to
>> search for binary blobs.
>>
>> In this way, the previous setting becomes unnecessary, so let's remove
>> it.
>>
>> [1] https://patchwork.ozlabs.org/project/uboot/patch/20231030110138.1347603-3-n-yadav@ti.com/
>> Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
>>
>> ---
>>
>> Changes in v5:
>> - Drop "DM=$(BINARIES_DIR)/ti-dm/$(UBOOT_TI_K3_DM_SOCNAME)/ipc_echo_testb_mcu1_0_release_strip.xer5f"
>>   from UBOOT_MAKE_OPTS.
>>
>> no changes since v1:
>>
>>  boot/uboot/uboot.mk | 2 +-
>>  1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
>> index dda606a88059..70982a87719f 100644
>> --- a/boot/uboot/uboot.mk
>> +++ b/boot/uboot/uboot.mk
>> @@ -189,7 +189,7 @@ endif
>>  ifeq ($(BR2_TARGET_UBOOT_NEEDS_TI_K3_DM),y)
>>  UBOOT_TI_K3_DM_SOCNAME = $(call qstrip,$(BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME))

UBOOT_TI_K3_DM_SOCNAME is not used anymore

With the ti-k3 package introduced in the followup patch, it can be simplifed to
(along the separate binman uboot option)

ifeq ($(BR2_PACKAGE_TI_K3),y)
UBOOT_DEPENDENCIES += ti-k3-boot-firmware
endif

>>  UBOOT_DEPENDENCIES += ti-k3-boot-firmware
>> -UBOOT_MAKE_OPTS += DM=$(BINARIES_DIR)/ti-dm/$(UBOOT_TI_K3_DM_SOCNAME)/ipc_echo_testb_mcu1_0_release_strip.xer5f
>> +UBOOT_MAKE_OPTS += BINMAN_INDIRS=$(BINARIES_DIR)
> 
> Binman tool is not specific to TI K3 platform, see my previous comment [1]
> 
> [1] http://lists.busybox.net/pipermail/buildroot/2024-February/685949.html
> 
> Best regards,
> Romain
> 
> 
>>  endif
>>  
>>  ifeq ($(BR2_TARGET_UBOOT_NEEDS_OPENSBI),y)
>
diff mbox series

Patch

diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index dda606a88059..70982a87719f 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -189,7 +189,7 @@  endif
 ifeq ($(BR2_TARGET_UBOOT_NEEDS_TI_K3_DM),y)
 UBOOT_TI_K3_DM_SOCNAME = $(call qstrip,$(BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME))
 UBOOT_DEPENDENCIES += ti-k3-boot-firmware
-UBOOT_MAKE_OPTS += DM=$(BINARIES_DIR)/ti-dm/$(UBOOT_TI_K3_DM_SOCNAME)/ipc_echo_testb_mcu1_0_release_strip.xer5f
+UBOOT_MAKE_OPTS += BINMAN_INDIRS=$(BINARIES_DIR)
 endif
 
 ifeq ($(BR2_TARGET_UBOOT_NEEDS_OPENSBI),y)