diff mbox series

[13/21] boot/uboot: use DM firmware name defined by ti-k3-boot-firmware package

Message ID 20240213172817.2872849-14-romain.naour@smile.fr
State Superseded
Headers show
Series Add ti_j721e_sk_defconfig | expand

Commit Message

Romain Naour Feb. 13, 2024, 5:28 p.m. UTC
The DM firmware name is now defined by ti-k3-boot-frimware package by
BR2_TARGET_TI_K3_BOOT_FIRMWARE_DM, so BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME
can be removed to avoid duplication in Kconfig.

Signed-off-by: Romain Naour <romain.naour@smile.fr>
---
 boot/uboot/Config.in | 9 ---------
 boot/uboot/uboot.mk  | 2 +-
 2 files changed, 1 insertion(+), 10 deletions(-)

Comments

Alexander Sverdlin Feb. 14, 2024, 11:29 a.m. UTC | #1
Hi Romain,

On Tue, 2024-02-13 at 18:28 +0100, Romain Naour wrote:
> The DM firmware name is now defined by ti-k3-boot-frimware package by
> BR2_TARGET_TI_K3_BOOT_FIRMWARE_DM, so BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME
> can be removed to avoid duplication in Kconfig.
> 
> Signed-off-by: Romain Naour <romain.naour@smile.fr>

Reviewed-by: Alexander Sverdlin <alexander.sverdlin@gmail.com>

> ---
>  boot/uboot/Config.in | 9 ---------
>  boot/uboot/uboot.mk  | 2 +-
>  2 files changed, 1 insertion(+), 10 deletions(-)
> 
> diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
> index e6e7956adc..63359266c6 100644
> --- a/boot/uboot/Config.in
> +++ b/boot/uboot/Config.in
> @@ -250,15 +250,6 @@ config BR2_TARGET_UBOOT_NEEDS_TI_K3_DM
>  	  Some TI K3 devices need the Device Manager (DM) firmware to
>  	  be available for the U-Boot build.
>  
> -if BR2_TARGET_UBOOT_NEEDS_TI_K3_DM
> -
> -config BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME
> -	string
> -	default "am62axx" if BR2_TARGET_TI_K3_IMAGE_GEN_SOC_AM62AX
> -	default "am62xx"  if BR2_TARGET_TI_K3_IMAGE_GEN_SOC_AM62X
> -
> -endif
> -
>  config BR2_TARGET_UBOOT_NEEDS_OPENSBI
>  	bool "U-Boot needs OpenSBI"
>  	depends on BR2_TARGET_OPENSBI
> diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
> index 0714522550..aa2ca99bdd 100644
> --- a/boot/uboot/uboot.mk
> +++ b/boot/uboot/uboot.mk
> @@ -187,7 +187,7 @@ UBOOT_MAKE_OPTS += TEE=$(BINARIES_DIR)/tee.elf
>  endif
>  
>  ifeq ($(BR2_TARGET_UBOOT_NEEDS_TI_K3_DM),y)
> -UBOOT_TI_K3_DM_SOCNAME = $(call qstrip,$(BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME))
> +UBOOT_TI_K3_DM_SOCNAME = $(call qstrip,$(BR2_TARGET_TI_K3_BOOT_FIRMWARE_DM))
>  UBOOT_DEPENDENCIES += ti-k3-boot-firmware
>  UBOOT_MAKE_OPTS += DM=$(BINARIES_DIR)/ti-dm/$(UBOOT_TI_K3_DM_SOCNAME)/ipc_echo_testb_mcu1_0_release_strip.xer5f
>  endif
diff mbox series

Patch

diff --git a/boot/uboot/Config.in b/boot/uboot/Config.in
index e6e7956adc..63359266c6 100644
--- a/boot/uboot/Config.in
+++ b/boot/uboot/Config.in
@@ -250,15 +250,6 @@  config BR2_TARGET_UBOOT_NEEDS_TI_K3_DM
 	  Some TI K3 devices need the Device Manager (DM) firmware to
 	  be available for the U-Boot build.
 
-if BR2_TARGET_UBOOT_NEEDS_TI_K3_DM
-
-config BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME
-	string
-	default "am62axx" if BR2_TARGET_TI_K3_IMAGE_GEN_SOC_AM62AX
-	default "am62xx"  if BR2_TARGET_TI_K3_IMAGE_GEN_SOC_AM62X
-
-endif
-
 config BR2_TARGET_UBOOT_NEEDS_OPENSBI
 	bool "U-Boot needs OpenSBI"
 	depends on BR2_TARGET_OPENSBI
diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index 0714522550..aa2ca99bdd 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -187,7 +187,7 @@  UBOOT_MAKE_OPTS += TEE=$(BINARIES_DIR)/tee.elf
 endif
 
 ifeq ($(BR2_TARGET_UBOOT_NEEDS_TI_K3_DM),y)
-UBOOT_TI_K3_DM_SOCNAME = $(call qstrip,$(BR2_TARGET_UBOOT_TI_K3_DM_SOCNAME))
+UBOOT_TI_K3_DM_SOCNAME = $(call qstrip,$(BR2_TARGET_TI_K3_BOOT_FIRMWARE_DM))
 UBOOT_DEPENDENCIES += ti-k3-boot-firmware
 UBOOT_MAKE_OPTS += DM=$(BINARIES_DIR)/ti-dm/$(UBOOT_TI_K3_DM_SOCNAME)/ipc_echo_testb_mcu1_0_release_strip.xer5f
 endif