diff mbox series

[2/2] package/tio: disable installing man page

Message ID 20240213114933.2444440-2-buildroot@bubu1.eu
State New
Headers show
Series [1/2] package/tio: install bash-completions | expand

Commit Message

Marcus Hoffmann Feb. 13, 2024, 11:49 a.m. UTC
Remove the man subdir from inclusion in the main meson.build file.

Reported upstream to get an option to disable this properly:
https://github.com/tio/tio/issues/222

Signed-off-by: Marcus Hoffmann <buildroot@bubu1.eu>
---
 package/tio/tio.mk | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/package/tio/tio.mk b/package/tio/tio.mk
index a7d3537850..66ce69db2f 100644
--- a/package/tio/tio.mk
+++ b/package/tio/tio.mk
@@ -16,4 +16,10 @@  else
 TIO_CONF_OPTS +=-Dbashcompletiondir=no
 endif
 
+define TIO_DISABLE_BUILDING_MAN_PAGE
+	sed -i -e "/subdir('man')/d" $(@D)/meson.build
+endef
+
+TIO_POST_PATCH_HOOKS += TIO_DISABLE_BUILDING_MAN_PAGE
+
 $(eval $(meson-package))