diff mbox series

[v5,1/5] package/petitboot: minor makefile cleanup

Message ID 20240207175135.1532037-2-arbab@linux.ibm.com
State Accepted
Headers show
Series package/petitboot: misc fixes/enhancement | expand

Commit Message

Reza Arbab Feb. 7, 2024, 5:51 p.m. UTC
Normalize the order of arguments to $(INSTALL). Remove an unnecessary
pair of parentheses.

Signed-off-by: Reza Arbab <arbab@linux.ibm.com>
---
 package/petitboot/petitboot.mk | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Yann E. MORIN Feb. 7, 2024, 7:14 p.m. UTC | #1
Reza, All,

On 2024-02-07 11:51 -0600, Reza Arbab spake thusly:
> Normalize the order of arguments to $(INSTALL). Remove an unnecessary
> pair of parentheses.
> 
> Signed-off-by: Reza Arbab <arbab@linux.ibm.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/petitboot/petitboot.mk | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/petitboot/petitboot.mk b/package/petitboot/petitboot.mk
> index 2087f01b090c..4c8bc35adb38 100644
> --- a/package/petitboot/petitboot.mk
> +++ b/package/petitboot/petitboot.mk
> @@ -63,15 +63,15 @@ define PETITBOOT_POST_INSTALL
>  		$(TARGET_DIR)/etc/petitboot/boot.d/01-create-default-dtb
>  	$(INSTALL) -D -m 0755 $(@D)/utils/hooks/90-sort-dtb \
>  		$(TARGET_DIR)/etc/petitboot/boot.d/90-sort-dtb
> -	$(INSTALL) -m 0755 -D $(PETITBOOT_PKGDIR)/S15pb-discover \
> +	$(INSTALL) -D -m 0755 $(PETITBOOT_PKGDIR)/S15pb-discover \
>  		$(TARGET_DIR)/etc/init.d/S15pb-discover
>  	$(INSTALL) -D -m 0755 $(PETITBOOT_PKGDIR)/pb-console \
>  		$(TARGET_DIR)/etc/init.d/pb-console
>  
>  	mkdir -p $(TARGET_DIR)/etc/udev/rules.d
> -	(for port in $(PETITBOOT_GETTY_PORT); do \
> +	for port in $(PETITBOOT_GETTY_PORT); do \
>  		printf 'SUBSYSTEM=="tty", KERNEL=="%s", RUN+="/etc/init.d/pb-console start $$name"\n' "$$port"; \
> -	done) > $(TARGET_DIR)/etc/udev/rules.d/petitboot-console-ui.rules
> +	done > $(TARGET_DIR)/etc/udev/rules.d/petitboot-console-ui.rules
>  
>  	mkdir -p $(TARGET_DIR)/usr/share/udhcpc/default.script.d/
>  	ln -sf /usr/sbin/pb-udhcpc \
> -- 
> 2.39.3
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard March 8, 2024, 11:27 a.m. UTC | #2
>>>>> "Reza" == Reza Arbab <arbab@linux.ibm.com> writes:

 > Normalize the order of arguments to $(INSTALL). Remove an unnecessary
 > pair of parentheses.

 > Signed-off-by: Reza Arbab <arbab@linux.ibm.com>

Committed to 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/petitboot/petitboot.mk b/package/petitboot/petitboot.mk
index 2087f01b090c..4c8bc35adb38 100644
--- a/package/petitboot/petitboot.mk
+++ b/package/petitboot/petitboot.mk
@@ -63,15 +63,15 @@  define PETITBOOT_POST_INSTALL
 		$(TARGET_DIR)/etc/petitboot/boot.d/01-create-default-dtb
 	$(INSTALL) -D -m 0755 $(@D)/utils/hooks/90-sort-dtb \
 		$(TARGET_DIR)/etc/petitboot/boot.d/90-sort-dtb
-	$(INSTALL) -m 0755 -D $(PETITBOOT_PKGDIR)/S15pb-discover \
+	$(INSTALL) -D -m 0755 $(PETITBOOT_PKGDIR)/S15pb-discover \
 		$(TARGET_DIR)/etc/init.d/S15pb-discover
 	$(INSTALL) -D -m 0755 $(PETITBOOT_PKGDIR)/pb-console \
 		$(TARGET_DIR)/etc/init.d/pb-console
 
 	mkdir -p $(TARGET_DIR)/etc/udev/rules.d
-	(for port in $(PETITBOOT_GETTY_PORT); do \
+	for port in $(PETITBOOT_GETTY_PORT); do \
 		printf 'SUBSYSTEM=="tty", KERNEL=="%s", RUN+="/etc/init.d/pb-console start $$name"\n' "$$port"; \
-	done) > $(TARGET_DIR)/etc/udev/rules.d/petitboot-console-ui.rules
+	done > $(TARGET_DIR)/etc/udev/rules.d/petitboot-console-ui.rules
 
 	mkdir -p $(TARGET_DIR)/usr/share/udhcpc/default.script.d/
 	ln -sf /usr/sbin/pb-udhcpc \