diff mbox series

[v3,1/3] package/python-poetry-core: new host package

Message ID 20240206193048.658003-1-james.hilliard1@gmail.com
State Superseded, archived
Headers show
Series [v3,1/3] package/python-poetry-core: new host package | expand

Commit Message

James Hilliard Feb. 6, 2024, 7:30 p.m. UTC
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
Changes v2 -> v3:
  - add vendored licenses
  - bump to version 1.9.0
---
 .../python-poetry-core.hash                   |  9 +++++++
 .../python-poetry-core/python-poetry-core.mk  | 24 +++++++++++++++++++
 2 files changed, 33 insertions(+)
 create mode 100644 package/python-poetry-core/python-poetry-core.hash
 create mode 100644 package/python-poetry-core/python-poetry-core.mk

Comments

Thomas Petazzoni Feb. 6, 2024, 8:47 p.m. UTC | #1
On Tue,  6 Feb 2024 12:30:46 -0700
James Hilliard <james.hilliard1@gmail.com> wrote:

> +PYTHON_POETRY_CORE_LICENSE = \
> +	Apache-2.0 or BSD-2-Clause (packaging), \
> +	BSD-3-Clause (fastjsonschema), \
> +	GPL-2.0-or-later (lark), \

Didn't review the licensing, but in Buildroot we diverge from SPDX on
this point, and we encode GPL-2.0-or-later as GPL-2.0+.

No need to resend just for that, it can be fixed when applying.

Thomas
diff mbox series

Patch

diff --git a/package/python-poetry-core/python-poetry-core.hash b/package/python-poetry-core/python-poetry-core.hash
new file mode 100644
index 0000000000..0d908be0f4
--- /dev/null
+++ b/package/python-poetry-core/python-poetry-core.hash
@@ -0,0 +1,9 @@ 
+# md5, sha256 from https://pypi.org/pypi/poetry-core/json
+md5  eb8730e30aec5f644754b29587b47122  poetry_core-1.9.0.tar.gz
+sha256  fa7a4001eae8aa572ee84f35feb510b321bd652e5cf9293249d62853e1f935a2  poetry_core-1.9.0.tar.gz
+# Locally computed sha256 checksums
+sha256  f1978133782b90f4733bc308ddb19267c3fe04797c88d9ed3bc219032495a982  LICENSE
+sha256  8263e5652d07cecb3adadf05140b65e70cfa169ecec5f520fe1671479ce12a83  src/poetry/core/_vendor/lark/LICENSE
+sha256  cad1ef5bd340d73e074ba614d26f7deaca5c7940c3d8c34852e65c4909686c48  src/poetry/core/_vendor/packaging/LICENSE
+sha256  b80816b0d530b8accb4c2211783790984a6e3b61922c2b5ee92f3372ab2742fe  src/poetry/core/_vendor/tomli/LICENSE
+sha256  9ccddf69eb3998a60148debe85b94c5afed53691b6474692e78abcc0a0e544f1  src/poetry/core/_vendor/fastjsonschema/LICENSE
diff --git a/package/python-poetry-core/python-poetry-core.mk b/package/python-poetry-core/python-poetry-core.mk
new file mode 100644
index 0000000000..676a0c9a52
--- /dev/null
+++ b/package/python-poetry-core/python-poetry-core.mk
@@ -0,0 +1,24 @@ 
+################################################################################
+#
+# python-poetry-core
+#
+################################################################################
+
+PYTHON_POETRY_CORE_VERSION = 1.9.0
+PYTHON_POETRY_CORE_SOURCE = poetry_core-$(PYTHON_POETRY_CORE_VERSION).tar.gz
+PYTHON_POETRY_CORE_SITE = https://files.pythonhosted.org/packages/f2/db/20a9f9cae3f3c213a8c406deb4395698459fd96962cea8f2ccb230b1943c
+PYTHON_POETRY_CORE_SETUP_TYPE = pep517
+PYTHON_POETRY_CORE_LICENSE = \
+	Apache-2.0 or BSD-2-Clause (packaging), \
+	BSD-3-Clause (fastjsonschema), \
+	GPL-2.0-or-later (lark), \
+	MIT (lark, poetry-core, tomli), \
+	MPL-2.0 (lark)
+PYTHON_POETRY_CORE_LICENSE_FILES = \
+	LICENSE \
+	src/poetry/core/_vendor/lark/LICENSE \
+	src/poetry/core/_vendor/packaging/LICENSE \
+	src/poetry/core/_vendor/tomli/LICENSE \
+	src/poetry/core/_vendor/fastjsonschema/LICENSE
+
+$(eval $(host-python-package))