diff mbox series

[1/1] package/ruby: disable unsupported yjit

Message ID 20240205183308.2120022-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/ruby: disable unsupported yjit | expand

Commit Message

James Hilliard Feb. 5, 2024, 6:33 p.m. UTC
The yjit feature requires rust toolchain support, since we don't
currently handle setting up the rust toolchain for ruby lets disable
this feature for now.

This broke when ruby was bumped to version 3.3.0 in buildroot commit
a01c278df7892c8a6736334aa008b2d7c09e9258.

Fixes:
linking static-library libruby-static.a
LLVM ERROR: Invalid encoding
make[2]: *** [Makefile:318: libruby-static.a] Aborted

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/ruby/ruby.mk | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Feb. 6, 2024, 9:48 a.m. UTC | #1
On Mon,  5 Feb 2024 11:33:08 -0700
James Hilliard <james.hilliard1@gmail.com> wrote:

> The yjit feature requires rust toolchain support, since we don't
> currently handle setting up the rust toolchain for ruby lets disable
> this feature for now.
> 
> This broke when ruby was bumped to version 3.3.0 in buildroot commit
> a01c278df7892c8a6736334aa008b2d7c09e9258.
> 
> Fixes:
> linking static-library libruby-static.a
> LLVM ERROR: Invalid encoding
> make[2]: *** [Makefile:318: libruby-static.a] Aborted
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  package/ruby/ruby.mk | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/ruby/ruby.mk b/package/ruby/ruby.mk
index b2396010c5..4b9ce80e67 100644
--- a/package/ruby/ruby.mk
+++ b/package/ruby/ruby.mk
@@ -22,9 +22,14 @@  RUBY_CPE_ID_VENDOR = ruby-lang
 RUBY_DEPENDENCIES = host-pkgconf host-ruby
 HOST_RUBY_DEPENDENCIES = host-pkgconf host-openssl
 RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
-RUBY_CONF_OPTS = --disable-install-doc --disable-rpath --disable-rubygems
+RUBY_CONF_OPTS = \
+	--disable-install-doc \
+	--disable-rpath \
+	--disable-rubygems \
+	--disable-yjit
 HOST_RUBY_CONF_OPTS = \
 	--disable-install-doc \
+	--disable-yjit \
 	--with-out-ext=curses,readline \
 	--without-gmp