diff mbox series

linux.mk: Allow wildcards in BR2_LINUX_KERNEL_CUSTOM_DTS_PATH.

Message ID 20240130210553.2554954-1-gsmecher@threespeedlogic.com
State Superseded
Headers show
Series linux.mk: Allow wildcards in BR2_LINUX_KERNEL_CUSTOM_DTS_PATH. | expand

Commit Message

Graeme Smecher Jan. 30, 2024, 9:05 p.m. UTC
From: Graeme Smecher <gsmecher@threespeedlogic.com>

There are a few config/ entries where wildcards are already present:

     $ grep -rle 'BR2_LINUX_KERNEL_CUSTOM_DTS_PATH=.*\*' configs/
     configs/octavo_osd32mp1_brk_defconfig
     configs/octavo_osd32mp1_red_defconfig

...however, while the copy-in step of device tree compilation works
correctly, these wildcards are not converted to DTC build targets in the
kernel build. As a result, this configuration line alone is not enough
to generate DTCs. It should be.

This patch adds a $(wildcard) expansion step into generation of DTB
compilation targets (the LINUX_DTB_NAME variable). As a result,
wildcards behave correctly.

Signed-off-by: Graeme Smecher <gsmecher@threespeedlogic.com>
---
 linux/linux.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Alexander Sverdlin Jan. 30, 2024, 9:11 p.m. UTC | #1
Hi Graeme!

On Tue, 2024-01-30 at 13:05 -0800, gsmecher@threespeedlogic.com wrote:
> From: Graeme Smecher <gsmecher@threespeedlogic.com>
> 
> There are a few config/ entries where wildcards are already present:
> 
>      $ grep -rle 'BR2_LINUX_KERNEL_CUSTOM_DTS_PATH=.*\*' configs/
>      configs/octavo_osd32mp1_brk_defconfig
>      configs/octavo_osd32mp1_red_defconfig
> 
> ...however, while the copy-in step of device tree compilation works
> correctly, these wildcards are not converted to DTC build targets in the
> kernel build. As a result, this configuration line alone is not enough
> to generate DTCs. It should be.
> 
> This patch adds a $(wildcard) expansion step into generation of DTB
> compilation targets (the LINUX_DTB_NAME variable). As a result,
> wildcards behave correctly.
> 
> Signed-off-by: Graeme Smecher <gsmecher@threespeedlogic.com>

Makes sense to me (except a dot in the commit Subject),

Reviewed-by: Alexander Sverdlin <alexander.sverdlin@gmail.com>

> ---
>  linux/linux.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/linux/linux.mk b/linux/linux.mk
> index 1db5c6046d..80881597ad 100644
> --- a/linux/linux.mk
> +++ b/linux/linux.mk
> @@ -195,7 +195,7 @@ LINUX_DTS_NAME += $(call qstrip,$(BR2_LINUX_KERNEL_INTREE_DTS_NAME))
>  # and .dtsi files in BR2_LINUX_KERNEL_CUSTOM_DTS_PATH. Both will be
>  # copied to arch/<arch>/boot/dts, but only the .dts files will
>  # actually be generated as .dtb.
> -LINUX_DTS_NAME += $(basename $(filter %.dts,$(notdir $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)))))
> +LINUX_DTS_NAME += $(basename $(filter %.dts,$(notdir $(wildcard $(call qstrip, $(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH))))))
>  
>  LINUX_DTBS = $(addsuffix .dtb,$(LINUX_DTS_NAME))
>
diff mbox series

Patch

diff --git a/linux/linux.mk b/linux/linux.mk
index 1db5c6046d..80881597ad 100644
--- a/linux/linux.mk
+++ b/linux/linux.mk
@@ -195,7 +195,7 @@  LINUX_DTS_NAME += $(call qstrip,$(BR2_LINUX_KERNEL_INTREE_DTS_NAME))
 # and .dtsi files in BR2_LINUX_KERNEL_CUSTOM_DTS_PATH. Both will be
 # copied to arch/<arch>/boot/dts, but only the .dts files will
 # actually be generated as .dtb.
-LINUX_DTS_NAME += $(basename $(filter %.dts,$(notdir $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH)))))
+LINUX_DTS_NAME += $(basename $(filter %.dts,$(notdir $(wildcard $(call qstrip, $(BR2_LINUX_KERNEL_CUSTOM_DTS_PATH))))))
 
 LINUX_DTBS = $(addsuffix .dtb,$(LINUX_DTS_NAME))