diff mbox series

[1/1] package/weston: fix build without gbm

Message ID 20240122211451.3591-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/weston: fix build without gbm | expand

Commit Message

Fabrice Fontaine Jan. 22, 2024, 9:14 p.m. UTC
Fix the following build failure without gbm raised since commit
534c22dd606e200969fce49b8d23b27902dec94e:

Message: dmabuf-feedback requires gbm which was not found. If you rather not build this, drop "dmabuf-feedback" from simple-clients option.

Fixes:
 - http://autobuild.buildroot.org/results/ebbba1d73ceeaacee17fde0c6c853415cd316091

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/weston/weston.mk | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Yann E. MORIN Jan. 27, 2024, 5:08 p.m. UTC | #1
Fabrice, All,

On 2024-01-22 22:14 +0100, Fabrice Fontaine spake thusly:
> Fix the following build failure without gbm raised since commit
> 534c22dd606e200969fce49b8d23b27902dec94e:
> 
> Message: dmabuf-feedback requires gbm which was not found. If you rather not build this, drop "dmabuf-feedback" from simple-clients option.
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/ebbba1d73ceeaacee17fde0c6c853415cd316091
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/weston/weston.mk | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/package/weston/weston.mk b/package/weston/weston.mk
> index 6a5c0e57f5..bf8c7ced85 100644
> --- a/package/weston/weston.mk
> +++ b/package/weston/weston.mk
> @@ -25,9 +25,6 @@ WESTON_CONF_OPTS = \
>  ifeq ($(BR2_PACKAGE_WESTON_SIMPLE_CLIENTS),y)
>  WESTON_SIMPLE_CLIENTS = \

I've added a little comment to explain why the list is incomplete.

>  	damage \
> -	dmabuf-egl \
> -	dmabuf-feedback \
> -	egl \
>  	im \
>  	shm \
>  	touch
> @@ -57,6 +54,9 @@ endif
>  ifeq ($(BR2_PACKAGE_HAS_LIBEGL_WAYLAND)$(BR2_PACKAGE_HAS_LIBGBM)$(BR2_PACKAGE_HAS_LIBGLES),yyy)
>  WESTON_CONF_OPTS += -Drenderer-gl=true
>  WESTON_DEPENDENCIES += libegl libgbm libgles
> +ifeq ($(BR2_PACKAGE_WESTON_SIMPLE_CLIENTS),y)
> +WESTON_SIMPLE_CLIENTS += dmabuf-egl dmabuf-feedback egl

Now, with this change, WESTON_SIMPLE_CLIENTS is asigned below the place
it is expanded to set the option. It is technically inconsequential in
this context, but for us mere humans, it is always a bit puzzling to
see a variable expansion before it is (fully) assigned. so I moved ita
bit later.

Applied to master, thanks.

Regards,
Yann E. MORIN.

> +endif
>  ifeq ($(BR2_PACKAGE_PIPEWIRE)$(BR2_PACKAGE_WESTON_DRM),yy)
>  WESTON_CONF_OPTS += -Dpipewire=true -Dbackend-pipewire=true
>  WESTON_DEPENDENCIES += pipewire
> -- 
> 2.43.0
>
Peter Korsgaard Feb. 28, 2024, 4:40 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fix the following build failure without gbm raised since commit
 > 534c22dd606e200969fce49b8d23b27902dec94e:

 > Message: dmabuf-feedback requires gbm which was not found. If you
 > rather not build this, drop "dmabuf-feedback" from simple-clients
 > option.

 > Fixes:
 >  - http://autobuild.buildroot.org/results/ebbba1d73ceeaacee17fde0c6c853415cd316091

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/weston/weston.mk b/package/weston/weston.mk
index 6a5c0e57f5..bf8c7ced85 100644
--- a/package/weston/weston.mk
+++ b/package/weston/weston.mk
@@ -25,9 +25,6 @@  WESTON_CONF_OPTS = \
 ifeq ($(BR2_PACKAGE_WESTON_SIMPLE_CLIENTS),y)
 WESTON_SIMPLE_CLIENTS = \
 	damage \
-	dmabuf-egl \
-	dmabuf-feedback \
-	egl \
 	im \
 	shm \
 	touch
@@ -57,6 +54,9 @@  endif
 ifeq ($(BR2_PACKAGE_HAS_LIBEGL_WAYLAND)$(BR2_PACKAGE_HAS_LIBGBM)$(BR2_PACKAGE_HAS_LIBGLES),yyy)
 WESTON_CONF_OPTS += -Drenderer-gl=true
 WESTON_DEPENDENCIES += libegl libgbm libgles
+ifeq ($(BR2_PACKAGE_WESTON_SIMPLE_CLIENTS),y)
+WESTON_SIMPLE_CLIENTS += dmabuf-egl dmabuf-feedback egl
+endif
 ifeq ($(BR2_PACKAGE_PIPEWIRE)$(BR2_PACKAGE_WESTON_DRM),yy)
 WESTON_CONF_OPTS += -Dpipewire=true -Dbackend-pipewire=true
 WESTON_DEPENDENCIES += pipewire