diff mbox series

[1/1] package/zlog: disable -Werror

Message ID 20240120163622.261411-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/zlog: disable -Werror | expand

Commit Message

Fabrice Fontaine Jan. 20, 2024, 4:36 p.m. UTC
Set WARNINGS="" to disable -Werror and fix the following build failure
raised since bump to version 1.2.17 in commit
53779570e50307482d095ff6ef95582cac2a0165 and
https://github.com/HardySimpson/zlog/commit/b8d9634a1a9fb6c60ec2a23b0cb4b5e29e6e3502:

event.c: In function 'zlog_event_new':
event.c:94:72: error: cast from pointer to integer of different size [-Werror=pointer-to-int-cast]
   94 |         a_event->tid_hex_str_len = sprintf(a_event->tid_hex_str, "%x", (unsigned int)a_event->tid);
      |                                                                        ^
cc1: all warnings being treated as errors

Fixes:
 - http://autobuild.buildroot.org/results/21e9212dbb3d77108b45f755890a8e66b23d2407

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/zlog/zlog.mk | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN Jan. 20, 2024, 11:10 p.m. UTC | #1
Fabrice, All,

On 2024-01-20 17:36 +0100, Fabrice Fontaine spake thusly:
> Set WARNINGS="" to disable -Werror and fix the following build failure
> raised since bump to version 1.2.17 in commit
> 53779570e50307482d095ff6ef95582cac2a0165 and
> https://github.com/HardySimpson/zlog/commit/b8d9634a1a9fb6c60ec2a23b0cb4b5e29e6e3502:
> 
> event.c: In function 'zlog_event_new':
> event.c:94:72: error: cast from pointer to integer of different size [-Werror=pointer-to-int-cast]
>    94 |         a_event->tid_hex_str_len = sprintf(a_event->tid_hex_str, "%x", (unsigned int)a_event->tid);
>       |                                                                        ^
> cc1: all warnings being treated as errors
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/21e9212dbb3d77108b45f755890a8e66b23d2407
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/zlog/zlog.mk | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/package/zlog/zlog.mk b/package/zlog/zlog.mk
> index ccf2576529..347f482211 100644
> --- a/package/zlog/zlog.mk
> +++ b/package/zlog/zlog.mk
> @@ -12,8 +12,9 @@ ZLOG_CPE_ID_VENDOR = zlog_project
>  ZLOG_INSTALL_STAGING = YES
>  
>  define ZLOG_BUILD_CMDS
> -	$(TARGET_MAKE_ENV) $(MAKE1) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
> -		-C $(@D) all
> +	$(TARGET_MAKE_ENV) $(MAKE1) \
> +		CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
> +		WARNINGS="" -C $(@D) all
>  endef
>  
>  define ZLOG_INSTALL_STAGING_CMDS
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/zlog/zlog.mk b/package/zlog/zlog.mk
index ccf2576529..347f482211 100644
--- a/package/zlog/zlog.mk
+++ b/package/zlog/zlog.mk
@@ -12,8 +12,9 @@  ZLOG_CPE_ID_VENDOR = zlog_project
 ZLOG_INSTALL_STAGING = YES
 
 define ZLOG_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(MAKE1) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
-		-C $(@D) all
+	$(TARGET_MAKE_ENV) $(MAKE1) \
+		CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
+		WARNINGS="" -C $(@D) all
 endef
 
 define ZLOG_INSTALL_STAGING_CMDS