diff mbox series

[2/2] package/micropython: drop GIT_DIR=. workaround

Message ID 20240111105621.2321957-2-peter@korsgaard.com
State Accepted
Headers show
Series [1/2] package/Makefile.in: set GIT_DIR=. in {HOST, TARGET}_MAKE_ENV | expand

Commit Message

Peter Korsgaard Jan. 11, 2024, 10:56 a.m. UTC
Now that it is handled globally in TARGET_MAKE_ENV.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/micropython/micropython.mk | 5 -----
 1 file changed, 5 deletions(-)

Comments

Yann E. MORIN Jan. 11, 2024, 8:08 p.m. UTC | #1
Peter, All,

On 2024-01-11 11:56 +0100, Peter Korsgaard spake thusly:
> Now that it is handled globally in TARGET_MAKE_ENV.
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/micropython/micropython.mk | 5 -----
>  1 file changed, 5 deletions(-)
> 
> diff --git a/package/micropython/micropython.mk b/package/micropython/micropython.mk
> index e6eb536ea5..3d356c51d8 100644
> --- a/package/micropython/micropython.mk
> +++ b/package/micropython/micropython.mk
> @@ -14,11 +14,6 @@ MICROPYTHON_LICENSE = MIT, BSD-1-Clause, BSD-3-Clause, Zlib
>  MICROPYTHON_LICENSE_FILES = LICENSE
>  MICROPYTHON_DEPENDENCIES = host-pkgconf libffi host-python3
>  
> -# Set GIT_DIR so package won't use buildroot's version number
> -MICROPYTHON_MAKE_ENV = \
> -	$(TARGET_MAKE_ENV) \
> -	GIT_DIR=.
> -
>  # Use fallback implementation for exception handling on architectures that don't
>  # have explicit support.
>  ifeq ($(BR2_i386)$(BR2_x86_64)$(BR2_arm)$(BR2_armeb),)
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Jan. 13, 2024, 8:31 p.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Now that it is handled globally in TARGET_MAKE_ENV.
 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2023.02.x and 2023.11.x, thanks.
Yann E. MORIN Jan. 21, 2024, 1:12 p.m. UTC | #3
Peter, All,

On 2024-01-11 11:56 +0100, Peter Korsgaard spake thusly:
> Now that it is handled globally in TARGET_MAKE_ENV.
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
> ---
>  package/micropython/micropython.mk | 5 -----
>  1 file changed, 5 deletions(-)
> 
> diff --git a/package/micropython/micropython.mk b/package/micropython/micropython.mk
> index e6eb536ea5..3d356c51d8 100644
> --- a/package/micropython/micropython.mk
> +++ b/package/micropython/micropython.mk
> @@ -14,11 +14,6 @@ MICROPYTHON_LICENSE = MIT, BSD-1-Clause, BSD-3-Clause, Zlib
>  MICROPYTHON_LICENSE_FILES = LICENSE
>  MICROPYTHON_DEPENDENCIES = host-pkgconf libffi host-python3
>  
> -# Set GIT_DIR so package won't use buildroot's version number
> -MICROPYTHON_MAKE_ENV = \
> -	$(TARGET_MAKE_ENV) \
> -	GIT_DIR=.

I was way too sloppy when applying this patch: MICROPYTHON_MAKE_ENV
previously contained $(TARGET_MAKE_ENV), but now it is totally unset,
and the expansions of it have not been replaced with TARGET_MAKE_ENV,
leading to all sorts of build faiulures, like:

    LINK build-standard/micropython
    arm-linux-gcc: ERROR: unsafe header/library path used in cross-compilation: '-L/usr/lib64/../lib64'

I suspect it is also the issue reported by Julien in his micropython
runtime test:

    https://patchwork.ozlabs.org/project/buildroot/patch/20240116210556.589407-1-ju.o@free.fr/

I'll push a fixup patch that uses TARGET_MAKE_ENV

Regards,
Yann E. MORIN.

>  # Use fallback implementation for exception handling on architectures that don't
>  # have explicit support.
>  ifeq ($(BR2_i386)$(BR2_x86_64)$(BR2_arm)$(BR2_armeb),)
> -- 
> 2.39.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Peter Korsgaard Jan. 21, 2024, 7:29 p.m. UTC | #4
>>>>> "Yann" == Yann E MORIN <yann.morin.1998@free.fr> writes:

 > Peter, All,
 > On 2024-01-11 11:56 +0100, Peter Korsgaard spake thusly:
 >> Now that it is handled globally in TARGET_MAKE_ENV.
 >> 
 >> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
 >> ---
 >> package/micropython/micropython.mk | 5 -----
 >> 1 file changed, 5 deletions(-)
 >> 
 >> diff --git a/package/micropython/micropython.mk b/package/micropython/micropython.mk
 >> index e6eb536ea5..3d356c51d8 100644
 >> --- a/package/micropython/micropython.mk
 >> +++ b/package/micropython/micropython.mk
 >> @@ -14,11 +14,6 @@ MICROPYTHON_LICENSE = MIT, BSD-1-Clause, BSD-3-Clause, Zlib
 >> MICROPYTHON_LICENSE_FILES = LICENSE
 >> MICROPYTHON_DEPENDENCIES = host-pkgconf libffi host-python3
 >> 
 >> -# Set GIT_DIR so package won't use buildroot's version number
 >> -MICROPYTHON_MAKE_ENV = \
 >> -	$(TARGET_MAKE_ENV) \
 >> -	GIT_DIR=.

 > I was way too sloppy when applying this patch: MICROPYTHON_MAKE_ENV
 > previously contained $(TARGET_MAKE_ENV), but now it is totally unset,
 > and the expansions of it have not been replaced with TARGET_MAKE_ENV,
 > leading to all sorts of build faiulures, like:

 >     LINK build-standard/micropython
 >     arm-linux-gcc: ERROR: unsafe header/library path used in
 > cross-compilation: '-L/usr/lib64/../lib64'

 > I suspect it is also the issue reported by Julien in his micropython
 > runtime test:

 >     https://patchwork.ozlabs.org/project/buildroot/patch/20240116210556.589407-1-ju.o@free.fr/

 > I'll push a fixup patch that uses TARGET_MAKE_ENV

Argh, thanks! Sorry.
diff mbox series

Patch

diff --git a/package/micropython/micropython.mk b/package/micropython/micropython.mk
index e6eb536ea5..3d356c51d8 100644
--- a/package/micropython/micropython.mk
+++ b/package/micropython/micropython.mk
@@ -14,11 +14,6 @@  MICROPYTHON_LICENSE = MIT, BSD-1-Clause, BSD-3-Clause, Zlib
 MICROPYTHON_LICENSE_FILES = LICENSE
 MICROPYTHON_DEPENDENCIES = host-pkgconf libffi host-python3
 
-# Set GIT_DIR so package won't use buildroot's version number
-MICROPYTHON_MAKE_ENV = \
-	$(TARGET_MAKE_ENV) \
-	GIT_DIR=.
-
 # Use fallback implementation for exception handling on architectures that don't
 # have explicit support.
 ifeq ($(BR2_i386)$(BR2_x86_64)$(BR2_arm)$(BR2_armeb),)