diff mbox series

[1/1] package/python-semver: bump to version 3.0.2

Message ID 20240111060214.3026046-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/python-semver: bump to version 3.0.2 | expand

Commit Message

James Hilliard Jan. 11, 2024, 6:02 a.m. UTC
Add new host-python-setuptools-scm build dependency.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-semver/Config.in          | 2 +-
 package/python-semver/python-semver.hash | 6 +++---
 package/python-semver/python-semver.mk   | 5 +++--
 3 files changed, 7 insertions(+), 6 deletions(-)

Comments

Peter Korsgaard Feb. 6, 2024, 3:41 p.m. UTC | #1
On 11/01/2024 07.02, James Hilliard wrote:
> Add new host-python-setuptools-scm build dependency.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/python-semver/Config.in b/package/python-semver/Config.in
index 4af2bbf449..db83d8edc4 100644
--- a/package/python-semver/Config.in
+++ b/package/python-semver/Config.in
@@ -1,6 +1,6 @@ 
 config BR2_PACKAGE_PYTHON_SEMVER
 	bool "python-semver"
 	help
-	  Python helper for Semantic Versioning (http://semver.org/).
+	  Python helper for Semantic Versioning (https://semver.org).
 
 	  https://github.com/python-semver/python-semver
diff --git a/package/python-semver/python-semver.hash b/package/python-semver/python-semver.hash
index 10cb0a8464..1e06167610 100644
--- a/package/python-semver/python-semver.hash
+++ b/package/python-semver/python-semver.hash
@@ -1,5 +1,5 @@ 
 # md5, sha256 from https://pypi.org/pypi/semver/json
-md5  e98b5fb283ea84daa5195087de83ebf1  semver-2.13.0.tar.gz
-sha256  fa0fe2722ee1c3f57eac478820c3a5ae2f624af8264cbdf9000c980ff7f75e3f  semver-2.13.0.tar.gz
-# Locally computed
+md5  0bbc4d74959c9f1522f75ffb4ae0934d  semver-3.0.2.tar.gz
+sha256  6253adb39c70f6e51afed2fa7152bcd414c411286088fb4b9effb133885ab4cc  semver-3.0.2.tar.gz
+# Locally computed sha256 checksums
 sha256  cda490c32e61d3884dc17791fc8078f2a3e564fba98dd18b4dc64eb2720b2b6f  LICENSE.txt
diff --git a/package/python-semver/python-semver.mk b/package/python-semver/python-semver.mk
index d3a905754f..29d7ba46b1 100644
--- a/package/python-semver/python-semver.mk
+++ b/package/python-semver/python-semver.mk
@@ -4,11 +4,12 @@ 
 #
 ################################################################################
 
-PYTHON_SEMVER_VERSION = 2.13.0
+PYTHON_SEMVER_VERSION = 3.0.2
 PYTHON_SEMVER_SOURCE = semver-$(PYTHON_SEMVER_VERSION).tar.gz
-PYTHON_SEMVER_SITE = https://files.pythonhosted.org/packages/31/a9/b61190916030ee9af83de342e101f192bbb436c59be20a4cb0cdb7256ece
+PYTHON_SEMVER_SITE = https://files.pythonhosted.org/packages/41/6c/a536cc008f38fd83b3c1b98ce19ead13b746b5588c9a0cb9dd9f6ea434bc
 PYTHON_SEMVER_SETUP_TYPE = setuptools
 PYTHON_SEMVER_LICENSE = BSD-3-Clause
 PYTHON_SEMVER_LICENSE_FILES = LICENSE.txt
+PYTHON_SEMVER_DEPENDENCIES = host-python-setuptools-scm
 
 $(eval $(python-package))