diff mbox series

[1/1] package/python-aiohttp-sse-client: new package

Message ID 20240110163726.447025-1-arnomessiaen@gmail.com
State New
Headers show
Series [1/1] package/python-aiohttp-sse-client: new package | expand

Commit Message

arnomessiaen@gmail.com Jan. 10, 2024, 4:37 p.m. UTC
From: Arno Messiaen <arnomessiaen@gmail.com>

This patch adds the python-aiohttp-sse-client package to buildroot.
This package adds SSE client support to the aiohttp library, as
opposed to the already exising python-aiohttp-sse package, which
only adds sse server support.

Signed-off-by: Arno Messiaen <arnomessiaen@gmail.com>
---
 DEVELOPERS                                    |  3 ++
 package/Config.in                             |  1 +
 ....py-remove-pytest-runner-requirement.patch | 37 +++++++++++++++++++
 package/python-aiohttp-sse-client/Config.in   |  7 ++++
 .../python-aiohttp-sse-client.hash            |  5 +++
 .../python-aiohttp-sse-client.mk              | 14 +++++++
 6 files changed, 67 insertions(+)
 create mode 100644 package/python-aiohttp-sse-client/0001-setup.py-remove-pytest-runner-requirement.patch
 create mode 100644 package/python-aiohttp-sse-client/Config.in
 create mode 100644 package/python-aiohttp-sse-client/python-aiohttp-sse-client.hash
 create mode 100644 package/python-aiohttp-sse-client/python-aiohttp-sse-client.mk
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index d7543247f2..ebdf8eb892 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -257,6 +257,9 @@  F:	package/mali-t76x/
 N:	Arnaud Aujon <arnaud@intelibre.fr>
 F:	package/espeak/
 
+N:	Arno Messiaen <arnomessiaen@gmail.com>
+F:	package/python-aiohttp-sse-client/
+
 N:	Arnout Vandecappelle <arnout@mind.be>
 F:	package/arp-scan/
 F:	package/dehydrated/
diff --git a/package/Config.in b/package/Config.in
index f5d0c06334..2302188fe5 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -971,6 +971,7 @@  menu "External python modules"
 	source "package/python-aiohttp-security/Config.in"
 	source "package/python-aiohttp-session/Config.in"
 	source "package/python-aiohttp-sse/Config.in"
+	source "package/python-aiohttp-sse-client/Config.in"
 	source "package/python-aiojobs/Config.in"
 	source "package/python-aiologstash/Config.in"
 	source "package/python-aiomonitor/Config.in"
diff --git a/package/python-aiohttp-sse-client/0001-setup.py-remove-pytest-runner-requirement.patch b/package/python-aiohttp-sse-client/0001-setup.py-remove-pytest-runner-requirement.patch
new file mode 100644
index 0000000000..96289797f1
--- /dev/null
+++ b/package/python-aiohttp-sse-client/0001-setup.py-remove-pytest-runner-requirement.patch
@@ -0,0 +1,37 @@ 
+From fdba1f12843d0fdbd5094144a8081244b71b2cf0 Mon Sep 17 00:00:00 2001
+From: Arno Messiaen <arnomessiaen@gmail.com>
+Date: Wed, 22 Nov 2023 08:12:08 +0100
+Subject: [PATCH] setup.py: remove pytest-runner requirement
+
+setup.py: pytest-runner is not required to install the package
+
+Signed-off-by: Arno Messiaen <arnomessiaen@gmail.com>
+
+---
+ setup.py | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 062bb08..f19bc0a 100644
+--- a/setup.py
++++ b/setup.py
+@@ -13,8 +13,6 @@ with open('HISTORY.rst') as history_file:
+ 
+ requirements = ['aiohttp>=3', 'attrs', 'multidict', 'yarl', ]
+ 
+-setup_requirements = ['pytest-runner', ]
+-
+ test_requirements = ['pytest', ]
+ 
+ setup(
+@@ -41,7 +39,6 @@ setup(
+     keywords='aiohttp_sse_client',
+     name='aiohttp-sse-client',
+     packages=find_packages(include=['aiohttp_sse_client']),
+-    setup_requires=setup_requirements,
+     test_suite='tests',
+     tests_require=test_requirements,
+     url='https://github.com/rtfol/aiohttp-sse-client',
+-- 
+2.40.1
+
diff --git a/package/python-aiohttp-sse-client/Config.in b/package/python-aiohttp-sse-client/Config.in
new file mode 100644
index 0000000000..a4f6a14060
--- /dev/null
+++ b/package/python-aiohttp-sse-client/Config.in
@@ -0,0 +1,7 @@ 
+config BR2_PACKAGE_PYTHON_AIOHTTP_SSE_CLIENT
+	bool "python-aiohttp-sse-client"
+	select BR2_PACKAGE_PYTHON_AIOHTTP # runtime
+	help
+	  Server-sent events client support for aiohttp.
+
+	  https://github.com/rtfol/aiohttp-sse-client
diff --git a/package/python-aiohttp-sse-client/python-aiohttp-sse-client.hash b/package/python-aiohttp-sse-client/python-aiohttp-sse-client.hash
new file mode 100644
index 0000000000..5a1d240777
--- /dev/null
+++ b/package/python-aiohttp-sse-client/python-aiohttp-sse-client.hash
@@ -0,0 +1,5 @@ 
+# md5, sha256 from https://pypi.org/pypi/aiohttp-sse-client/json
+md5  d9065bf151fbb485a175ae453a9a5f9f  aiohttp-sse-client-0.2.1.tar.gz
+sha256  5004e29271624af586158dc7166cb0687a7a5997aab5b808f4b53400e1b72e3b  aiohttp-sse-client-0.2.1.tar.gz
+# Locally computed sha256 checksums
+sha256  44c346abc42b39f1390e4747adfd60a3ca349e01462965e5750ae531299b8ff1  LICENSE
diff --git a/package/python-aiohttp-sse-client/python-aiohttp-sse-client.mk b/package/python-aiohttp-sse-client/python-aiohttp-sse-client.mk
new file mode 100644
index 0000000000..4feae517ae
--- /dev/null
+++ b/package/python-aiohttp-sse-client/python-aiohttp-sse-client.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+#
+# python-aiohttp-sse-client
+#
+################################################################################
+
+PYTHON_AIOHTTP_SSE_CLIENT_VERSION = 0.2.1
+PYTHON_AIOHTTP_SSE_CLIENT_SOURCE = aiohttp-sse-client-$(PYTHON_AIOHTTP_SSE_CLIENT_VERSION).tar.gz
+PYTHON_AIOHTTP_SSE_CLIENT_SITE = https://files.pythonhosted.org/packages/71/c3/4825c5f37909a70c8018924b3d521847dd7acf1fce7e1054574bafed2271
+PYTHON_AIOHTTP_SSE_CLIENT_SETUP_TYPE = setuptools
+PYTHON_AIOHTTP_SSE_CLIENT_LICENSE = Apache-2.0
+PYTHON_AIOHTTP_SSE_CLIENT_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))