diff mbox series

[1/1] package/python-pylibftdi: bump to version 0.21.0

Message ID 20240110053449.1157385-1-james.hilliard1@gmail.com
State Accepted
Headers show
Series [1/1] package/python-pylibftdi: bump to version 0.21.0 | expand

Commit Message

James Hilliard Jan. 10, 2024, 5:34 a.m. UTC
License hash changed due to year update:
https://github.com/codedstructure/pylibftdi/commit/c96231bb8134a2afeb0b77c12474b97a3355d2dc

Fixup patch so that it applies against 0.21.0.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 .../0001-do-not-use-find-library.patch            | 15 ++++++++-------
 package/python-pylibftdi/python-pylibftdi.hash    |  6 +++---
 package/python-pylibftdi/python-pylibftdi.mk      |  4 ++--
 3 files changed, 13 insertions(+), 12 deletions(-)

Comments

Thomas Petazzoni Feb. 6, 2024, 3:21 p.m. UTC | #1
On Tue,  9 Jan 2024 22:34:49 -0700
James Hilliard <james.hilliard1@gmail.com> wrote:

> License hash changed due to year update:
> https://github.com/codedstructure/pylibftdi/commit/c96231bb8134a2afeb0b77c12474b97a3355d2dc
> 
> Fixup patch so that it applies against 0.21.0.
> 
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>  .../0001-do-not-use-find-library.patch            | 15 ++++++++-------
>  package/python-pylibftdi/python-pylibftdi.hash    |  6 +++---
>  package/python-pylibftdi/python-pylibftdi.mk      |  4 ++--
>  3 files changed, 13 insertions(+), 12 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/python-pylibftdi/0001-do-not-use-find-library.patch b/package/python-pylibftdi/0001-do-not-use-find-library.patch
index 192ed43e54..19dabebffe 100644
--- a/package/python-pylibftdi/0001-do-not-use-find-library.patch
+++ b/package/python-pylibftdi/0001-do-not-use-find-library.patch
@@ -15,17 +15,18 @@  this package.
 Signed-off-by: Christian Kellermann <christian.kellermann@solectrix.de>
 
 ---
-diff -purN pylibftdi-0.15.0.orig/pylibftdi/driver.py pylibftdi-0.15.0/pylibftdi/driver.py
---- pylibftdi-0.15.0.orig/pylibftdi/driver.py	2015-04-26 22:41:39.000000000 +0200
-+++ pylibftdi-0.15.0/pylibftdi/driver.py	2017-02-27 13:08:56.502958000 +0100
-@@ -121,8 +121,8 @@ class Driver(object):
+diff -purN pylibftdi-0.21.0.orig/src/pylibftdi/driver.py pylibftdi-0.21.0/src/pylibftdi/driver.py
+--- pylibftdi-0.21.0.orig/src/pylibftdi/driver.py	2015-04-26 22:41:39.000000000 +0200
++++ pylibftdi-0.21.0/src/pylibftdi/driver.py	2017-02-27 13:08:56.502958000 +0100
+@@ -148,9 +148,8 @@ class Driver:
                      lib = getattr(cdll, lib_path)
                      break
          if lib is None:
--            raise LibraryMissingError('{} library not found (search: {})'.format(
--                name, search_list))
+-            raise LibraryMissingError(
+-                f"{name} library not found (search: {str(search_list)})"
+-            )
 +            return cdll.LoadLibrary(name + '.so')
 +
          return lib
- 
+
      @property
diff --git a/package/python-pylibftdi/python-pylibftdi.hash b/package/python-pylibftdi/python-pylibftdi.hash
index ee0ba127ca..5d8a19647f 100644
--- a/package/python-pylibftdi/python-pylibftdi.hash
+++ b/package/python-pylibftdi/python-pylibftdi.hash
@@ -1,5 +1,5 @@ 
 # md5, sha256 from https://pypi.org/pypi/pylibftdi/json
-md5  fb43ade3283b809d4ebe92bf4a60d7fc  pylibftdi-0.20.0.tar.gz
-sha256  f4a87fc4af2c9c7d42badd4192ca9b529f32c9d96fdc8daea7e29c509226df5f  pylibftdi-0.20.0.tar.gz
+md5  75b63f325b760cc6342b7d35fbb84fde  pylibftdi-0.21.0.tar.gz
+sha256  eb7e2f5052852547f4c6c46022a1665f9d7453439639171eade56fdc80a58832  pylibftdi-0.21.0.tar.gz
 # Locally computed sha256 checksums
-sha256  0d3f1af06b566a783091422061b60e864fc5d5853418b71643041e254b4ae7f9  LICENSE.txt
+sha256  b8a7b113cfaa2c01d0701183de16ba653465692b1e29e0229244eee42fb3a9a8  LICENSE.txt
diff --git a/package/python-pylibftdi/python-pylibftdi.mk b/package/python-pylibftdi/python-pylibftdi.mk
index 34040b72ac..7dca37e416 100644
--- a/package/python-pylibftdi/python-pylibftdi.mk
+++ b/package/python-pylibftdi/python-pylibftdi.mk
@@ -4,9 +4,9 @@ 
 #
 ################################################################################
 
-PYTHON_PYLIBFTDI_VERSION = 0.20.0
+PYTHON_PYLIBFTDI_VERSION = 0.21.0
 PYTHON_PYLIBFTDI_SOURCE = pylibftdi-$(PYTHON_PYLIBFTDI_VERSION).tar.gz
-PYTHON_PYLIBFTDI_SITE = https://files.pythonhosted.org/packages/b8/03/4f778ce6dceea58dc5bfd555c22fdb265afc922d81d3c4496a791a54c479
+PYTHON_PYLIBFTDI_SITE = https://files.pythonhosted.org/packages/d2/ce/ff3e83f3a14eb5b7950ff3657f07cdc3033dd0ded5c8ed093db515e1de33
 PYTHON_PYLIBFTDI_LICENSE = MIT
 PYTHON_PYLIBFTDI_LICENSE_FILES = LICENSE.txt
 PYTHON_PYLIBFTDI_DEPENDENCIES = libftdi