diff mbox series

[6/6] package/python-cherrypy: bump to version 18.9.0

Message ID 20240109060128.3974794-6-james.hilliard1@gmail.com
State New
Headers show
Series [1/6] package/python-autocommand: new package | expand

Commit Message

James Hilliard Jan. 9, 2024, 6:01 a.m. UTC
Add new host-python-setuptools-scm-git-archive build dependency.

Add new python-jaraco-collections runtime dependency.

Add new python-more-itertools runtime dependency.

Add new python-zc-lockfile runtime dependency.

Drop no longer required python-six and python-jaraco-classes runtime
dependencies.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-cherrypy/Config.in            | 6 ++++--
 package/python-cherrypy/python-cherrypy.hash | 4 ++--
 package/python-cherrypy/python-cherrypy.mk   | 8 +++++---
 3 files changed, 11 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/package/python-cherrypy/Config.in b/package/python-cherrypy/Config.in
index 7548dcf91b..fd67872873 100644
--- a/package/python-cherrypy/Config.in
+++ b/package/python-cherrypy/Config.in
@@ -1,10 +1,12 @@ 
 config BR2_PACKAGE_PYTHON_CHERRYPY
 	bool "python-cherrypy"
+	depends on BR2_PACKAGE_HOST_RUSTC_TARGET_ARCH_SUPPORTS # python-jaraco-collections -> python-jaraco-text -> python-inflect -> python-pydantic -> python-pydantic-core
 	select BR2_PACKAGE_PYTHON_CHEROOT # runtime
-	select BR2_PACKAGE_PYTHON_JARACO_CLASSES # runtime
+	select BR2_PACKAGE_PYTHON_JARACO_COLLECTIONS # runtime
+	select BR2_PACKAGE_PYTHON_MORE_ITERTOOLS # runtime
 	select BR2_PACKAGE_PYTHON_PORTEND # runtime
+	select BR2_PACKAGE_PYTHON_ZC_LOCKFILE # runtime
 	select BR2_PACKAGE_PYTHON3_PYEXPAT # runtime
-	select BR2_PACKAGE_PYTHON_SIX # runtime
 	select BR2_PACKAGE_PYTHON3_ZLIB # runtime
 	help
 	  A minimalist web framework
diff --git a/package/python-cherrypy/python-cherrypy.hash b/package/python-cherrypy/python-cherrypy.hash
index cd8f8756d8..92697e5f06 100644
--- a/package/python-cherrypy/python-cherrypy.hash
+++ b/package/python-cherrypy/python-cherrypy.hash
@@ -1,5 +1,5 @@ 
 # md5, sha256 from https://pypi.org/pypi/cherrypy/json
-md5  033c58bf3da497f283b039911d1c882b  CherryPy-18.8.0.tar.gz
-sha256  9b48cfba8a2f16d5b6419cc657e6d51db005ba35c5e3824e4728bb03bbc7ef9b  CherryPy-18.8.0.tar.gz
+md5  014dbd400aeda9d2b098ed01c95b4a30  CherryPy-18.9.0.tar.gz
+sha256  6b06c191ce71a86461f30572a1ab57ffc09f43143ba8e42c103c7b3347220eb1  CherryPy-18.9.0.tar.gz
 # Locally computed sha256 checksums
 sha256  45ade933c280ece37e3e01d3a91afeed9505746a456f72ad10b0897c49e65104  LICENSE.md
diff --git a/package/python-cherrypy/python-cherrypy.mk b/package/python-cherrypy/python-cherrypy.mk
index 9b6ad0e99a..244491a040 100644
--- a/package/python-cherrypy/python-cherrypy.mk
+++ b/package/python-cherrypy/python-cherrypy.mk
@@ -4,12 +4,14 @@ 
 #
 ################################################################################
 
-PYTHON_CHERRYPY_VERSION = 18.8.0
+PYTHON_CHERRYPY_VERSION = 18.9.0
 PYTHON_CHERRYPY_SOURCE = CherryPy-$(PYTHON_CHERRYPY_VERSION).tar.gz
-PYTHON_CHERRYPY_SITE = https://files.pythonhosted.org/packages/60/ea/6c4d16b0cd1f4f64a478bac8a37d75a585e854afb5693ce80a9711efdc4a
+PYTHON_CHERRYPY_SITE = https://files.pythonhosted.org/packages/bd/5f/e265a49883bfcfb7f2c3d3d9e96197cfe8136783e96c5ce20e201550aaa0
 PYTHON_CHERRYPY_LICENSE = BSD-3-Clause
 PYTHON_CHERRYPY_LICENSE_FILES = LICENSE.md
 PYTHON_CHERRYPY_SETUP_TYPE = setuptools
-PYTHON_CHERRYPY_DEPENDENCIES = host-python-setuptools-scm
+PYTHON_CHERRYPY_DEPENDENCIES = \
+	host-python-setuptools-scm \
+	host-python-setuptools-scm-git-archive
 
 $(eval $(python-package))