diff mbox series

[v2,1/4] package/python-poetry-core: new host package

Message ID 20240106214410.3294887-1-james.hilliard1@gmail.com
State Changes Requested
Headers show
Series [v2,1/4] package/python-poetry-core: new host package | expand

Commit Message

James Hilliard Jan. 6, 2024, 9:44 p.m. UTC
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
---
 package/python-poetry-core/python-poetry-core.hash |  5 +++++
 package/python-poetry-core/python-poetry-core.mk   | 14 ++++++++++++++
 2 files changed, 19 insertions(+)
 create mode 100644 package/python-poetry-core/python-poetry-core.hash
 create mode 100644 package/python-poetry-core/python-poetry-core.mk

Comments

Arnout Vandecappelle Feb. 6, 2024, 5:43 p.m. UTC | #1
Hi James,

On 06/01/2024 22:44, James Hilliard wrote:
> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> ---
>   package/python-poetry-core/python-poetry-core.hash |  5 +++++
>   package/python-poetry-core/python-poetry-core.mk   | 14 ++++++++++++++
>   2 files changed, 19 insertions(+)
>   create mode 100644 package/python-poetry-core/python-poetry-core.hash
>   create mode 100644 package/python-poetry-core/python-poetry-core.mk
> 
> diff --git a/package/python-poetry-core/python-poetry-core.hash b/package/python-poetry-core/python-poetry-core.hash
> new file mode 100644
> index 0000000000..3c07fef04f
> --- /dev/null
> +++ b/package/python-poetry-core/python-poetry-core.hash
> @@ -0,0 +1,5 @@
> +# md5, sha256 from https://pypi.org/pypi/poetry-core/json
> +md5  9ed2f2e9244165b34d7233c306a34a2a  poetry_core-1.8.1.tar.gz
> +sha256  67a76c671da2a70e55047cddda83566035b701f7e463b32a2abfeac6e2a16376  poetry_core-1.8.1.tar.gz
> +# Locally computed sha256 checksums
> +sha256  f1978133782b90f4733bc308ddb19267c3fe04797c88d9ed3bc219032495a982  LICENSE
> diff --git a/package/python-poetry-core/python-poetry-core.mk b/package/python-poetry-core/python-poetry-core.mk
> new file mode 100644
> index 0000000000..e1acf3179c
> --- /dev/null
> +++ b/package/python-poetry-core/python-poetry-core.mk
> @@ -0,0 +1,14 @@
> +################################################################################
> +#
> +# python-poetry-core
> +#
> +################################################################################
> +
> +PYTHON_POETRY_CORE_VERSION = 1.8.1
> +PYTHON_POETRY_CORE_SOURCE = poetry_core-$(PYTHON_POETRY_CORE_VERSION).tar.gz
> +PYTHON_POETRY_CORE_SITE = https://files.pythonhosted.org/packages/36/66/6af2891495d12020419c8447d0b29c1e96f3be16631faaed6bda5b886d5d
> +PYTHON_POETRY_CORE_SETUP_TYPE = pep517
> +PYTHON_POETRY_CORE_LICENSE = MIT
> +PYTHON_POETRY_CORE_LICENSE_FILES = LICENSE

  This package has 4 vendored dependencies, each with their own license. Those 
should also be specified in the LICENSE and LICENSE_FILES.

  In addition, for lark, there's a file under MPL and a file under GPL, even 
though neither if those licenses is mentioned in the lark license. Ideally those 
two should be mentioned in the LICENSES as well. And of course, this should 
ideally also be done for the python-lark package which suffers from the same 
issue...

  Regards,
  Arnout

> +
> +$(eval $(host-python-package))
James Hilliard Feb. 6, 2024, 7:32 p.m. UTC | #2
On Tue, Feb 6, 2024 at 10:43 AM Arnout Vandecappelle <arnout@mind.be> wrote:
>
>   Hi James,
>
> On 06/01/2024 22:44, James Hilliard wrote:
> > Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
> > ---
> >   package/python-poetry-core/python-poetry-core.hash |  5 +++++
> >   package/python-poetry-core/python-poetry-core.mk   | 14 ++++++++++++++
> >   2 files changed, 19 insertions(+)
> >   create mode 100644 package/python-poetry-core/python-poetry-core.hash
> >   create mode 100644 package/python-poetry-core/python-poetry-core.mk
> >
> > diff --git a/package/python-poetry-core/python-poetry-core.hash b/package/python-poetry-core/python-poetry-core.hash
> > new file mode 100644
> > index 0000000000..3c07fef04f
> > --- /dev/null
> > +++ b/package/python-poetry-core/python-poetry-core.hash
> > @@ -0,0 +1,5 @@
> > +# md5, sha256 from https://pypi.org/pypi/poetry-core/json
> > +md5  9ed2f2e9244165b34d7233c306a34a2a  poetry_core-1.8.1.tar.gz
> > +sha256  67a76c671da2a70e55047cddda83566035b701f7e463b32a2abfeac6e2a16376  poetry_core-1.8.1.tar.gz
> > +# Locally computed sha256 checksums
> > +sha256  f1978133782b90f4733bc308ddb19267c3fe04797c88d9ed3bc219032495a982  LICENSE
> > diff --git a/package/python-poetry-core/python-poetry-core.mk b/package/python-poetry-core/python-poetry-core.mk
> > new file mode 100644
> > index 0000000000..e1acf3179c
> > --- /dev/null
> > +++ b/package/python-poetry-core/python-poetry-core.mk
> > @@ -0,0 +1,14 @@
> > +################################################################################
> > +#
> > +# python-poetry-core
> > +#
> > +################################################################################
> > +
> > +PYTHON_POETRY_CORE_VERSION = 1.8.1
> > +PYTHON_POETRY_CORE_SOURCE = poetry_core-$(PYTHON_POETRY_CORE_VERSION).tar.gz
> > +PYTHON_POETRY_CORE_SITE = https://files.pythonhosted.org/packages/36/66/6af2891495d12020419c8447d0b29c1e96f3be16631faaed6bda5b886d5d
> > +PYTHON_POETRY_CORE_SETUP_TYPE = pep517
> > +PYTHON_POETRY_CORE_LICENSE = MIT
> > +PYTHON_POETRY_CORE_LICENSE_FILES = LICENSE
>
>   This package has 4 vendored dependencies, each with their own license. Those
> should also be specified in the LICENSE and LICENSE_FILES.

Does this look right?
https://patchwork.ozlabs.org/project/buildroot/patch/20240206193048.658003-1-james.hilliard1@gmail.com/

>
>   In addition, for lark, there's a file under MPL and a file under GPL, even
> though neither if those licenses is mentioned in the lark license. Ideally those
> two should be mentioned in the LICENSES as well. And of course, this should
> ideally also be done for the python-lark package which suffers from the same
> issue...
>
>   Regards,
>   Arnout
>
> > +
> > +$(eval $(host-python-package))
Arnout Vandecappelle Feb. 7, 2024, 8:23 a.m. UTC | #3
On 06/02/2024 20:32, James Hilliard wrote:
> On Tue, Feb 6, 2024 at 10:43 AM Arnout Vandecappelle <arnout@mind.be> wrote:
>>
>>    Hi James,
>>
>> On 06/01/2024 22:44, James Hilliard wrote:
>>> Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
>>> ---
>>>    package/python-poetry-core/python-poetry-core.hash |  5 +++++
>>>    package/python-poetry-core/python-poetry-core.mk   | 14 ++++++++++++++
>>>    2 files changed, 19 insertions(+)
>>>    create mode 100644 package/python-poetry-core/python-poetry-core.hash
>>>    create mode 100644 package/python-poetry-core/python-poetry-core.mk
>>>
>>> diff --git a/package/python-poetry-core/python-poetry-core.hash b/package/python-poetry-core/python-poetry-core.hash
>>> new file mode 100644
>>> index 0000000000..3c07fef04f
>>> --- /dev/null
>>> +++ b/package/python-poetry-core/python-poetry-core.hash
>>> @@ -0,0 +1,5 @@
>>> +# md5, sha256 from https://pypi.org/pypi/poetry-core/json
>>> +md5  9ed2f2e9244165b34d7233c306a34a2a  poetry_core-1.8.1.tar.gz
>>> +sha256  67a76c671da2a70e55047cddda83566035b701f7e463b32a2abfeac6e2a16376  poetry_core-1.8.1.tar.gz
>>> +# Locally computed sha256 checksums
>>> +sha256  f1978133782b90f4733bc308ddb19267c3fe04797c88d9ed3bc219032495a982  LICENSE
>>> diff --git a/package/python-poetry-core/python-poetry-core.mk b/package/python-poetry-core/python-poetry-core.mk
>>> new file mode 100644
>>> index 0000000000..e1acf3179c
>>> --- /dev/null
>>> +++ b/package/python-poetry-core/python-poetry-core.mk
>>> @@ -0,0 +1,14 @@
>>> +################################################################################
>>> +#
>>> +# python-poetry-core
>>> +#
>>> +################################################################################
>>> +
>>> +PYTHON_POETRY_CORE_VERSION = 1.8.1
>>> +PYTHON_POETRY_CORE_SOURCE = poetry_core-$(PYTHON_POETRY_CORE_VERSION).tar.gz
>>> +PYTHON_POETRY_CORE_SITE = https://files.pythonhosted.org/packages/36/66/6af2891495d12020419c8447d0b29c1e96f3be16631faaed6bda5b886d5d
>>> +PYTHON_POETRY_CORE_SETUP_TYPE = pep517
>>> +PYTHON_POETRY_CORE_LICENSE = MIT
>>> +PYTHON_POETRY_CORE_LICENSE_FILES = LICENSE
>>
>>    This package has 4 vendored dependencies, each with their own license. Those
>> should also be specified in the LICENSE and LICENSE_FILES.
> 
> Does this look right?
> https://patchwork.ozlabs.org/project/buildroot/patch/20240206193048.658003-1-james.hilliard1@gmail.com/

  Excellent, thank you!

  Regards,
  Arnout

> 
>>
>>    In addition, for lark, there's a file under MPL and a file under GPL, even
>> though neither if those licenses is mentioned in the lark license. Ideally those
>> two should be mentioned in the LICENSES as well. And of course, this should
>> ideally also be done for the python-lark package which suffers from the same
>> issue...
>>
>>    Regards,
>>    Arnout
>>
>>> +
>>> +$(eval $(host-python-package))
diff mbox series

Patch

diff --git a/package/python-poetry-core/python-poetry-core.hash b/package/python-poetry-core/python-poetry-core.hash
new file mode 100644
index 0000000000..3c07fef04f
--- /dev/null
+++ b/package/python-poetry-core/python-poetry-core.hash
@@ -0,0 +1,5 @@ 
+# md5, sha256 from https://pypi.org/pypi/poetry-core/json
+md5  9ed2f2e9244165b34d7233c306a34a2a  poetry_core-1.8.1.tar.gz
+sha256  67a76c671da2a70e55047cddda83566035b701f7e463b32a2abfeac6e2a16376  poetry_core-1.8.1.tar.gz
+# Locally computed sha256 checksums
+sha256  f1978133782b90f4733bc308ddb19267c3fe04797c88d9ed3bc219032495a982  LICENSE
diff --git a/package/python-poetry-core/python-poetry-core.mk b/package/python-poetry-core/python-poetry-core.mk
new file mode 100644
index 0000000000..e1acf3179c
--- /dev/null
+++ b/package/python-poetry-core/python-poetry-core.mk
@@ -0,0 +1,14 @@ 
+################################################################################
+#
+# python-poetry-core
+#
+################################################################################
+
+PYTHON_POETRY_CORE_VERSION = 1.8.1
+PYTHON_POETRY_CORE_SOURCE = poetry_core-$(PYTHON_POETRY_CORE_VERSION).tar.gz
+PYTHON_POETRY_CORE_SITE = https://files.pythonhosted.org/packages/36/66/6af2891495d12020419c8447d0b29c1e96f3be16631faaed6bda5b886d5d
+PYTHON_POETRY_CORE_SETUP_TYPE = pep517
+PYTHON_POETRY_CORE_LICENSE = MIT
+PYTHON_POETRY_CORE_LICENSE_FILES = LICENSE
+
+$(eval $(host-python-package))