diff mbox series

boot/arm-trusted-firmware: fix fiptool linking issue on hosts without openssl

Message ID 20240104165634.1215451-1-peter@korsgaard.com
State Accepted
Headers show
Series boot/arm-trusted-firmware: fix fiptool linking issue on hosts without openssl | expand

Commit Message

Peter Korsgaard Jan. 4, 2024, 4:56 p.m. UTC
Fixes:
https://gitlab.com/buildroot.org/buildroot/-/jobs/5834758777

Commit e7d16c35a (boot/arm-trusted-firmware: fix the RPATH of fiptool) tried
to fix the build of host-fiptool, but forgot to pass HOST_CFLAGS.

On hosts without (compatible) openssl development headers, this breaks
the build when it cannot find the openssl headers:

fiptool_platform.h:19:11: fatal error: openssl/sha.h: No such file or directory

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 boot/arm-trusted-firmware/arm-trusted-firmware.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Jan. 4, 2024, 9:43 p.m. UTC | #1
On Thu,  4 Jan 2024 17:56:33 +0100
Peter Korsgaard <peter@korsgaard.com> wrote:

> Fixes:
> https://gitlab.com/buildroot.org/buildroot/-/jobs/5834758777
> 
> Commit e7d16c35a (boot/arm-trusted-firmware: fix the RPATH of fiptool) tried
> to fix the build of host-fiptool, but forgot to pass HOST_CFLAGS.
> 
> On hosts without (compatible) openssl development headers, this breaks
> the build when it cannot find the openssl headers:
> 
> fiptool_platform.h:19:11: fatal error: openssl/sha.h: No such file or directory
> 
> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
> ---
>  boot/arm-trusted-firmware/arm-trusted-firmware.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Thanks a lot for having cooked the patch! Applied to master, thanks!

Thomas
Peter Korsgaard Jan. 5, 2024, 7:30 a.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Fixes:
 > https://gitlab.com/buildroot.org/buildroot/-/jobs/5834758777

 > Commit e7d16c35a (boot/arm-trusted-firmware: fix the RPATH of fiptool) tried
 > to fix the build of host-fiptool, but forgot to pass HOST_CFLAGS.

 > On hosts without (compatible) openssl development headers, this breaks
 > the build when it cannot find the openssl headers:

 > fiptool_platform.h:19:11: fatal error: openssl/sha.h: No such file or directory

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2023.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/boot/arm-trusted-firmware/arm-trusted-firmware.mk b/boot/arm-trusted-firmware/arm-trusted-firmware.mk
index bed873a182..7f9c896387 100644
--- a/boot/arm-trusted-firmware/arm-trusted-firmware.mk
+++ b/boot/arm-trusted-firmware/arm-trusted-firmware.mk
@@ -64,7 +64,7 @@  ARM_TRUSTED_FIRMWARE_MAKE_OPTS += \
 	$(call qstrip,$(BR2_TARGET_ARM_TRUSTED_FIRMWARE_ADDITIONAL_VARIABLES)) \
 	PLAT=$(ARM_TRUSTED_FIRMWARE_PLATFORM) \
 	TARGET_BOARD=$(ARM_TRUSTED_FIRMWARE_TARGET_BOARD) \
-	HOSTCC="$(HOSTCC) $(HOST_LDFLAGS)"
+	HOSTCC="$(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS)"
 
 ifeq ($(BR2_TARGET_ARM_TRUSTED_FIRMWARE_SSP),y)
 ARM_TRUSTED_FIRMWARE_MAKE_OPTS += \