diff mbox series

package/gdb: Remove special handling of libstdc++ for ARC

Message ID 20240102155552.1902447-1-abrodkin@synopsys.com
State Accepted
Headers show
Series package/gdb: Remove special handling of libstdc++ for ARC | expand

Commit Message

Alexey Brodkin Jan. 2, 2024, 3:55 p.m. UTC
Effectively that's a revert of a very old fix [1]
which is no longer needed.

[1] https://git.buildroot.net/buildroot/commit/?id=ca99d0ea925e5a8e42bd270402b0171a39d1d955

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
---
 package/gdb/gdb.mk | 7 -------
 1 file changed, 7 deletions(-)

Comments

Yann E. MORIN Jan. 2, 2024, 8:46 p.m. UTC | #1
Alexey, All,

On 2024-01-02 07:55 -0800, Alexey Brodkin via buildroot spake thusly:
> Effectively that's a revert of a very old fix [1]
> which is no longer needed.

It would have been nice to get a better indication of how much time it
has not been needed anymore, so that we know wehther we should backport
that to maintenance beranches. ca99d0ea925e5a8 mentions that it would be
fixed in 2017.03, so we can certainly assume that it has been fixed for
quite some time now, and thus we can backport this to all our
maintenance branches (2023.02 LTS and 2023.11).

I forgot to add that information befoe pushing, sorry.

> [1] https://git.buildroot.net/buildroot/commit/?id=ca99d0ea925e5a8e42bd270402b0171a39d1d955
> 
> Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> Cc: Yann E. MORIN <yann.morin.1998@free.fr>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/gdb/gdb.mk | 7 -------
>  1 file changed, 7 deletions(-)
> 
> diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
> index d677c6bdb1..f96086eed2 100644
> --- a/package/gdb/gdb.mk
> +++ b/package/gdb/gdb.mk
> @@ -180,13 +180,6 @@ else
>  GDB_CONF_OPTS += --disable-gdbserver
>  endif
>  
> -# When gdb is built as C++ application for ARC it segfaults at runtime
> -# So we pass --disable-build-with-cxx config option to force gdb not to
> -# be built as C++ app.
> -ifeq ($(BR2_arc),y)
> -GDB_CONF_OPTS += --disable-build-with-cxx
> -endif
> -
>  # gdb 7.12+ by default builds with a C++ compiler, which doesn't work
>  # when we don't have C++ support in the toolchain
>  ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
> -- 
> 2.31.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Alexey Brodkin Jan. 2, 2024, 9:55 p.m. UTC | #2
Hi Yann,

> On 2024-01-02 07:55 -0800, Alexey Brodkin via buildroot spake thusly:
> > Effectively that's a revert of a very old fix [1]
> > which is no longer needed.
> 
> It would have been nice to get a better indication of how much time it
> has not been needed anymore, so that we know wehther we should backport
> that to maintenance beranches. ca99d0ea925e5a8 mentions that it would be
> fixed in 2017.03, so we can certainly assume that it has been fixed for
> quite some time now, and thus we can backport this to all our
> maintenance branches (2023.02 LTS and 2023.11).
> 
> I forgot to add that information befoe pushing, sorry.

Well, indeed it's been so many years since that fix and I'm sure
that problem is long gone.

What's moreinteresting, that option "--disable-build-with-cxx" was removed
in GDB 8.x in September 2016 as since then C++ is required, see
https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=cf6de44d75082116865a85cbf94db2632b679361

That said it's totaly fine to back-port that fix to stable Buildroot branches,
but since it's not functional (it doesn't change anyting in reality) I'd say
there's no point in back-porting it.

Moreover another use of "--disable-build-with-cxx" needs to go away, see
https://git.buildroot.net/buildroot/tree/package/gdb/gdb.mk#n188:
------------------------>8-----------------------
# gdb 7.12+ by default builds with a C++ compiler, which doesn't work
# when we don't have C++ support in the toolchain
ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
GDB_CONF_OPTS += --disable-build-with-cxx
endif
------------------------>8-----------------------

Do you want me to prepare that patch or you prefer to quickly do that yourself?

Regards,
Alexey
Yann E. MORIN Jan. 3, 2024, 8:31 p.m. UTC | #3
Alexey, All,

On 2024-01-02 21:55 +0000, Alexey Brodkin via buildroot spake thusly:
[--SNIP--]
> What's moreinteresting, that option "--disable-build-with-cxx" was removed
> in GDB 8.x in September 2016 as since then C++ is required, see
> https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=cf6de44d75082116865a85cbf94db2632b679361
> 
> That said it's totaly fine to back-port that fix to stable Buildroot branches,
> but since it's not functional (it doesn't change anyting in reality) I'd say
> there's no point in back-porting it.

OK, that's Peter's call, so your input is going to be helpful to him to
assess whether to backport or not, thanls!

> Moreover another use of "--disable-build-with-cxx" needs to go away, see
> https://git.buildroot.net/buildroot/tree/package/gdb/gdb.mk#n188:
> ------------------------>8-----------------------
> # gdb 7.12+ by default builds with a C++ compiler, which doesn't work
> # when we don't have C++ support in the toolchain
> ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
> GDB_CONF_OPTS += --disable-build-with-cxx
> endif
> ------------------------>8-----------------------

Indeed, and we do have the proper dependency in Buildroot already, since
d36f2c73331b (package/gdb: remove gdb 7.12.1) in 2019.

Good catch!

> Do you want me to prepare that patch or you prefer to quickly do that yourself?

Please do.

Regards,
Yann E. MORIN.
Peter Korsgaard Jan. 12, 2024, 4:34 p.m. UTC | #4
>>>>> "Alexey" == Alexey Brodkin via buildroot <buildroot@buildroot.org> writes:

 > Hi Yann,
 >> On 2024-01-02 07:55 -0800, Alexey Brodkin via buildroot spake thusly:
 >> > Effectively that's a revert of a very old fix [1]
 >> > which is no longer needed.
 >> 
 >> It would have been nice to get a better indication of how much time it
 >> has not been needed anymore, so that we know wehther we should backport
 >> that to maintenance beranches. ca99d0ea925e5a8 mentions that it would be
 >> fixed in 2017.03, so we can certainly assume that it has been fixed for
 >> quite some time now, and thus we can backport this to all our
 >> maintenance branches (2023.02 LTS and 2023.11).
 >> 
 >> I forgot to add that information befoe pushing, sorry.

 > Well, indeed it's been so many years since that fix and I'm sure
 > that problem is long gone.

 > What's moreinteresting, that option "--disable-build-with-cxx" was removed
 > in GDB 8.x in September 2016 as since then C++ is required, see
 > https://sourceware.org/git/?p=binutils-gdb.git;a=commit;h=cf6de44d75082116865a85cbf94db2632b679361

 > That said it's totaly fine to back-port that fix to stable Buildroot branches,
 > but since it's not functional (it doesn't change anyting in reality) I'd say
 > there's no point in back-porting it.

Committed to 2023.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index d677c6bdb1..f96086eed2 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -180,13 +180,6 @@  else
 GDB_CONF_OPTS += --disable-gdbserver
 endif
 
-# When gdb is built as C++ application for ARC it segfaults at runtime
-# So we pass --disable-build-with-cxx config option to force gdb not to
-# be built as C++ app.
-ifeq ($(BR2_arc),y)
-GDB_CONF_OPTS += --disable-build-with-cxx
-endif
-
 # gdb 7.12+ by default builds with a C++ compiler, which doesn't work
 # when we don't have C++ support in the toolchain
 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)