diff mbox series

[1/1] package/gupnp-tools: bump to version 0.12.1

Message ID 20231229214918.15851-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/gupnp-tools: bump to version 0.12.1 | expand

Commit Message

Fabrice Fontaine Dec. 29, 2023, 9:49 p.m. UTC
- libsoup has been replaced by libsoup3
- Add patches to fix build with libxml2 2.12

https://gitlab.gnome.org/GNOME/gupnp-tools/-/blob/gupnp-tools-0.12.1/NEWS

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 ...mon-Drop-deprecated-xmlRecoverMemory.patch | 33 +++++++++++++++++++
 ...-Fix-compatibility-with-libxml2-2-12.patch | 28 ++++++++++++++++
 package/gupnp-tools/Config.in                 |  4 +--
 package/gupnp-tools/gupnp-tools.hash          |  4 +--
 package/gupnp-tools/gupnp-tools.mk            |  6 ++--
 5 files changed, 68 insertions(+), 7 deletions(-)
 create mode 100644 package/gupnp-tools/0001-common-Drop-deprecated-xmlRecoverMemory.patch
 create mode 100644 package/gupnp-tools/0002-common-Fix-compatibility-with-libxml2-2-12.patch

Comments

Thomas Petazzoni Jan. 1, 2024, 8:19 p.m. UTC | #1
On Fri, 29 Dec 2023 22:49:18 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> - libsoup has been replaced by libsoup3
> - Add patches to fix build with libxml2 2.12
> 
> https://gitlab.gnome.org/GNOME/gupnp-tools/-/blob/gupnp-tools-0.12.1/NEWS
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  ...mon-Drop-deprecated-xmlRecoverMemory.patch | 33 +++++++++++++++++++
>  ...-Fix-compatibility-with-libxml2-2-12.patch | 28 ++++++++++++++++
>  package/gupnp-tools/Config.in                 |  4 +--
>  package/gupnp-tools/gupnp-tools.hash          |  4 +--
>  package/gupnp-tools/gupnp-tools.mk            |  6 ++--
>  5 files changed, 68 insertions(+), 7 deletions(-)
>  create mode 100644 package/gupnp-tools/0001-common-Drop-deprecated-xmlRecoverMemory.patch
>  create mode 100644 package/gupnp-tools/0002-common-Fix-compatibility-with-libxml2-2-12.patch

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/gupnp-tools/0001-common-Drop-deprecated-xmlRecoverMemory.patch b/package/gupnp-tools/0001-common-Drop-deprecated-xmlRecoverMemory.patch
new file mode 100644
index 0000000000..c81d1b01fe
--- /dev/null
+++ b/package/gupnp-tools/0001-common-Drop-deprecated-xmlRecoverMemory.patch
@@ -0,0 +1,33 @@ 
+From f675ac7e0afe67a86f3f1191d3274d6ffbd4e5d7 Mon Sep 17 00:00:00 2001
+From: Jens Georg <mail@jensge.org>
+Date: Thu, 3 Aug 2023 23:44:15 +0200
+Subject: [PATCH] common: Drop deprecated xmlRecoverMemory
+
+Fixes #27
+
+Upstream: https://gitlab.gnome.org/GNOME/gupnp-tools/-/commit/f675ac7e0afe67a86f3f1191d3274d6ffbd4e5d7
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ src/common/pretty-print.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/src/common/pretty-print.c b/src/common/pretty-print.c
+index c692664..c8ebc9a 100644
+--- a/src/common/pretty-print.c
++++ b/src/common/pretty-print.c
+@@ -34,7 +34,11 @@ pretty_print_xml (const char *xml)
+         char *text;
+         int length;
+ 
+-        doc = xmlRecoverMemory (xml, strlen (xml));
++        doc = xmlReadMemory (xml,
++                             strlen (xml),
++                             NULL,
++                             NULL,
++                             XML_PARSE_NONET | XML_PARSE_RECOVER);
+ 
+         if (!doc)
+                 return NULL;
+-- 
+GitLab
+
diff --git a/package/gupnp-tools/0002-common-Fix-compatibility-with-libxml2-2-12.patch b/package/gupnp-tools/0002-common-Fix-compatibility-with-libxml2-2-12.patch
new file mode 100644
index 0000000000..c76d440b5d
--- /dev/null
+++ b/package/gupnp-tools/0002-common-Fix-compatibility-with-libxml2-2-12.patch
@@ -0,0 +1,28 @@ 
+From 4e06104df81fba2cda06d4747b33e75f4cade458 Mon Sep 17 00:00:00 2001
+From: Jens Georg <mail@jensge.org>
+Date: Fri, 24 Nov 2023 18:12:50 +0100
+Subject: [PATCH] common: Fix compatibility with libxml2 2.12
+
+Fixes #28
+
+Upstream: https://gitlab.gnome.org/GNOME/gupnp-tools/-/commit/4e06104df81fba2cda06d4747b33e75f4cade458
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ src/common/pretty-print.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/common/pretty-print.c b/src/common/pretty-print.c
+index c8ebc9a..1519cb0 100644
+--- a/src/common/pretty-print.c
++++ b/src/common/pretty-print.c
+@@ -22,6 +22,7 @@
+ 
+ #include "pretty-print.h"
+ 
++#include <libxml/globals.h>
+ #include <libxml/xmlreader.h>
+ 
+ #include <string.h>
+-- 
+GitLab
+
diff --git a/package/gupnp-tools/Config.in b/package/gupnp-tools/Config.in
index af662417c2..5bce5cabeb 100644
--- a/package/gupnp-tools/Config.in
+++ b/package/gupnp-tools/Config.in
@@ -1,13 +1,13 @@ 
 config BR2_PACKAGE_GUPNP_TOOLS
 	bool "gupnp-tools"
 	depends on BR2_PACKAGE_LIBGTK3
-	# gssdp, gupnp, libsoup all select on libglib2, so they have
+	# gssdp, gupnp, libsoup3 all select on libglib2, so they have
 	# the same dependencies as libgtk3, which we depend on. So for
 	# the same of simplicity, we don't replicate all those
 	# (complex) dependencies.
 	select BR2_PACKAGE_GSSDP
 	select BR2_PACKAGE_GUPNP
-	select BR2_PACKAGE_LIBSOUP
+	select BR2_PACKAGE_LIBSOUP3
 	select BR2_PACKAGE_LIBXML2
 	help
 	  GUPnP Tools are free replacements of Intel UPnP tools that
diff --git a/package/gupnp-tools/gupnp-tools.hash b/package/gupnp-tools/gupnp-tools.hash
index c3808de6e2..28e2661360 100644
--- a/package/gupnp-tools/gupnp-tools.hash
+++ b/package/gupnp-tools/gupnp-tools.hash
@@ -1,5 +1,5 @@ 
-# Hash from: https://download.gnome.org/sources/gupnp-tools/0.10/gupnp-tools-0.10.3.sha256sum:
-sha256  457f4d923935b078415cd2ba88d78db60079b725926b7ee106e4565efe3204de  gupnp-tools-0.10.3.tar.xz
+# Hash from: https://download.gnome.org/sources/gupnp-tools/0.12/gupnp-tools-0.12.1.sha256sum:
+sha256  53cf93123f397e8f8f0b8e9e4364c86a7502a5334f4c0be2e054a824478bd5ba  gupnp-tools-0.12.1.tar.xz
 
 # Locally computed:
 sha256  ab15fd526bd8dd18a9e77ebc139656bf4d33e97fc7238cd11bf60e2b9b8666c6  COPYING
diff --git a/package/gupnp-tools/gupnp-tools.mk b/package/gupnp-tools/gupnp-tools.mk
index f87e98ef03..99fdf54f13 100644
--- a/package/gupnp-tools/gupnp-tools.mk
+++ b/package/gupnp-tools/gupnp-tools.mk
@@ -4,8 +4,8 @@ 
 #
 ################################################################################
 
-GUPNP_TOOLS_VERSION_MAJOR = 0.10
-GUPNP_TOOLS_VERSION = $(GUPNP_TOOLS_VERSION_MAJOR).3
+GUPNP_TOOLS_VERSION_MAJOR = 0.12
+GUPNP_TOOLS_VERSION = $(GUPNP_TOOLS_VERSION_MAJOR).1
 GUPNP_TOOLS_SOURCE = gupnp-tools-$(GUPNP_TOOLS_VERSION).tar.xz
 GUPNP_TOOLS_SITE = \
 	https://download.gnome.org/sources/gupnp-tools/$(GUPNP_TOOLS_VERSION_MAJOR)
@@ -18,7 +18,7 @@  GUPNP_TOOLS_DEPENDENCIES = \
 	libxml2 \
 	gssdp \
 	gupnp \
-	libsoup \
+	libsoup3 \
 	libgtk3 \
 	$(TARGET_NLS_DEPENDENCIES)