diff mbox series

[v2,1/1] package/libostree: switch to libsoup3

Message ID 20231227225940.1683593-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [v2,1/1] package/libostree: switch to libsoup3 | expand

Commit Message

Fabrice Fontaine Dec. 27, 2023, 10:59 p.m. UTC
libsoup3 is supported since bump to version 2023.3 in commit
618eb375a046cc4ff007758510c883788e6ff690 and
https://github.com/ostreedev/ostree/commit/d0ea2db4300eb7871b59d0b997a7f06869120297

So switch to libsoup3 and drop libsoup2 as:
 - libsoup2 is unmaintained (as stated by commit
   b45c2a048d02a0e30da8534b5c048d048b252452)
 - libsoup2 will be removed at some point (as stated by commit
   f93380ab1a36bdd019cfbc651a9df5904096e189)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Changes v1 -> v2 (after review of Yann E. Morin):
 - Update commit message and explain why libsoup2 is dropped

 package/libostree/libostree.mk | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Thomas Petazzoni Dec. 30, 2023, 6:01 p.m. UTC | #1
On Wed, 27 Dec 2023 23:59:39 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> libsoup3 is supported since bump to version 2023.3 in commit
> 618eb375a046cc4ff007758510c883788e6ff690 and
> https://github.com/ostreedev/ostree/commit/d0ea2db4300eb7871b59d0b997a7f06869120297
> 
> So switch to libsoup3 and drop libsoup2 as:
>  - libsoup2 is unmaintained (as stated by commit
>    b45c2a048d02a0e30da8534b5c048d048b252452)
>  - libsoup2 will be removed at some point (as stated by commit
>    f93380ab1a36bdd019cfbc651a9df5904096e189)
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
> Changes v1 -> v2 (after review of Yann E. Morin):
>  - Update commit message and explain why libsoup2 is dropped

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
index d13f484041..a737dc047f 100644
--- a/package/libostree/libostree.mk
+++ b/package/libostree/libostree.mk
@@ -17,6 +17,7 @@  LIBOSTREE_CONF_ENV = \
 	GPG_ERROR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
 LIBOSTREE_CONF_OPTS += \
 	--with-gpgme-prefix=$(STAGING_DIR)/usr \
+	--without-soup \
 	--disable-gtk-doc \
 	--disable-gtk-doc-html \
 	--disable-gtk-doc-pdf \
@@ -44,10 +45,10 @@  else
 LIBOSTREE_CONF_OPTS += --without-avahi
 endif
 
-#cURL support depends on libsoup
-ifeq ($(BR2_PACKAGE_LIBSOUP),y)
-LIBOSTREE_CONF_OPTS += --with-soup
-LIBOSTREE_DEPENDENCIES += libsoup
+# cURL support depends on libsoup3
+ifeq ($(BR2_PACKAGE_LIBSOUP3),y)
+LIBOSTREE_CONF_OPTS += --with-soup3
+LIBOSTREE_DEPENDENCIES += libsoup3
 ifeq ($(BR2_PACKAGE_LIBCURL),y)
 LIBOSTREE_CONF_OPTS += --with-curl
 LIBOSTREE_DEPENDENCIES += libcurl
@@ -55,7 +56,7 @@  else
 LIBOSTREE_CONF_OPTS += --without-curl
 endif
 else
-LIBOSTREE_CONF_OPTS += --without-soup --without-curl
+LIBOSTREE_CONF_OPTS += --without-soup3 --without-curl
 endif
 
 ifeq ($(BR2_PACKAGE_LIBARCHIVE),y)