diff mbox series

[2/2] package/exim: do not build perl-based utilities

Message ID 20231227181756.156827-2-bernd@kuhls.net
State Changes Requested
Headers show
Series [1/2] package/exim: fix build with libexecinfo | expand

Commit Message

Bernd Kuhls Dec. 27, 2023, 6:17 p.m. UTC
Upstream added various utilities, for example exim_id_update
with commit https://github.com/Exim/exim/commit/46a36afae41f63de654269c8a0b7cf5852a85a14
which is a "Utility for one-time upgrage/downgrade between exim message-
id formats, around the 4.97 transition" which would add a dependency to
host-perl/perl so we build only the exim binary.

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
 package/exim/exim.mk | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

Comments

Luca Ceresoli Dec. 28, 2023, 9:02 a.m. UTC | #1
Hello Bernd,

[+Cc Yann]

On Wed, 27 Dec 2023 19:17:56 +0100
Bernd Kuhls <bernd@kuhls.net> wrote:

> Upstream added various utilities, for example exim_id_update
> with commit https://github.com/Exim/exim/commit/46a36afae41f63de654269c8a0b7cf5852a85a14
> which is a "Utility for one-time upgrage/downgrade between exim message-
> id formats, around the 4.97 transition" which would add a dependency to
> host-perl/perl so we build only the exim binary.
> 
> Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
> ---
>  package/exim/exim.mk | 9 ++++-----
>  1 file changed, 4 insertions(+), 5 deletions(-)
> 
> diff --git a/package/exim/exim.mk b/package/exim/exim.mk
> index 30b0d78c94..1b3295697e 100644
> --- a/package/exim/exim.mk
> +++ b/package/exim/exim.mk
> @@ -146,16 +146,15 @@ define EXIM_BUILD_CMDS
>  		CFLAGS="-std=c99 $(HOST_CFLAGS)" \
>  		LFLAGS="-fPIC $(HOST_LDFLAGS)"
>  	$(TARGET_MAKE_ENV) build=br $(MAKE) -C $(@D) $(EXIM_STATIC_FLAGS) \
> -		CFLAGS="-std=c99 $(TARGET_CFLAGS) $(EXIM_C_FLAGS)"
> +		CFLAGS="-std=c99 $(TARGET_CFLAGS) $(EXIM_C_FLAGS)" exim
>  endef
>  
>  # Need to replicate the LFLAGS in install, as exim still wants to build
>  # something when installing...
>  define EXIM_INSTALL_TARGET_CMDS
> -	DESTDIR=$(TARGET_DIR) INSTALL_ARG="-no_chown -no_symlink" build=br \
> -	  $(MAKE) -C $(@D) $(EXIM_STATIC_FLAGS) \
> -		CFLAGS="-std=c99 $(TARGET_CFLAGS)" \
> -		install
> +	cd $(@D)/build-br; \
> +	DESTDIR=$(TARGET_DIR) build=br \
> +	../scripts/exim_install -no_chown -no_symlink exim
>  	chmod u+s $(TARGET_DIR)/usr/sbin/exim
>  endef

I like this complete rewrite of the install commands, which get rid of
the utterly complex installation step currently in place. However I'd
have mentioned this in the commit log, including a mention of the
checks done to ensure this is still installing whatever is
actually needed.

Also, the comment about the LFLAGS, added by Yann in [0], should be
removed as it it does not apply anymore.

[0]
https://git.busybox.net/buildroot/commit/?id=bf22cea53fa2af48bde3010673d3babee1ae6873

Luca
diff mbox series

Patch

diff --git a/package/exim/exim.mk b/package/exim/exim.mk
index 30b0d78c94..1b3295697e 100644
--- a/package/exim/exim.mk
+++ b/package/exim/exim.mk
@@ -146,16 +146,15 @@  define EXIM_BUILD_CMDS
 		CFLAGS="-std=c99 $(HOST_CFLAGS)" \
 		LFLAGS="-fPIC $(HOST_LDFLAGS)"
 	$(TARGET_MAKE_ENV) build=br $(MAKE) -C $(@D) $(EXIM_STATIC_FLAGS) \
-		CFLAGS="-std=c99 $(TARGET_CFLAGS) $(EXIM_C_FLAGS)"
+		CFLAGS="-std=c99 $(TARGET_CFLAGS) $(EXIM_C_FLAGS)" exim
 endef
 
 # Need to replicate the LFLAGS in install, as exim still wants to build
 # something when installing...
 define EXIM_INSTALL_TARGET_CMDS
-	DESTDIR=$(TARGET_DIR) INSTALL_ARG="-no_chown -no_symlink" build=br \
-	  $(MAKE) -C $(@D) $(EXIM_STATIC_FLAGS) \
-		CFLAGS="-std=c99 $(TARGET_CFLAGS)" \
-		install
+	cd $(@D)/build-br; \
+	DESTDIR=$(TARGET_DIR) build=br \
+	../scripts/exim_install -no_chown -no_symlink exim
 	chmod u+s $(TARGET_DIR)/usr/sbin/exim
 endef