diff mbox series

[1/1] package/libostree: switch to libsoup3

Message ID 20231227105607.1010960-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/libostree: switch to libsoup3 | expand

Commit Message

Fabrice Fontaine Dec. 27, 2023, 10:56 a.m. UTC
libsoup3 is supported since bump to version 2023.3 in commit
618eb375a046cc4ff007758510c883788e6ff690 and
https://github.com/ostreedev/ostree/commit/d0ea2db4300eb7871b59d0b997a7f06869120297

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libostree/libostree.mk | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

Comments

Yann E. MORIN Dec. 27, 2023, 10:01 p.m. UTC | #1
Fabrice, All,

On 2023-12-27 11:56 +0100, Fabrice Fontaine spake thusly:
> libsoup3 is supported since bump to version 2023.3 in commit
> 618eb375a046cc4ff007758510c883788e6ff690 and
> https://github.com/ostreedev/ostree/commit/d0ea2db4300eb7871b59d0b997a7f06869120297
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/libostree/libostree.mk | 11 ++++++-----
>  1 file changed, 6 insertions(+), 5 deletions(-)
> 
> diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
> index d13f484041..a737dc047f 100644
> --- a/package/libostree/libostree.mk
> +++ b/package/libostree/libostree.mk
> @@ -17,6 +17,7 @@ LIBOSTREE_CONF_ENV = \
>  	GPG_ERROR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
>  LIBOSTREE_CONF_OPTS += \
>  	--with-gpgme-prefix=$(STAGING_DIR)/usr \
> +	--without-soup \

AFAICS, upstream still supports libsoup2, and the commit you reference
even mentions it is still the default. But seeing the code in that
commit, if both are enabled, libsoup3 is still the preferred option.

However, what your patch does, is to really switch over to libsoup3, and
no longer use libsoup2 as a falback at all.

That's fine, but that should be explained and motivated in the commit
log.

CCan you expand on that and respin, pleasE?

Regards,
Yann E. MORIN.

>  	--disable-gtk-doc \
>  	--disable-gtk-doc-html \
>  	--disable-gtk-doc-pdf \
> @@ -44,10 +45,10 @@ else
>  LIBOSTREE_CONF_OPTS += --without-avahi
>  endif
>  
> -#cURL support depends on libsoup
> -ifeq ($(BR2_PACKAGE_LIBSOUP),y)
> -LIBOSTREE_CONF_OPTS += --with-soup
> -LIBOSTREE_DEPENDENCIES += libsoup
> +# cURL support depends on libsoup3
> +ifeq ($(BR2_PACKAGE_LIBSOUP3),y)
> +LIBOSTREE_CONF_OPTS += --with-soup3
> +LIBOSTREE_DEPENDENCIES += libsoup3
>  ifeq ($(BR2_PACKAGE_LIBCURL),y)
>  LIBOSTREE_CONF_OPTS += --with-curl
>  LIBOSTREE_DEPENDENCIES += libcurl
> @@ -55,7 +56,7 @@ else
>  LIBOSTREE_CONF_OPTS += --without-curl
>  endif
>  else
> -LIBOSTREE_CONF_OPTS += --without-soup --without-curl
> +LIBOSTREE_CONF_OPTS += --without-soup3 --without-curl
>  endif
>  
>  ifeq ($(BR2_PACKAGE_LIBARCHIVE),y)
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
index d13f484041..a737dc047f 100644
--- a/package/libostree/libostree.mk
+++ b/package/libostree/libostree.mk
@@ -17,6 +17,7 @@  LIBOSTREE_CONF_ENV = \
 	GPG_ERROR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
 LIBOSTREE_CONF_OPTS += \
 	--with-gpgme-prefix=$(STAGING_DIR)/usr \
+	--without-soup \
 	--disable-gtk-doc \
 	--disable-gtk-doc-html \
 	--disable-gtk-doc-pdf \
@@ -44,10 +45,10 @@  else
 LIBOSTREE_CONF_OPTS += --without-avahi
 endif
 
-#cURL support depends on libsoup
-ifeq ($(BR2_PACKAGE_LIBSOUP),y)
-LIBOSTREE_CONF_OPTS += --with-soup
-LIBOSTREE_DEPENDENCIES += libsoup
+# cURL support depends on libsoup3
+ifeq ($(BR2_PACKAGE_LIBSOUP3),y)
+LIBOSTREE_CONF_OPTS += --with-soup3
+LIBOSTREE_DEPENDENCIES += libsoup3
 ifeq ($(BR2_PACKAGE_LIBCURL),y)
 LIBOSTREE_CONF_OPTS += --with-curl
 LIBOSTREE_DEPENDENCIES += libcurl
@@ -55,7 +56,7 @@  else
 LIBOSTREE_CONF_OPTS += --without-curl
 endif
 else
-LIBOSTREE_CONF_OPTS += --without-soup --without-curl
+LIBOSTREE_CONF_OPTS += --without-soup3 --without-curl
 endif
 
 ifeq ($(BR2_PACKAGE_LIBARCHIVE),y)