diff mbox series

[v2] package/swugenerator: add missing runtime dependencies

Message ID 20231226214037.144870-1-giulio.benetti@benettiengineering.com
State Superseded
Headers show
Series [v2] package/swugenerator: add missing runtime dependencies | expand

Commit Message

Giulio Benetti Dec. 26, 2023, 9:40 p.m. UTC
From: Giulio Benetti <giulio.benetti+tekvox@benettiengineering.com>

At the moment swugenerator package lacks host-openssl, host-gzip and
host-zstd runtime dependency so let's add them to prevent swugenerator from
failing to run.

Signed-off-by: Giulio Benetti <giulio.benetti+tekvox@benettiengineering.com>
---
V1->V2:
* add host-zstd and clarify in commit log these are runtime dependencies as
  pointed by Thomas Petazzoni
---
 package/swugenerator/swugenerator.mk | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Jan. 5, 2024, 1:06 p.m. UTC | #1
Hello Giulio,

Thanks for the v2!

On Tue, 26 Dec 2023 22:40:37 +0100
Giulio Benetti <giulio.benetti@benettiengineering.com> wrote:

> From: Giulio Benetti <giulio.benetti+tekvox@benettiengineering.com>
> 
> At the moment swugenerator package lacks host-openssl, host-gzip and
> host-zstd runtime dependency so let's add them to prevent swugenerator from
> failing to run.

I'm going to nitpick a bit (yes, I admit), but this commit log explains
what the commit does, not why it does it. The *why* is important. The
problem is not that swugenerator lacks host-openssl, host-gzip and
host-zstd.

The problem is that swugenerator can (apparently) use openssl, gzip and
zstd on the host (under which conditions?), and therefore we should add
host-openssl, host-gzip and host-zstd as runtime dependencies.

Thomas
Giulio Benetti Jan. 5, 2024, 1:22 p.m. UTC | #2
Hello Thomas,

> Il giorno 5 gen 2024, alle ore 14:07, Thomas Petazzoni <thomas.petazzoni@bootlin.com> ha scritto:
> 
> Hello Giulio,
> 
> Thanks for the v2!
> 
>> On Tue, 26 Dec 2023 22:40:37 +0100
>> Giulio Benetti <giulio.benetti@benettiengineering.com> wrote:
>> 
>> From: Giulio Benetti <giulio.benetti+tekvox@benettiengineering.com>
>> 
>> At the moment swugenerator package lacks host-openssl, host-gzip and
>> host-zstd runtime dependency so let's add them to prevent swugenerator from
>> failing to run.
> 
> I'm going to nitpick a bit (yes, I admit), but this commit log explains
> what the commit does, not why it does it. The *why* is important. The
> problem is not that swugenerator lacks host-openssl, host-gzip and
> host-zstd.

Absolutely,

> 
> The problem is that swugenerator can (apparently) use openssl, gzip and
> zstd on the host (under which conditions?), and therefore we should add
> host-openssl, host-gzip and host-zstd as runtime dependencies.

Yes. To tell the truth I don’t even remember why I have sent V2 since I still have to answer to previous email, including the runtime test to check for host dependencies.

So thank you for pointing how to improve commit log, I will take care of all.

Best regards
Giulio

> 
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering and training
> https://bootlin.com
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
Thomas Petazzoni Jan. 5, 2024, 1:25 p.m. UTC | #3
Hello Giulio,

On Fri, 5 Jan 2024 14:22:15 +0100
Giulio Benetti <giulio.benetti@benettiengineering.com> wrote:

> Yes. To tell the truth I don’t even remember why I have sent V2 since
> I still have to answer to previous email, including the runtime test
> to check for host dependencies.

A runtime test would obviously be good, but I clearly to make that a
requirement to merge this patch. Only to have a slightly better commit
log that explains how/why openssl/gzip/zstd are used by swugenerator.

Thomas
diff mbox series

Patch

diff --git a/package/swugenerator/swugenerator.mk b/package/swugenerator/swugenerator.mk
index f4ead1d229..466fe1f046 100644
--- a/package/swugenerator/swugenerator.mk
+++ b/package/swugenerator/swugenerator.mk
@@ -9,6 +9,10 @@  SWUGENERATOR_SITE = $(call github,sbabic,swugenerator,v$(SWUGENERATOR_VERSION))
 SWUGENERATOR_LICENSE = GPL-3.0
 SWUGENERATOR_LICENSE_FILES = LICENSE
 HOST_SWUGENERATOR_SETUP_TYPE = setuptools
-HOST_SWUGENERATOR_DEPENDENCIES = host-python-libconf
+HOST_SWUGENERATOR_DEPENDENCIES = \
+	host-gzip \
+	host-openssl \
+	host-python-libconf \
+	host-zstd
 
 $(eval $(host-python-package))