diff mbox series

[1/1] boot/grub2: needs host-gawk

Message ID 20231223203032.1598109-1-ju.o@free.fr
State Accepted
Headers show
Series [1/1] boot/grub2: needs host-gawk | expand

Commit Message

Julien Olivain Dec. 23, 2023, 8:30 p.m. UTC
grub2 build is failing, when compiled on host system not including
gawk and host-gawk is not built by another package before. This can
be the the case on current Buildroot Docker image, based on Debian,
which includes mawk.

grub2 was updated in commit 5baf1ffe7e "boot/grub2: bump to version
2.12". This version includes the commit [1], which introduced the use
of the asorti() awk function. This function is a specific gawk
builtin extension. See [2].

This commit fixes this issue by adding host-gawk as a dependency.

Fixes:

    mawk: ../../grub-core/genmoddep.awk: line 110: function asorti never defined
    make[4]: *** [Makefile:49030: moddep.lst] Error 1
    make[4]: Leaving directory '/buildroot/output/build/grub2-2.12/build-i386-pc/grub-core'
    make[3]: *** [Makefile:28116: all] Error 2
    make[3]: Leaving directory '/buildroot/output/build/grub2-2.12/build-i386-pc/grub-core'
    make[2]: *** [Makefile:11714: all-recursive] Error 1
    make[2]: Leaving directory '/buildroot/output/build/grub2-2.12/build-i386-pc'
    make[1]: *** [Makefile:3547: all] Error 2
    make[1]: Leaving directory '/buildroot/output/build/grub2-2.12/build-i386-pc'
    make: *** [package/pkg-generic.mk:283: /buildroot/output/build/grub2-2.12/.stamp_built] Error 2

[1] https://git.savannah.gnu.org/gitweb/?p=grub.git;a=commitdiff;h=87648e9c12a32bddb005b899edc44c2c9c63df82
[2] https://www.gnu.org/software/gawk/manual/gawk.html#Sorting-Array-Values-and-Indices-with-gawk

Signed-off-by: Julien Olivain <ju.o@free.fr>
---
 boot/grub2/grub2.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Yann E. MORIN Dec. 24, 2023, 10:25 a.m. UTC | #1
Julien, All,

On 2023-12-23 21:30 +0100, Julien Olivain spake thusly:
> grub2 build is failing, when compiled on host system not including
> gawk and host-gawk is not built by another package before. This can
> be the the case on current Buildroot Docker image, based on Debian,
> which includes mawk.
> 
> grub2 was updated in commit 5baf1ffe7e "boot/grub2: bump to version
> 2.12". This version includes the commit [1], which introduced the use
> of the asorti() awk function. This function is a specific gawk
> builtin extension. See [2].
> 
> This commit fixes this issue by adding host-gawk as a dependency.
> 
> Fixes:
> 
>     mawk: ../../grub-core/genmoddep.awk: line 110: function asorti never defined
>     make[4]: *** [Makefile:49030: moddep.lst] Error 1
>     make[4]: Leaving directory '/buildroot/output/build/grub2-2.12/build-i386-pc/grub-core'
>     make[3]: *** [Makefile:28116: all] Error 2
>     make[3]: Leaving directory '/buildroot/output/build/grub2-2.12/build-i386-pc/grub-core'
>     make[2]: *** [Makefile:11714: all-recursive] Error 1
>     make[2]: Leaving directory '/buildroot/output/build/grub2-2.12/build-i386-pc'
>     make[1]: *** [Makefile:3547: all] Error 2
>     make[1]: Leaving directory '/buildroot/output/build/grub2-2.12/build-i386-pc'
>     make: *** [package/pkg-generic.mk:283: /buildroot/output/build/grub2-2.12/.stamp_built] Error 2
> 
> [1] https://git.savannah.gnu.org/gitweb/?p=grub.git;a=commitdiff;h=87648e9c12a32bddb005b899edc44c2c9c63df82
> [2] https://www.gnu.org/software/gawk/manual/gawk.html#Sorting-Array-Values-and-Indices-with-gawk
> 
> Signed-off-by: Julien Olivain <ju.o@free.fr>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  boot/grub2/grub2.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/boot/grub2/grub2.mk b/boot/grub2/grub2.mk
> index b9be826885..4430aebd59 100644
> --- a/boot/grub2/grub2.mk
> +++ b/boot/grub2/grub2.mk
> @@ -9,8 +9,8 @@ GRUB2_SITE = http://ftp.gnu.org/gnu/grub
>  GRUB2_SOURCE = grub-$(GRUB2_VERSION).tar.xz
>  GRUB2_LICENSE = GPL-3.0+
>  GRUB2_LICENSE_FILES = COPYING
> -GRUB2_DEPENDENCIES = host-bison host-flex host-grub2
> -HOST_GRUB2_DEPENDENCIES = host-bison host-flex
> +GRUB2_DEPENDENCIES = host-bison host-flex host-gawk host-grub2
> +HOST_GRUB2_DEPENDENCIES = host-bison host-flex host-gawk
>  GRUB2_INSTALL_IMAGES = YES
>  
>  # CVE-2019-14865 is about a flaw in the grub2-set-bootflag tool, which
> -- 
> 2.43.0
> 
> _______________________________________________
> buildroot mailing list
> buildroot@buildroot.org
> https://lists.buildroot.org/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/boot/grub2/grub2.mk b/boot/grub2/grub2.mk
index b9be826885..4430aebd59 100644
--- a/boot/grub2/grub2.mk
+++ b/boot/grub2/grub2.mk
@@ -9,8 +9,8 @@  GRUB2_SITE = http://ftp.gnu.org/gnu/grub
 GRUB2_SOURCE = grub-$(GRUB2_VERSION).tar.xz
 GRUB2_LICENSE = GPL-3.0+
 GRUB2_LICENSE_FILES = COPYING
-GRUB2_DEPENDENCIES = host-bison host-flex host-grub2
-HOST_GRUB2_DEPENDENCIES = host-bison host-flex
+GRUB2_DEPENDENCIES = host-bison host-flex host-gawk host-grub2
+HOST_GRUB2_DEPENDENCIES = host-bison host-flex host-gawk
 GRUB2_INSTALL_IMAGES = YES
 
 # CVE-2019-14865 is about a flaw in the grub2-set-bootflag tool, which