diff mbox series

package/xwayland: libdrm is required, not optional

Message ID 20231211164530.1914335-1-peter@korsgaard.com
State Accepted
Headers show
Series package/xwayland: libdrm is required, not optional | expand

Commit Message

Peter Korsgaard Dec. 11, 2023, 4:45 p.m. UTC
Fixes:
http://autobuild.buildroot.net/results/476/47665d417dbae76bf27e805a5bcb1d8d6ab1f445/

xwayland unconditionally includes xf86drm.h, so libdrm is required and not
optional:

grep -rs xf86drm.h
glamor/glamor_egl.c:#include <xf86drm.h>
hw/xwayland/xwayland-glamor.h:#include <xf86drm.h>
hw/xwayland/xwayland-glamor-eglstream.c:#include <xf86drm.h>
hw/xwayland/xwayland-window.h:#include <xf86drm.h>
hw/xwayland/xwayland-drm-lease.c:#include <xf86drm.h>
hw/xwayland/xwayland-glamor-gbm.c:#include <xf86drm.h>

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/x11r7/xwayland/Config.in   |  1 +
 package/x11r7/xwayland/xwayland.mk | 13 ++++---------
 2 files changed, 5 insertions(+), 9 deletions(-)

Comments

Peter Korsgaard Dec. 12, 2023, 9:56 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Fixes:
 > http://autobuild.buildroot.net/results/476/47665d417dbae76bf27e805a5bcb1d8d6ab1f445/

 > xwayland unconditionally includes xf86drm.h, so libdrm is required and not
 > optional:

 > grep -rs xf86drm.h
 > glamor/glamor_egl.c:#include <xf86drm.h>
 > hw/xwayland/xwayland-glamor.h:#include <xf86drm.h>
 > hw/xwayland/xwayland-glamor-eglstream.c:#include <xf86drm.h>
 > hw/xwayland/xwayland-window.h:#include <xf86drm.h>
 > hw/xwayland/xwayland-drm-lease.c:#include <xf86drm.h>
 > hw/xwayland/xwayland-glamor-gbm.c:#include <xf86drm.h>

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
Peter Korsgaard Jan. 5, 2024, 10:52 a.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Fixes:
 > http://autobuild.buildroot.net/results/476/47665d417dbae76bf27e805a5bcb1d8d6ab1f445/

 > xwayland unconditionally includes xf86drm.h, so libdrm is required and not
 > optional:

 > grep -rs xf86drm.h
 > glamor/glamor_egl.c:#include <xf86drm.h>
 > hw/xwayland/xwayland-glamor.h:#include <xf86drm.h>
 > hw/xwayland/xwayland-glamor-eglstream.c:#include <xf86drm.h>
 > hw/xwayland/xwayland-window.h:#include <xf86drm.h>
 > hw/xwayland/xwayland-drm-lease.c:#include <xf86drm.h>
 > hw/xwayland/xwayland-glamor-gbm.c:#include <xf86drm.h>

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2023.02.x and 2023.11.x, thanks.
diff mbox series

Patch

diff --git a/package/x11r7/xwayland/Config.in b/package/x11r7/xwayland/Config.in
index 241ab73ad3..9ac1928f51 100644
--- a/package/x11r7/xwayland/Config.in
+++ b/package/x11r7/xwayland/Config.in
@@ -8,6 +8,7 @@  config BR2_PACKAGE_XWAYLAND
 	# them, otherwise, use the small libsha1 library.
 	depends on !BR2_RISCV_32 # xlib_libxshmfence
 	depends on BR2_TOOLCHAIN_HAS_SYNC_4 # xlib_libxshmfence
+	select BR2_PACKAGE_LIBDRM
 	select BR2_PACKAGE_LIBSHA1 if (!BR2_PACKAGE_OPENSSL && !BR2_PACKAGE_LIBGCRYPT)
 	select BR2_PACKAGE_PIXMAN
 	select BR2_PACKAGE_WAYLAND
diff --git a/package/x11r7/xwayland/xwayland.mk b/package/x11r7/xwayland/xwayland.mk
index 8550b61389..ac24fb94ec 100644
--- a/package/x11r7/xwayland/xwayland.mk
+++ b/package/x11r7/xwayland/xwayland.mk
@@ -12,6 +12,7 @@  XWAYLAND_LICENSE_FILES = COPYING
 XWAYLAND_CPE_ID_VENDOR = x.org
 XWAYLAND_INSTALL_STAGING = YES
 XWAYLAND_DEPENDENCIES = \
+	libdrm \
 	pixman \
 	wayland \
 	wayland-protocols \
@@ -23,15 +24,16 @@  XWAYLAND_DEPENDENCIES = \
 	xlib_xtrans \
 	xorgproto
 XWAYLAND_CONF_OPTS = \
+	-Ddri3=true \
 	-Dxwayland_eglstream=false \
 	-Dxvfb=false \
 	-Ddefault_font_path=/usr/share/fonts/X11/ \
 	-Ddtrace=false \
 	-Ddocs=false
 
-ifeq ($(BR2_PACKAGE_LIBDRM)$(BR2_PACKAGE_LIBEPOXY),yy)
+ifeq ($(BR2_PACKAGE_LIBEPOXY),y)
 XWAYLAND_CONF_OPTS += -Dglamor=true
-XWAYLAND_DEPENDENCIES += libdrm libepoxy
+XWAYLAND_DEPENDENCIES += libepoxy
 else
 XWAYLAND_CONF_OPTS += -Dglamor=false
 endif
@@ -79,13 +81,6 @@  XWAYLAND_CONF_OPTS += -Dsha1=libsha1
 XWAYLAND_DEPENDENCIES += libsha1
 endif
 
-ifeq ($(BR2_PACKAGE_LIBDRM),y)
-XWAYLAND_CONF_OPTS += -Ddri3=true
-XWAYLAND_DEPENDENCIES +=  libdrm
-else
-XWAYLAND_CONF_OPTS += -Ddri3=false
-endif
-
 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
 XWAYLAND_CONF_OPTS += -Dlibunwind=true
 XWAYLAND_DEPENDENCIES += libunwind