diff mbox series

[2/2] package/lua-compat53: install compat-5.3.h

Message ID 20231210152513.1642373-2-francois.perrad@gadz.org
State Accepted
Headers show
Series [1/2] package/lua-compat53: bump to version 0.12 | expand

Commit Message

Francois Perrad Dec. 10, 2023, 3:25 p.m. UTC
this file could be required by some native modules

note: compat-5.3.c is included by compat-5.3.h
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/lua-compat53/lua-compat53.mk | 6 ++++++
 1 file changed, 6 insertions(+)
diff mbox series

Patch

diff --git a/package/lua-compat53/lua-compat53.mk b/package/lua-compat53/lua-compat53.mk
index 0cfbe2d795..07bc4aab10 100644
--- a/package/lua-compat53/lua-compat53.mk
+++ b/package/lua-compat53/lua-compat53.mk
@@ -10,5 +10,11 @@  LUA_COMPAT53_NAME_UPSTREAM = compat53
 LUA_COMPAT53_SUBDIR = lua-compat-5.3-$(LUA_COMPAT53_VERSION_UPSTREAM)
 LUA_COMPAT53_LICENSE = MIT
 LUA_COMPAT53_LICENSE_FILES = $(LUA_COMPAT53_SUBDIR)/LICENSE
+LUA_COMPAT53_INSTALL_STAGING = YES
+
+define LUA_COMPAT53_INSTALL_STAGING_CMDS
+	cp $(@D)/$(LUA_COMPAT53_SUBDIR)/c-api/compat-5.3.c $(STAGING_DIR)/usr/include
+	cp $(@D)/$(LUA_COMPAT53_SUBDIR)/c-api/compat-5.3.h $(STAGING_DIR)/usr/include
+endef
 
 $(eval $(luarocks-package))