diff mbox series

[v2,1/2] package/xuantie-bins: new package

Message ID 20231204231212.36450-2-kilian.zinnecker@mail.de
State Changes Requested
Headers show
Series Add board support for the BeagleV-Ahead | expand

Commit Message

Frager, Neal via buildroot Dec. 4, 2023, 11:12 p.m. UTC
From: Kilian Zinnecker <kilian.zinnecker@mail.de>

This patch adds a package for Xuantie binary blobs. These binaries
are needed for the BeagleV-Ahead.

Signed-off-by: Kilian Zinnecker <kilian.zinnecker@mail.de>
---
 DEVELOPERS                             |  5 +++--
 package/Config.in                      |  1 +
 package/xuantie-bins/Config.in         |  6 ++++++
 package/xuantie-bins/xuantie-bins.hash |  1 +
 package/xuantie-bins/xuantie-bins.mk   | 27 ++++++++++++++++++++++++++
 5 files changed, 38 insertions(+), 2 deletions(-)
 create mode 100644 package/xuantie-bins/Config.in
 create mode 100644 package/xuantie-bins/xuantie-bins.hash
 create mode 100644 package/xuantie-bins/xuantie-bins.mk

Comments

Giulio Benetti Feb. 6, 2024, 4:56 p.m. UTC | #1
Hi Yegor, Kilian,

On 05/12/23 00:12, yegorslists--- via buildroot wrote:
> From: Kilian Zinnecker <kilian.zinnecker@mail.de>
> 
> This patch adds a package for Xuantie binary blobs. These binaries
> are needed for the BeagleV-Ahead.
> 
> Signed-off-by: Kilian Zinnecker <kilian.zinnecker@mail.de>
> ---
>   DEVELOPERS                             |  5 +++--
>   package/Config.in                      |  1 +
>   package/xuantie-bins/Config.in         |  6 ++++++
>   package/xuantie-bins/xuantie-bins.hash |  1 +
>   package/xuantie-bins/xuantie-bins.mk   | 27 ++++++++++++++++++++++++++
>   5 files changed, 38 insertions(+), 2 deletions(-)
>   create mode 100644 package/xuantie-bins/Config.in
>   create mode 100644 package/xuantie-bins/xuantie-bins.hash
>   create mode 100644 package/xuantie-bins/xuantie-bins.mk
> 
> diff --git a/DEVELOPERS b/DEVELOPERS
> index f504ca8d36..4d18bc49d4 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -1839,9 +1839,10 @@ N:	Kieran Bingham <kieran.bingham@ideasonboard.com>
>   F:	package/libcamera/
>   
>   N:	Kilian Zinnecker <kilian.zinnecker@mail.de>
> -F:	package/rockchip-rkbin/
> -F:	configs/rock5b_defconfig
>   F:	board/radxa/rock5b/
> +F:	configs/rock5b_defconfig

can you please provide a separate patch to alphabetize?

> +F:	package/rockchip-rkbin/
> +F:	package/xuantie-bins/
>   
>   N:	Klaus Heinrich Kiwi <klaus@linux.vnet.ibm.com>
>   F:	package/wqy-zenhei/
> diff --git a/package/Config.in b/package/Config.in
> index fcc09b07c4..3772e2ac81 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -653,6 +653,7 @@ endmenu
>   	source "package/wipe/Config.in"
>   	source "package/xorriso/Config.in"
>   	source "package/xr819-xradio/Config.in"
> +	source "package/xuantie-bins/Config.in"
>   endmenu
>   
>   menu "Interpreter languages and scripting"
> diff --git a/package/xuantie-bins/Config.in b/package/xuantie-bins/Config.in
> new file mode 100644
> index 0000000000..a04497ce6b
> --- /dev/null
> +++ b/package/xuantie-bins/Config.in
> @@ -0,0 +1,6 @@
> +config BR2_PACKAGE_XUANTIE_BINS
> +	bool "xuantie-bins"
> +	depends on BR2_riscv
> +	help
> +	  This package provides binary blobs, needed for the
> +	  BeagleV-Ahead's SoC (TH1520).

Can you please describe a bit what those binaries are meant for?

> diff --git a/package/xuantie-bins/xuantie-bins.hash b/package/xuantie-bins/xuantie-bins.hash
> new file mode 100644
> index 0000000000..4d1ec297c9
> --- /dev/null
> +++ b/package/xuantie-bins/xuantie-bins.hash
> @@ -0,0 +1 @@
> +sha256  608e9fec79823996004f65ba692a76d741307b0de23552d147ad1b567e7054dc  xuantie-bins-0a2e02bb53758cc12448d8670e65c854528a96b4-br1.tar.gz
> diff --git a/package/xuantie-bins/xuantie-bins.mk b/package/xuantie-bins/xuantie-bins.mk
> new file mode 100644
> index 0000000000..3a5611cf36
> --- /dev/null
> +++ b/package/xuantie-bins/xuantie-bins.mk
> @@ -0,0 +1,27 @@
> +################################################################################
> +#
> +# xuantie-bins
> +#
> +################################################################################
> +
> +XUANTIE_BINS_VERSION = 0a2e02bb53758cc12448d8670e65c854528a96b4
> +XUANTIE_BINS_SITE = https://github.com/beagleboard/xuantie-ubuntu.git
> +XUANTIE_BINS_SITE_METHOD = git
> +XUANTIE_BINS_LICENSE = PROPRIETARY
> +
> +XUANTIE_BINS_INSTALL_IMAGES = YES
> +XUANTIE_BINS_INSTALL_TARGET = NO
> +
> +XUANTIE_BINS_FPGA_BIN_FILENAME = "bins/light_aon_fpga.bin"
> +XUANTIE_BINS_AUDIO_BIN_FILENAME = "bins/light_c906_audio.bin"
> +
> +define XUANTIE_BINS_INSTALL_IMAGES_CMDS
> +	$(foreach f, \
> +		$(XUANTIE_BINS_FPGA_BIN_FILENAME) \
> +		$(XUANTIE_BINS_AUDIO_BIN_FILENAME) \
> +		, \
> +		$(INSTALL) -D -m 0644 -t $(BINARIES_DIR) $(@D)/$(f)
> +	)
> +endef

Being only 2 files to be installed I'd prefer to see 2 lines instead of
foreach loop. Can you please change it accordingly?

Thank you
Best regards
Frager, Neal via buildroot Feb. 10, 2024, 3:22 p.m. UTC | #2
Hello Giulio, all,

> Hi Yegor, Kilian,

This is strange, maybe someone can have a look here: On ozlabs, there are a 
lot of patches, which have the submitter "kilian.zinnecker--- via buildroot". 
However, most of them are NOT from me. E.g., one from Yegor Yefremov [1] is 
marked with submitter "kilian.zinnecker--- via buildroot" - However, I am 
definitively not Yegor, and none of his patches is from me. There are even more 
patches marked with "kilian.zinnecker--- via buildroot" [2], some of them even 
from before I ever submitted my first patch (the Rock5B board support) to 
buildroot. Does anyone have any idea what this is about, or can have a deeper 
look at this? (The BeagleV-Ahead patches are from me.)

[1] https://patchwork.ozlabs.org/project/buildroot/patch/
20240206132051.2838897-1-yegorslists@googlemail.com/

[2] https://patchwork.ozlabs.org/project/buildroot/list/?
submitter=82609&archive=both&state=*

[--SNIP--]

Thanks for your review Giulio. I will try to address the issues and prepare a 
new version of the patches.

Best regards,
Kilian
Frager, Neal via buildroot Feb. 11, 2024, 12:15 p.m. UTC | #3
Hello Giulio, all,

[--SNIP--]
> can you please provide a separate patch to alphabetize?

I did so: https://gitlab.com/buildroot.org/buildroot/-/commit/
53fad3242d74b9fad11978429d6cc2879f783f4b

However, unfortunately Thomas de-alphabetized it again when he applied my 
RZBoard V2L patches: https://gitlab.com/buildroot.org/buildroot/-/commit/
f003675119c9ca503afa19c04074e81c49538baf

I just send a v3 of the BeagleV-Ahead patches. After we get this series 
applied, I will then again send a single patch to alphabetize.

[--SNIP--]
> > --- /dev/null
> > +++ b/package/xuantie-bins/Config.in
> > @@ -0,0 +1,6 @@
> > +config BR2_PACKAGE_XUANTIE_BINS
> > +	bool "xuantie-bins"
> > +	depends on BR2_riscv
> > +	help
> > +	  This package provides binary blobs, needed for the
> > +	  BeagleV-Ahead's SoC (TH1520).
> 
> Can you please describe a bit what those binaries are meant for?


I gave a brief description, but I don't know much about these. Maybe Robert 
can give even more information, if more is needed?

[--SNIP--]
> > +XUANTIE_BINS_FPGA_BIN_FILENAME = "bins/light_aon_fpga.bin"
> > +XUANTIE_BINS_AUDIO_BIN_FILENAME = "bins/light_c906_audio.bin"
> > +
> > +define XUANTIE_BINS_INSTALL_IMAGES_CMDS
> > +	$(foreach f, \
> > +		$(XUANTIE_BINS_FPGA_BIN_FILENAME) \
> > +		$(XUANTIE_BINS_AUDIO_BIN_FILENAME) \
> > +		, \
> > +		$(INSTALL) -D -m 0644 -t $(BINARIES_DIR) $(@D)/$(f)
> > +	)
> > +endef
> 
> Being only 2 files to be installed I'd prefer to see 2 lines instead of
> foreach loop. Can you please change it accordingly?

I unrolled the loop in my v3 of the patches.

Thanks for reviewing and best regards,
Kilian
Thomas Petazzoni Feb. 11, 2024, 12:38 p.m. UTC | #4
On Sat, 10 Feb 2024 16:22:10 +0100
kilian.zinnecker@mail.de wrote:

> This is strange, maybe someone can have a look here: On ozlabs, there are a 
> lot of patches, which have the submitter "kilian.zinnecker--- via buildroot". 
> However, most of them are NOT from me. E.g., one from Yegor Yefremov [1] is 
> marked with submitter "kilian.zinnecker--- via buildroot" - However, I am 
> definitively not Yegor, and none of his patches is from me. There are even more 
> patches marked with "kilian.zinnecker--- via buildroot" [2], some of them even 
> from before I ever submitted my first patch (the Rock5B board support) to 
> buildroot. Does anyone have any idea what this is about, or can have a deeper 
> look at this? (The BeagleV-Ahead patches are from me.)

Yes, this is a known issue, caused by an interaction between the From:
rewriting by mailman (needed due to strict DMARC policies by some SMTP
servers) and a bug in patchwork.

Sadly, the patchwork instance we are using (ozlabs.org) is using an
ancient version of patchwork, which is no longer updated. We have asked
the kernel.org people if we could migrate to the patchwork.kernel.org,
but we still haven't heard back a definitive answer.

Best regards,

Thomas
Giulio Benetti Feb. 13, 2024, 6:19 p.m. UTC | #5
Hi Kilian,

On 11/02/24 13:15, kilian.zinnecker--- via buildroot wrote:
> Hello Giulio, all,
> 
> [--SNIP--]
>> can you please provide a separate patch to alphabetize?
> 
> I did so: https://gitlab.com/buildroot.org/buildroot/-/commit/
> 53fad3242d74b9fad11978429d6cc2879f783f4b
> 
> However, unfortunately Thomas de-alphabetized it again when he applied my
> RZBoard V2L patches: https://gitlab.com/buildroot.org/buildroot/-/commit/
> f003675119c9ca503afa19c04074e81c49538baf
> 
> I just send a v3 of the BeagleV-Ahead patches. After we get this series
> applied, I will then again send a single patch to alphabetize.

Please send the alphabetize patch along with the V4 patchset,

> 
> [--SNIP--]
>>> --- /dev/null
>>> +++ b/package/xuantie-bins/Config.in
>>> @@ -0,0 +1,6 @@
>>> +config BR2_PACKAGE_XUANTIE_BINS
>>> +	bool "xuantie-bins"
>>> +	depends on BR2_riscv
>>> +	help
>>> +	  This package provides binary blobs, needed for the
>>> +	  BeagleV-Ahead's SoC (TH1520).
>>
>> Can you please describe a bit what those binaries are meant for?
> 
> 
> I gave a brief description, but I don't know much about these. Maybe Robert
> can give even more information, if more is needed?

I see sufficient explanation in V3

> 
> [--SNIP--]
>>> +XUANTIE_BINS_FPGA_BIN_FILENAME = "bins/light_aon_fpga.bin"
>>> +XUANTIE_BINS_AUDIO_BIN_FILENAME = "bins/light_c906_audio.bin"
>>> +
>>> +define XUANTIE_BINS_INSTALL_IMAGES_CMDS
>>> +	$(foreach f, \
>>> +		$(XUANTIE_BINS_FPGA_BIN_FILENAME) \
>>> +		$(XUANTIE_BINS_AUDIO_BIN_FILENAME) \
>>> +		, \
>>> +		$(INSTALL) -D -m 0644 -t $(BINARIES_DIR) $(@D)/$(f)
>>> +	)
>>> +endef
>>
>> Being only 2 files to be installed I'd prefer to see 2 lines instead of
>> foreach loop. Can you please change it accordingly?
> 
> I unrolled the loop in my v3 of the patches.

Fine, see V3 comments.

Thank you!

Best regards
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index f504ca8d36..4d18bc49d4 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -1839,9 +1839,10 @@  N:	Kieran Bingham <kieran.bingham@ideasonboard.com>
 F:	package/libcamera/
 
 N:	Kilian Zinnecker <kilian.zinnecker@mail.de>
-F:	package/rockchip-rkbin/
-F:	configs/rock5b_defconfig
 F:	board/radxa/rock5b/
+F:	configs/rock5b_defconfig
+F:	package/rockchip-rkbin/
+F:	package/xuantie-bins/
 
 N:	Klaus Heinrich Kiwi <klaus@linux.vnet.ibm.com>
 F:	package/wqy-zenhei/
diff --git a/package/Config.in b/package/Config.in
index fcc09b07c4..3772e2ac81 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -653,6 +653,7 @@  endmenu
 	source "package/wipe/Config.in"
 	source "package/xorriso/Config.in"
 	source "package/xr819-xradio/Config.in"
+	source "package/xuantie-bins/Config.in"
 endmenu
 
 menu "Interpreter languages and scripting"
diff --git a/package/xuantie-bins/Config.in b/package/xuantie-bins/Config.in
new file mode 100644
index 0000000000..a04497ce6b
--- /dev/null
+++ b/package/xuantie-bins/Config.in
@@ -0,0 +1,6 @@ 
+config BR2_PACKAGE_XUANTIE_BINS
+	bool "xuantie-bins"
+	depends on BR2_riscv
+	help
+	  This package provides binary blobs, needed for the
+	  BeagleV-Ahead's SoC (TH1520).
diff --git a/package/xuantie-bins/xuantie-bins.hash b/package/xuantie-bins/xuantie-bins.hash
new file mode 100644
index 0000000000..4d1ec297c9
--- /dev/null
+++ b/package/xuantie-bins/xuantie-bins.hash
@@ -0,0 +1 @@ 
+sha256  608e9fec79823996004f65ba692a76d741307b0de23552d147ad1b567e7054dc  xuantie-bins-0a2e02bb53758cc12448d8670e65c854528a96b4-br1.tar.gz
diff --git a/package/xuantie-bins/xuantie-bins.mk b/package/xuantie-bins/xuantie-bins.mk
new file mode 100644
index 0000000000..3a5611cf36
--- /dev/null
+++ b/package/xuantie-bins/xuantie-bins.mk
@@ -0,0 +1,27 @@ 
+################################################################################
+#
+# xuantie-bins
+#
+################################################################################
+
+XUANTIE_BINS_VERSION = 0a2e02bb53758cc12448d8670e65c854528a96b4
+XUANTIE_BINS_SITE = https://github.com/beagleboard/xuantie-ubuntu.git
+XUANTIE_BINS_SITE_METHOD = git
+XUANTIE_BINS_LICENSE = PROPRIETARY
+
+XUANTIE_BINS_INSTALL_IMAGES = YES
+XUANTIE_BINS_INSTALL_TARGET = NO
+
+XUANTIE_BINS_FPGA_BIN_FILENAME = "bins/light_aon_fpga.bin"
+XUANTIE_BINS_AUDIO_BIN_FILENAME = "bins/light_c906_audio.bin"
+
+define XUANTIE_BINS_INSTALL_IMAGES_CMDS
+	$(foreach f, \
+		$(XUANTIE_BINS_FPGA_BIN_FILENAME) \
+		$(XUANTIE_BINS_AUDIO_BIN_FILENAME) \
+		, \
+		$(INSTALL) -D -m 0644 -t $(BINARIES_DIR) $(@D)/$(f)
+	)
+endef
+
+$(eval $(generic-package))