diff mbox series

[1/1] package/freeradius-server: fix redis handling

Message ID 20231104095448.641992-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] package/freeradius-server: fix redis handling | expand

Commit Message

Fabrice Fontaine Nov. 4, 2023, 9:54 a.m. UTC
redis handling is wrong since the addition of the package in commit
736c4c1655d93652a9a7e79235bbe726b3d46176. Indeed, freeradius-server
needs hiredis, not redis

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 .../freeradius-server/freeradius-server.mk    | 20 ++++++++++++-------
 1 file changed, 13 insertions(+), 7 deletions(-)

Comments

Thomas Petazzoni Nov. 4, 2023, 1:55 p.m. UTC | #1
Hello Fabrice,

On Sat,  4 Nov 2023 10:54:48 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> redis handling is wrong since the addition of the package in commit
> 736c4c1655d93652a9a7e79235bbe726b3d46176. Indeed, freeradius-server
> needs hiredis, not redis
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  .../freeradius-server/freeradius-server.mk    | 20 ++++++++++++-------
>  1 file changed, 13 insertions(+), 7 deletions(-)
> 
> diff --git a/package/freeradius-server/freeradius-server.mk b/package/freeradius-server/freeradius-server.mk
> index af3320eb44..1931c970e8 100644
> --- a/package/freeradius-server/freeradius-server.mk
> +++ b/package/freeradius-server/freeradius-server.mk
> @@ -71,6 +71,19 @@ FREERADIUS_SERVER_CONF_OPTS += \
>  	--without-rlm_ippool
>  endif
>  
> +ifeq ($(BR2_PACKAGE_HIREDIS),y)
> +FREERADIUS_SERVER_CONF_OPTS += \
> +	--with-rlm_cache_redis \

Are you sure about this option? I don't see it existing.

> -ifeq ($(BR2_PACKAGE_REDIS),y)
> -FREERADIUS_SERVER_CONF_OPTS += --with-rlm_redis --with-rlm_rediswho

And it wasn't used here.

Could you clarify this?

Is this a mixup with your other patch bumping freeradius-server?

Thanks,

Thomas
Fabrice Fontaine Nov. 4, 2023, 2:06 p.m. UTC | #2
Hello Thomas,

Le sam. 4 nov. 2023 à 14:55, Thomas Petazzoni <thomas.petazzoni@bootlin.com>
a écrit :

> Hello Fabrice,
>
> On Sat,  4 Nov 2023 10:54:48 +0100
> Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:
>
> > redis handling is wrong since the addition of the package in commit
> > 736c4c1655d93652a9a7e79235bbe726b3d46176. Indeed, freeradius-server
> > needs hiredis, not redis
> >
> > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> > ---
> >  .../freeradius-server/freeradius-server.mk    | 20 ++++++++++++-------
> >  1 file changed, 13 insertions(+), 7 deletions(-)
> >
> > diff --git a/package/freeradius-server/freeradius-server.mk
> b/package/freeradius-server/freeradius-server.mk
> > index af3320eb44..1931c970e8 100644
> > --- a/package/freeradius-server/freeradius-server.mk
> > +++ b/package/freeradius-server/freeradius-server.mk
> > @@ -71,6 +71,19 @@ FREERADIUS_SERVER_CONF_OPTS += \
> >       --without-rlm_ippool
> >  endif
> >
> > +ifeq ($(BR2_PACKAGE_HIREDIS),y)
> > +FREERADIUS_SERVER_CONF_OPTS += \
> > +     --with-rlm_cache_redis \
>
> Are you sure about this option? I don't see it existing.
>
> > -ifeq ($(BR2_PACKAGE_REDIS),y)
> > -FREERADIUS_SERVER_CONF_OPTS += --with-rlm_redis --with-rlm_rediswho
>
> And it wasn't used here.
>
> Could you clarify this?
>
> Is this a mixup with your other patch bumping freeradius-server?
>

Yes, good catch, I sent a v2.


>
> Thanks,
>
> Thomas
> --
> Thomas Petazzoni, co-owner and CEO, Bootlin
> Embedded Linux and Kernel engineering and training
> https://bootlin.com


Best Regards,

Fabrice
diff mbox series

Patch

diff --git a/package/freeradius-server/freeradius-server.mk b/package/freeradius-server/freeradius-server.mk
index af3320eb44..1931c970e8 100644
--- a/package/freeradius-server/freeradius-server.mk
+++ b/package/freeradius-server/freeradius-server.mk
@@ -71,6 +71,19 @@  FREERADIUS_SERVER_CONF_OPTS += \
 	--without-rlm_ippool
 endif
 
+ifeq ($(BR2_PACKAGE_HIREDIS),y)
+FREERADIUS_SERVER_CONF_OPTS += \
+	--with-rlm_cache_redis \
+	--with-rlm_redis \
+	--with-rlm_rediswho
+FREERADIUS_SERVER_DEPENDENCIES += hiredis
+else
+FREERADIUS_SERVER_CONF_OPTS += \
+	--without-rlm_cache_redis \
+	--without-rlm_redis \
+	--without-rlm_rediswho
+endif
+
 ifeq ($(BR2_PACKAGE_JSON_C)$(BR2_PACKAGE_LIBCURL),yy)
 FREERADIUS_SERVER_CONF_OPTS += --with-rlm_rest
 FREERADIUS_SERVER_DEPENDENCIES += json-c libcurl
@@ -150,13 +163,6 @@  else
 FREERADIUS_SERVER_CONF_OPTS += --without-readline
 endif
 
-ifeq ($(BR2_PACKAGE_REDIS),y)
-FREERADIUS_SERVER_CONF_OPTS += --with-rlm_redis --with-rlm_rediswho
-FREERADIUS_SERVER_DEPENDENCIES += redis
-else
-FREERADIUS_SERVER_CONF_OPTS += --without-rlm_redis --without-rlm_rediswho
-endif
-
 ifeq ($(BR2_PACKAGE_SQLITE),y)
 FREERADIUS_SERVER_CONF_OPTS += --with-rlm_sql_sqlite
 FREERADIUS_SERVER_DEPENDENCIES += sqlite